LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-28-2008, 06:04 AM   #1
chu2654
LQ Newbie
 
Registered: Nov 2006
Posts: 15

Rep: Reputation: 0
Setting up apache virtual host in redhat linux


After configuring httpd.conf, I restart httpd. But there is an error message:

[error] VirtualHost _default_:443 --mixing * ports and non_* ports with a NameVirtualHost address is not supported, proceeding with undefined results.

When browing, There is also error message.

Bad request!
Your browser sent a request that this server could not understand.


How can I solve this problem ?


Thanks.
 
Old 02-28-2008, 07:47 AM   #2
lord-fu
Member
 
Registered: Apr 2005
Location: Ohio
Distribution: Slackware && freeBSD
Posts: 676

Rep: Reputation: 30
Hi.

What do you have for

ServerName *
NameVirtualHost *

And then the
<VirtualHost *>
ServerName domain.com
</VirtualHost>


Most likely you just have a definition already in place and are mucking it up a bit by confusing apache.

hth
 
Old 02-28-2008, 07:13 PM   #3
chu2654
LQ Newbie
 
Registered: Nov 2006
Posts: 15

Original Poster
Rep: Reputation: 0
the httpd.conf configuration

Quote:
Originally Posted by lord-fu View Post
Hi.

What do you have for

ServerName *
NameVirtualHost *

And then the
<VirtualHost *>
ServerName domain.com
</VirtualHost>


Most likely you just have a definition already in place and are mucking it up a bit by confusing apache.

hth

httpd.conf

NameVirtualHost *

<VirtualHost *>
.......
ServerName www.redhat.com.tw
DocumentRoot /var/www
</VirtualHost>
<VirtualHost *>
.......
ServerName Virtual.redhat.com.tw
DocumentRoot /var/virtual
</VirtualHost>
 
Old 02-28-2008, 10:06 PM   #4
Lantzvillian
Member
 
Registered: Oct 2007
Location: BC, Canada
Distribution: Fedora, Debian
Posts: 210

Rep: Reputation: 41
I remember doing something similar with zimbra and apache since I was running a web server on the box. You can tell it somewhere in the httpd.conf file to listen on https port of 443 as well if that is what you are trying to do.
 
Old 02-28-2008, 10:20 PM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
You are using port 443, so I assume you're using SSL. It also looks like you're trying to use name based virtual hosts which won't work with SSL. Have a look on the Apache site here and here for more info.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache and virtual host voip_tech_2004 Red Hat 1 04-12-2006 11:36 AM
Apache 2 Virtual host eckertc1 Linux - Software 6 03-22-2005 09:58 PM
Setting up a virtual host zupidupi Linux - Networking 2 01-30-2005 08:58 AM
Setting up webalizer for virtual host hct224 Linux - Newbie 18 11-10-2004 03:31 PM
apache virtual host navinc Linux - Software 10 05-22-2003 12:16 PM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration