LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-16-2009, 08:49 AM   #1
silviap
LQ Newbie
 
Registered: Mar 2009
Distribution: CentOS, Fedora, Debian
Posts: 11

Rep: Reputation: 0
Postfix, Dovecot, MySQL users - issue with SASL


Hello,

I installed on a CentOS 5 machine Postfix and Dovecot with MySQL users and PostfixAdmin (I mainly followed this tutorial: http://wiki.dovecot.org/HowTo/Doveco...tfixAdminMySQL). This setup worked for me in the past, but now, I notice I can send emails out, but I cannot receive any.
In maillog I have:

postfix/smtpd: warning: SASL: Connect to private/auth failed: Connection refused
postfix/smtpd: fatal: no SASL authentication mechanisms
postfix/master: warning: process /usr/libexec/postfix/smtpd pid 7632 exit status 1
postfix/master: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

Any suggestions?
Thanks!
 
Old 06-16-2009, 04:24 PM   #2
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
Check your sasl/smtpd.conf, look for what you're permitting and blocking for recipient restrictions in your main.cf... It looks like your recipient restrictions may be broken.

Your outbound sending should be pretty different from inbound since you're allowing relaying to senders who are either on your local network or else who are authenticating (via SASL) so it doesn't mean to much that you can have email go one way but not the other. This really just means that Postfix is on and doing *something*

- Arch
 
Old 06-17-2009, 06:24 AM   #3
silviap
LQ Newbie
 
Registered: Mar 2009
Distribution: CentOS, Fedora, Debian
Posts: 11

Original Poster
Rep: Reputation: 0
Hello,

I noticed the server was updated recently (not by me). I restarted all the services, I even re-installed Postfix and Dovecot.

The /usr/lib/sasl2/smtpd.conf file had the following line:
pwcheck_method: saslauthd

The output for "saslauthd -v" is:
saslauthd 2.1.22
authentication mechanisms: getpwent kerberos5 pam rimap shadow ldap

I tried adding mech_list: plain login, but nothing happened.

Any suggestions?
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix/dovecot - sasl authentication works no more ddaas Linux - Server 6 05-15-2009 04:45 AM
Postfix/SASL/MySQL "SASL LOGIN authentication failed" Temujin_12 Linux - Server 8 10-04-2008 10:37 PM
postfix dovecot mysql permissions issue gnetcon Linux - Software 4 08-03-2006 11:05 AM


All times are GMT -5. The time now is 05:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration