LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 05-20-2012, 10:39 PM   #1
SarahGurung
Member
 
Registered: Jul 2011
Posts: 310

Rep: Reputation: Disabled
httpd not starting in centos webserver


well we have webserver runnung on centos 5.8 and today the httpd has stopped and i'm not able to start it..the error logs shows the following:

Code:
[Sun May 20 04:02:05 2012] [error] Unable to verify certificate 'Server-Cert'. A
dd "NSSEnforceValidCerts off" to nss.conf so the server can start until the prob
lem can be resolved.
[Sun May 20 04:02:05 2012] [error] SSL Library Error: -8181 Certificate has expi
red
Can anyone tell me what has happened and what should i be doing?it's really urgent..
 
Old 05-20-2012, 11:55 PM   #2
es0teric
Member
 
Registered: Apr 2007
Distribution: Ubuntu
Posts: 105

Rep: Reputation: 19
It sounds like the SSL certificate you're using to secure your website has expired. You may need to purchase another one, have it issued, and install it before you'll be able to have verified SSL again.

Since that will take a while, you can add the line it suggests to the httpd config file. That will tell httpd to ignore the error and start anyway (but the cert will still be expired).
 
Old 05-20-2012, 11:56 PM   #3
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Rep: Reputation: Disabled
it says cleayly that your server's cert has been expired,maybe you should creat a new cert for your server,or you could try to update the cert.
 
Old 05-20-2012, 11:56 PM   #4
SarahGurung
Member
 
Registered: Jul 2011
Posts: 310

Original Poster
Rep: Reputation: Disabled
so what should be done then?
 
Old 05-21-2012, 12:23 AM   #5
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Rep: Reputation: Disabled
if you are not sure you can first add "NSSEnforceValidCerts off" to nss.conf forcely start the httpd,if you have are sure having your problems done,you can comment the "NSSEnforceValidCerts off" in the nss.conf and try to start the http server.
 
Old 05-21-2012, 12:40 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,938

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Or, if you don't need mod_nss, you can rename /etc/httpd/conf.d/nss.conf to /etc/httpd/conf.d/nss.conf.bak, so apache does snot try to load it at startup.

Regards
 
Old 05-21-2012, 01:08 AM   #7
SarahGurung
Member
 
Registered: Jul 2011
Posts: 310

Original Poster
Rep: Reputation: Disabled
yes Mr.Bathory,i did that n it worked..

But just wondering what has nss.conf got to do with it?
 
Old 05-21-2012, 01:49 AM   #8
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Rep: Reputation: Disabled
it's for nss certification for your server,my suggestion is if you surely don't need it,you can do the mv,if not,better to fix it.
 
Old 05-21-2012, 01:57 AM   #9
SarahGurung
Member
 
Registered: Jul 2011
Posts: 310

Original Poster
Rep: Reputation: Disabled
ya i have moved it that's y it's working...

but i don't know how should i fix it..
 
Old 05-21-2012, 02:30 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,938

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Quote:
Originally Posted by SarahGurung View Post
ya i have moved it that's y it's working...

but i don't know how should i fix it..
If you don't use https, or if you have https working through mod_ssl, don't bother.
Otherwise, you might try the solution proposed here (remove and reinstall mod_nss)

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to start apache on CentOS Linux with error Starting httpd: Syntax error on lin pkumar2533 Linux - Newbie 9 08-26-2009 07:48 AM
Starting httpd: /etc/init.d/httpd: line 40: 10243 Segmentation fault LANG=C grep RMLinux Linux - Newbie 10 12-01-2008 10:17 PM
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax sethukpathi Linux - Networking 6 04-12-2008 11:26 AM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 07:24 AM
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 05:07 PM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration