LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-05-2006, 01:48 AM   #16
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53

Hi chort,

Quote:
Why is your Postfix trying to connect to it's own external IP address? Something is very wrong with your Postfix config.
Sorry, I'm not quite clear of your question.

Here is /etc/postfix/main.cf
Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server1.example.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = /etc/postfix/local-host-names
relayhost = satimis.homelinux.com
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command = 
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
B.R.
satimis
 
Old 12-05-2006, 02:40 AM   #17
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Code:
relayhost = satimis.homelinux.com
^^ That's wrong. It's trying to relay mail through itself. Just comment that line out.

Code:
myhostname = server1.example.com
^^ That should be satimis.homelinux.com

Code:
myorigin = /etc/mailname
mydestination = /etc/postfix/local-host-names
I've never used these settings with Postfix, but I suppose the first one should be your domain name, and the second should be a list of all your hostnames.
 
Old 12-05-2006, 05:21 AM   #18
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi chort,

Tks for your advice.

Edited /etc/postfix/main.cf
Code:
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#myhostname = server1.example.com
myhostname = satimis.freeddns.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#myorigin = /etc/mailname
#mydestination = /etc/postfix/local-host-names
#relayhost = satimis.homelinux.com
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command = 
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
# ping -c 3 satimis.freeddns.com
Code:
PING satimis.freeddns.com (220.246.239.125) 56(84) bytes of data.
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=1 ttl=64 time=0.028 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=2 ttl=64 time=0.034 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=3 ttl=64 time=0.034 ms

--- satimis.freeddns.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2008ms
rtt min/avg/max/mdev = 0.028/0.032/0.034/0.003 ms
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 satimis.freeddns.com ESMTP Postfix (Ubuntu)
ehlo satimis.freeddns.com
250-satimis.freeddns.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from: satimis@satimis.freeddnc.com
250 Ok
rcpt to: satimis@yahoo.com
250 Ok
data
354 End data with <CR><LF>.<CR><LF>

Subject: Test

This is a test
.
250 Ok: queued as 35A9D754060
quit
221 Bye
Connection closed by foreign host.
Still failed. Mail not received.

# cat /var/log/mail.log
Code:
....
....
Dec  5 18:37:19 ubuntu postfix/smtpd[6995]: 35A9D754060: client=localhost.localdomain[127.0.0.1]
Dec  5 18:37:57 ubuntu postfix/cleanup[7003]: 35A9D754060: message-id=<20061205103719.35A9D754060@satimis.freeddns.com>
Dec  5 18:37:57 ubuntu postfix/qmgr[6534]: 35A9D754060: from=<satimis@satimis.freeddnc.com>, size=409, nrcpt=1 (queue active)
Dec  5 18:38:29 ubuntu postfix/smtp[7004]: connect to d.mx.mail.yahoo.com[216.39.53.2]: Connection timed out (port 25)
Dec  5 18:38:52 ubuntu postfix/smtpd[6995]: disconnect from localhost.localdomain[127.0.0.1]
Dec  5 18:38:59 ubuntu postfix/smtp[7004]: connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out (port 25)
port 25 seems blocked by ISP including port 80

Is there any way to jump over this block? TIA

The dynamic domain registered with DYNDNS.ORG/COM seems not working. It is much easier to register a static free domain and update the IP on its website after the server up. IP address on server only changes on connection.


Edit: * * *

re your previous question on setting;
relayhost = satimis.homelinux.com

I followed following thread to set smarthost in order to get over ISP blocking on port 25
http://ubuntu.wordpress.com/2005/09/...st-in-postfix/

B.R.
satimis

Last edited by satimis; 12-05-2006 at 06:13 AM.
 
Old 12-05-2006, 07:51 AM   #19
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
This is how I observed it, but I don’t know if it has something to do with your issue of not
beeing able to send mails outside.

Since you are simply riding with freeddns.com as "satimis", your domain shall be
"satimis.freeddns.com" and thus:

myhostname = mail.satimis.freeddns.com # and not satimis.freeddns.com

With your previous myhostname, and since you never specified mydomain as I have seen on
your postconf output without an entry for mydomain, it would take by default "freeddns.com"
(minus the host part) that would create trouble when mails are coming in since it might be
routed instead to freeddns.com.

Also,

mydomain = satimis.freeddns.com

Also add this to your mynetworks to allow your internal network block to relay

mynetworks = 127.0.0/8, 192.168.0.0/24 # if this is your case

Also just for the sake of further testing:

myorigin = $myhostname
# your originating mails would be seen as user@mail.satimis.freeddns.com
# if you prefer user@satimis.freeddns.com, change it to $mydomain

mydestination = $myhostname, localhost.$mydomain, localhost
# this has nothing to do with sending out mails but on receiving mails

If I did not forget anything else, this is the most basic settings to test a newly installed
Postfix.

Then edit your /etc/hosts:

127.0.0.1 localhost.satimis.freeddns.com localhost
192.168.0.x mail.satimis.freeddns.com mail

Then modify your previously set hostname:

In Slackware it is stored in /etc/HOSTNAME and in OpenBSD in /etc/myname that would now
contain "mail.satimis.freeddns.com". Then reload your new network settings by running
your appropriate startup script.

# ping mail.satimis.freeddns.com
# postfix reload

I can ping you from my node:

@webmaster:~$ ping satimis.freeddns.com
PING satimis.freeddns.com (220.246.239.125) 56(84) bytes of data.
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=1 ttl=52 time=100 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=2 ttl=52 time=88.4 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=3 ttl=52 time=96.6 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=4 ttl=52 time=89.3 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=5 ttl=52 time=89.4 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=6 ttl=52 time=90.5 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=7 ttl=52 time=106 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=8 ttl=52 time=98.6 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=9 ttl=52 time=90.6 ms
64 bytes from n220246239125.netvigator.com (220.246.239.125): icmp_seq=10 ttl=52 time=106 ms

@webmaster:~$ host satimis.freeddns.com
satimis.freeddns.com has address 220.246.239.125
satimis.freeddns.com mail is handled by 10 satimis.freeddns.com.
satimis.freeddns.com mail is handled by 20 satimis.freeddns.com.
 
Old 12-05-2006, 10:01 AM   #20
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi gani,


Tks for your advice.

# cat /etc/postfix/main.cf
Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#myhostname = server1.example.com
myhostname = mail.satimis.freeddns.com
mydomain = satimis.freeddns.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#myorigin = /etc/mailname
#mydestination = /etc/postfix/local-host-names
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
#relayhost = satimis.homelinux.com
mynetworks = 127.0.0.0/8, 192.168.0.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command = 
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
mynetworks = 127.0.0.0/8 #is the original entry

# cat /etc/hosts
Code:
#127.0.0.1      localhost.localdomain   localhost
127.0.0.1      localhost.satimis.freeddns.com   localhost
#192.168.0.100  sever1.example.com   server1
192.168.0.100   mail.satimis.freeddns.com mail
#ubuntu

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
# cat /etc/hostname
Code:
#ubuntu
mail.satimis.freeddns.com
# /etc/init.d/networking restart
Code:
 * Reconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:13:d4:fe:da:87
Sending on   LPF/eth0/00:13:d4:fe:da:87
Sending on   Socket/fallback
Plugin rp-pppoe.so loaded.
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:13:d4:fe:da:87
Sending on   LPF/eth0/00:13:d4:fe:da:87
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 17
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
# pon dsl-provider
Code:
Plugin rp-pppoe.so loaded.
# ping -c 3 satimis.freeddns.com
Code:
PING satimis.freeddns.com (58.152.180.218) 56(84) bytes of data.
64 bytes from n058152180218.netvigator.com (58.152.180.218): icmp_seq=1 ttl=64 time=0.035 ms
64 bytes from n058152180218.netvigator.com (58.152.180.218): icmp_seq=2 ttl=64 time=0.033 ms
64 bytes from n058152180218.netvigator.com (58.152.180.218): icmp_seq=3 ttl=64 time=0.032 ms

--- satimis.freeddns.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2009ms
rtt min/avg/max/mdev = 0.032/0.033/0.035/0.004 ms
# ping -c 3 mail.satimis.freeddns.com
Code:
PING mail.satimis.freeddns.com (192.168.0.100) 56(84) bytes of data.

--- mail.satimis.freeddns.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2000ms
# host satimis.freeddns.com
Code:
satimis.freeddns.com has address 58.152.180.218
satimis.freeddns.com mail is handled by 10 satimis.freeddns.com.
satimis.freeddns.com mail is handled by 20 satimis.freeddns.com.
Failed

# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.satimis.freeddns.com.
Escape character is '^]'.
220 mail.satimis.freeddns.com ESMTP Postfix (Ubuntu)
ehlo satimis.freeddns.com
250-mail.satimis.freeddns.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from: satimis@satimis.freeddns.com
250 Ok
rcpt to: satimis@yahoo.com
250 Ok
data
354 End data with <CR><LF>.<CR><LF>

Subject: Test

This is a test
.
250 Ok: queued as 0F64F754050
quit
221 Bye
Connection closed by foreign host.
Mail never arrived.

# cat /var/log/mail.log
Code:
.......
Dec  5 23:33:35 ubuntu postfix/smtp[9581]: connect to imsmx04.netvigator.com[218.102.53.63]: Connection timed out (port 25)
Dec  5 23:33:35 ubuntu postfix/smtp[9583]: connect to imsmx09.netvigator.com[218.102.53.68]: Connection timed out (port 25)
Dec  5 23:33:35 ubuntu postfix/smtp[9586]: connect to imsmx09.netvigator.com[218.102.53.68]: Connection timed out (port 25)
Dec  5 23:33:36 ubuntu postfix/smtp[9585]: connect to c.mx.mail.yahoo.com[216.39.53.3]: Connection timed out (port 25)
Dec  5 23:33:36 ubuntu postfix/smtp[9587]: connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out (port 25)
Dec  5 23:33:36 ubuntu postfix/smtp[9584]: connect to e.mx.mail.yahoo.com[216.39.53.1]: Connection timed out (port 25)
Dec  5 23:33:36 ubuntu postfix/smtp[9588]: connect to c.mx.mail.yahoo.com[216.39.53.3]: Connection timed out (port 25)
Dec  5 23:33:37 ubuntu postfix/smtp[9589]: connect to g.mx.mail.yahoo.com[206.190.53.191]: Connection timed out (port 25)
Dec  5 23:33:51 ubuntu postfix/smtpd[9602]: connect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  5 23:34:05 ubuntu postfix/smtp[9581]: connect to imsmx09.netvigator.com[218.102.53.68]: Connection timed out (port 25)
Dec  5 23:34:05 ubuntu postfix/smtp[9583]: connect to imsmx02.netvigator.com[218.102.53.61]: Connection timed out (port 25)
Dec  5 23:34:05 ubuntu postfix/smtp[9586]: connect to imsmx06.netvigator.com[218.102.53.65]: Connection timed out (port 25)
Dec  5 23:34:06 ubuntu postfix/smtp[9585]: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out (port 25)
Dec  5 23:34:06 ubuntu postfix/smtp[9587]: connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out (port 25)
Dec  5 23:34:06 ubuntu postfix/smtp[9584]: connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out (port 25)
Dec  5 23:34:06 ubuntu postfix/smtp[9588]: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out (port 25)
Dec  5 23:34:07 ubuntu postfix/smtp[9589]: connect to c.mx.mail.yahoo.com[216.39.53.3]: Connection timed out (port 25)
Dec  5 23:34:35 ubuntu postfix/smtp[9581]: connect to imsmx07.netvigator.com[218.102.53.66]: Connection timed out (port 25)
Dec  5 23:34:35 ubuntu postfix/smtp[9583]: connect to imsmx10.netvigator.com[218.102.53.69]: Connection timed out (port 25)
Dec  5 23:34:35 ubuntu postfix/smtp[9586]: connect to imsmx07.netvigator.com[218.102.53.66]: Connection timed out (port 25)
Dec  5 23:34:36 ubuntu postfix/smtp[9585]: connect to g.mx.mail.yahoo.com[209.191.88.239]: Connection timed out (port 25)
Dec  5 23:34:36 ubuntu postfix/smtp[9587]: connect to d.mx.mail.yahoo.com[216.39.53.2]: Connection timed out (port 25)
Dec  5 23:34:36 ubuntu postfix/smtp[9584]: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out (port 25)
Dec  5 23:34:36 ubuntu postfix/smtp[9588]: connect to e.mx.mail.yahoo.com[216.39.53.1]: Connection timed out (port 25)
Dec  5 23:34:37 ubuntu postfix/smtp[9589]: connect to b.mx.mail.yahoo.com[66.196.97.250]: Connection timed out (port 25)
Dec  5 23:35:05 ubuntu postfix/smtp[9581]: connect to imsmx01.netvigator.com[218.102.53.60]: Connection timed out (port 25)
Dec  5 23:35:05 ubuntu postfix/smtp[9583]: connect to imsmx07.netvigator.com[218.102.53.66]: Connection timed out (port 25)
Dec  5 23:35:05 ubuntu postfix/smtp[9586]: connect to imsmx08.netvigator.com[218.102.53.67]: Connection timed out (port 25)
Dec  5 23:35:06 ubuntu postfix/smtp[9585]: connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out (port 25)
Dec  5 23:35:06 ubuntu postfix/smtp[9587]: connect to c.mx.mail.yahoo.com[216.39.53.3]: Connection timed out (port 25)
Dec  5 23:35:06 ubuntu postfix/smtp[9584]: connect to c.mx.mail.yahoo.com[68.142.237.182]: Connection timed out (port 25)
Dec  5 23:35:06 ubuntu postfix/smtp[9588]: connect to c.mx.mail.yahoo.com[68.142.237.182]: Connection timed out (port 25)
Dec  5 23:35:07 ubuntu postfix/smtp[9589]: connect to g.mx.mail.yahoo.com[209.191.88.239]: Connection timed out (port 25)
Dec  5 23:35:12 ubuntu postfix/smtpd[9602]: 0F64F754050: client=localhost.satimis.freeddns.com[127.0.0.1]
Dec  5 23:35:34 ubuntu postfix/cleanup[9607]: 0F64F754050: message-id=<20061205153512.0F64F754050@mail.satimis.freeddns.com>
Dec  5 23:35:34 ubuntu postfix/qmgr[9576]: 0F64F754050: from=<satimis@satimis.freeddns.com>, size=428, nrcpt=1 (queue active)
Dec  5 23:35:35 ubuntu postfix/smtp[9581]: connect to imsmx05.netvigator.com[218.102.53.64]: Connection timed out (port 25)
Dec  5 23:35:35 ubuntu postfix/smtp[9583]: connect to imsmx03.netvigator.com[218.102.53.62]: Connection timed out (port 25)
Dec  5 23:35:35 ubuntu postfix/smtp[9581]: 9A0B07540AD: to=<satimis@netvigator.com>, relay=none, delay=85180, status=deferred (connect to imsmx05.netvigator.com[218.102.53.64]: Connection timed out)
Dec  5 23:35:35 ubuntu postfix/smtp[9583]: BC62E75406A: to=<satimis@netvigator.com>, relay=none, delay=84887, status=deferred (connect to imsmx03.netvigator.com[218.102.53.62]: Connection timed out)
Dec  5 23:35:35 ubuntu postfix/smtp[9586]: connect to imsmx01.netvigator.com[218.102.53.60]: Connection timed out (port 25)
Dec  5 23:35:35 ubuntu postfix/smtp[9586]: 187B77540B0: to=<satimis@netvigator.com>, relay=none, delay=85015, status=deferred (connect to imsmx01.netvigator.com[218.102.53.60]: Connection timed out)
Dec  5 23:35:36 ubuntu postfix/smtp[9585]: connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out (port 25)
Dec  5 23:35:36 ubuntu postfix/smtp[9585]: BE120754099: to=<satimis@yahoo.com>, relay=none, delay=23867, status=deferred (connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out)
Dec  5 23:35:36 ubuntu postfix/smtp[9587]: connect to c.mx.mail.yahoo.com[68.142.237.182]: Connection timed out (port 25)
Dec  5 23:35:36 ubuntu postfix/smtp[9587]: 3D9807540A0: to=<satimis@yahoo.com>, relay=none, delay=342719, status=deferred (connect to c.mx.mail.yahoo.com[68.142.237.182]: Connection timed out)
Dec  5 23:35:36 ubuntu postfix/smtp[9584]: connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out (port 25)
Dec  5 23:35:36 ubuntu postfix/smtp[9584]: B7F957540A5: to=<satimis@yahoo.com>, relay=none, delay=85402, status=deferred (connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out)
Dec  5 23:35:36 ubuntu postfix/smtp[9588]: connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out (port 25)
Dec  5 23:35:36 ubuntu postfix/smtp[9588]: 35A9D754060: to=<satimis@yahoo.com>, relay=none, delay=17916, status=deferred (connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out)
Dec  5 23:35:37 ubuntu postfix/smtp[9589]: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out (port 25)
Dec  5 23:35:37 ubuntu postfix/smtp[9589]: 71BAB754065: to=<satimis@yahoo.com>, relay=none, delay=417, status=deferred (connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out)
Dec  5 23:35:37 ubuntu postfix/qmgr[9576]: C767A75404C: to=<satimis@yahoo.com>, relay=none, delay=1114, status=deferred (delivery temporarily suspended: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out)
Dec  5 23:35:37 ubuntu postfix/qmgr[9576]: 0F64F754050: to=<satimis@yahoo.com>, relay=none, delay=41, status=deferred (delivery temporarily suspended: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out)
Dec  5 23:36:54 ubuntu postfix/smtpd[9602]: disconnect from localhost.satimis.freeddns.com[127.0.0.1]
port 25 seems blocked.

Others noted with tks.


B.R.
satimis
 
Old 12-05-2006, 11:37 AM   #21
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Outbound port 25/tcp is blocked. If you're not blocking it with your own firewall, then your ISP is. BTW your outbound port 80/tcp is not blocked, else you could not surf the web. I think you meant inbound port 80/tcp (means you cannot host an http server on the default port).

The only ways to get around an ISP blocking outbound mail are a) relay the mail through your ISP's mail server (set relayhost to their mail server), or relay though someone else's server (who doesn't have an ISP that filters) and do so on a different port. I cannot recall if Postfix allows you to change the destination port for outbound smtp connections.
 
Old 12-05-2006, 08:33 PM   #22
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi chort,

Quote:
Outbound port 25/tcp is blocked. If you're not blocking it with your own firewall, then your ISP is......
Would it be postfix not properly configured?

# iptables -L
Code:
sudo: unable to lookup #ubuntu
mail.satimis.freeddns.com via gethostbyname()

Chain INPUT (policy ACCEPT)
target  prot opt source   destination

Chain FORWARD (policy ACCEPT)
target     prot opt source   destination
TCPMSS     tcp  --  anywhere  anywhere    tcp flags:SYN,RST/SYN tcpmss match
1400:1536 TCPMSS clamp to PMTU

Chain OUTPUT (policy ACCEPT)
target     prot opt source   destination
I used "ShieldsUp" on;
http://www.grc.com/default.htm

scanning ISP' port 25, 80 and 8080

port 25
Code:
Your computer at IP:
219.79.145.110 

Is now being examined:

Total elapsed testing time: 0.202 seconds

Solicited TCP Packets: RECEIVED (FAILED) — As detailed in the port report below, one or more of
your system's ports actively responded to our deliberate attempts to establish a connection. It
is generally possible to increase your system's security by hiding it from the probes of 
potentially hostile hackers. Please see the details presented by the specific port links below,
as well as the various resources on this site, and in our extremely helpful and active user community.

Unsolicited Packets: PASSED — No Internet packets of any sort were received from your system as
a side-effect of our attempts to elicit some response from any of the ports listed above. Some
questionable personal security systems expose their users by attempting to "counter-probe the 
prober", thus revealing themselves. But your system remained wisely silent. (Except for the fact
that not all of its ports are completely stealthed as shown below.)

Ping Reply: RECEIVED (FAILED) — Your system REPLIED to our Ping (ICMP Echo) requests, making it
visible on the Internet. Most personal firewalls can be configured to block, drop, and ignore
such ping requests in order to better hide systems from hackers. This is highly recommended
since "Ping" is among the oldest and most common methods used to locate systems prior to further exploitation.

Port	
Status 	Protocol and Application

25 	
OPEN! 	smtp

The ports you specified have been successfully probed. Their open, closed, or stealth status is
displayed in the table above. This Text Summary button provides a textual report that can be
printed, copied, and saved:
Text Summary
Code:
Results from probe of port: 25
    1 Ports Open
    0 Ports Closed
    0 Ports Stealth

    1 Ports Tested

THE PORT tested was found to be: OPEN.
TruStealth: FAILED - NOT all tested ports were STEALTH,
                   - NO unsolicited packets were received,
                   - A PING REPLY (ICMP Echo) WAS RECEIVED.
Scanned 80
Code:
Your computer at IP:
219.79.145.110 

Is now being examined:
Total elapsed testing time: 5.028 seconds

Solicited TCP Packets: PASSED — No TCP packets were received from your system as a direct result
of our attempts to elicit some response from any of the ports listed below — they are all either
fully stealthed or blocked by your ISP. However . . .

Unsolicited Packets: PASSED — (as above)

Ping Reply: RECEIVED (FAILED) — (as above)

Port	
Status 	Protocol and Application

80 	
Stealth 	http
World Wide Web HTTP

The ports you specified...(as above)
Text summary;
Code:
Results from probe of port: 80
    0 Ports Open
    0 Ports Closed
    1 Ports Stealth
    1 Ports Tested

THE PORT tested was found to be: STEALTH.

TruStealth: FAILED - ALL tested ports were STEALTH,
                   - NO unsolicited packets were received,
                   - A PING REPLY (ICMP Echo) WAS RECEIVED.
Scanned 8080
Code:
Your computer at IP:
219.79.145.110 

Is now being examined:
Total elapsed testing time: 0.202 seconds

Solicited TCP Packets: RECEIVED (FAILED) - (as above)

Unsolicited Packets: PASSED — (as above)

Ping Reply: RECEIVED (FAILED)- (as above)

Port	
Status 	Protocol and Application

8080 	
OPEN! 	http-alt
HTTP Alternate (see port 80 and port 81)

The ports ... (as above)
Text summary;
Code:
Results from probe of port: 8080
    1 Ports Open
    0 Ports Closed
    0 Ports Stealth

    1 Ports Tested

THE PORT tested was found to be: OPEN.

TruStealth: FAILED - NOT all tested ports were STEALTH,
                   - NO unsolicited packets were received,
                   - A PING REPLY (ICMP Echo) WAS RECEIVED.
My friend on his WinXP box can visit the homepage on my server with;
"satimis.freeddns.com:8080"

Performed further test;

1)
# cat /etc/postfix/main.cf
Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

append_dot_mydomain = no

#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

#myhostname = server1.example.com
myhostname = mail.satimis.freeddns.com
mydomain = satimis.freeddns.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#myorigin = /etc/mailname
#mydestination = /etc/postfix/local-host-names
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
#relayhost = satimis.homelinux.com
mynetworks = 127.0.0.0/8, 192.168.0.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command = 
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
# ping -c 3 satimis.freeddns.com
Code:
--- satimis.freeddns.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2013ms
rtt min/avg/max/mdev = 0.032/0.033/0.035/0.004 ms
# host satimis.freeddns.com
Code:
# host satimis.freeddns.com satimis.freeddns.com has address 219.79.145.110
satimis.freeddns.com mail is handled by 20 satimis.freeddns.com.
satimis.freeddns.com mail is handled by 10 satimis.freeddns.com.
# host mail.satimis.freeddns.com
Code:
mail.satimis.freeddns.com has address 208.67.219.40
Host mail.satimis.freeddns.com not found: 3(NXDOMAIN)
Host mail.satimis.freeddns.com not found: 3(NXDOMAIN)
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.satimis.freeddns.com.
Escape character is '^]'.
.....
This is a test
.
250 Ok: queued as AAA0A75406D
quit
221 Bye
# cat /var/log/mail.log
Code:
Dec  6 08:41:12 #ubuntu
mail postfix/smtpd[5977]: connect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:42:37 #ubuntu
mail postfix/smtpd[5977]: AAA0A75406D: client=localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:43:03 #ubuntu
mail postfix/cleanup[5980]: AAA0A75406D: message-id=<20061206004237.AAA0A75406D@mail.satimis.freeddns.com>
Dec  6 08:43:03 #ubuntu
mail postfix/qmgr[5562]: AAA0A75406D: from=<satimis@satimis.freeddns.com>, size=428, nrcpt=1 (queue active)
Dec  6 08:43:03 #ubuntu
mail postfix/qmgr[5562]: AAA0A75406D: to=<satimis@yahoo.com>, relay=none, delay=45, status=deferred (delivery temporarily suspended: connect to e.mx.mail.yahoo.com[216.39.53.1]: Connection timed out)
Dec  6 08:44:18 #ubuntu
mail postfix/smtpd[5977]: disconnect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:45:21 #ubuntu
mail postfix/cleanup[6007]: 9245F754072: message-id=<20061206004521.9245F754072@mail.satimis.freeddns.com>
Dec  6 08:45:21 #ubuntu
mail postfix/qmgr[5562]: 9245F754072: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 08:45:21 #ubuntu
mail postfix/local[6008]: fatal: gethostbyname: Success
Dec  6 08:45:22 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 08:45:22 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 08:45:22 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 08:45:22 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6008 exit status 1
Dec  6 08:45:22 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 08:45:22 #ubuntu
mail postfix/qmgr[5562]: 9245F754072: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 08:48:13 #ubuntu
mail postfix/cleanup[6020]: 9951F754075: message-id=<20061206004813.9951F754075@mail.satimis.freeddns.com>
Dec  6 08:48:13 #ubuntu
mail postfix/qmgr[5562]: 9951F754075: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 08:48:13 #ubuntu
mail postfix/local[6021]: fatal: gethostbyname: Success
Dec  6 08:48:14 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 08:48:14 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 08:48:14 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 08:48:14 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6021 exit status 1
Dec  6 08:48:14 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 08:48:14 #ubuntu
mail postfix/qmgr[5562]: 9951F754075: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1, status=deferred (delivery temporarily suspended: unknown mail transport error)
Failed. No indication on "(connection timed out) port 25"


2)
Quote:
The only ways to get around an ISP blocking outbound mail are a) relay the mail through your ISP's mail server (set relayhost to their mail server), or relay though someone else's server (who doesn't have an ISP that filters) and do so on a different port....
added "relayhost = mail.netvigator.com" on /etc/postfix/main.cf
(netvigator.com is ISP)

Repeated above step "telnet localhost 25"

# cat /var/log/mail.log
Code:
Dec  6 08:49:46 #ubuntu
mail postfix/qmgr[5562]: CD5DC754055: from=<root@mail.satimis.freeddns.com>, size=613, nrcpt=1 (queue active)
Dec  6 08:49:46 #ubuntu
mail postfix/local[6028]: fatal: gethostbyname: Success
Dec  6 08:49:47 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 08:49:47 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 08:49:47 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 08:49:47 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6028 exit status 1
Dec  6 08:49:47 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 08:49:47 #ubuntu
mail postfix/qmgr[5562]: CD5DC754055: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1687, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 08:51:07 #ubuntu
mail postfix/smtpd[6033]: connect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:52:10 #ubuntu
mail postfix/smtpd[6033]: 5DB06754079: client=localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:52:44 #ubuntu
mail postfix/cleanup[6035]: 5DB06754079: message-id=<20061206005210.5DB06754079@mail.satimis.freeddns.com>
Dec  6 08:52:44 #ubuntu
mail postfix/qmgr[5562]: 5DB06754079: from=<satimis@satimis.freeddns.com>, size=428, nrcpt=1 (queue active)
Dec  6 08:53:07 #ubuntu
mail postfix/cleanup[6035]: 0B61D75407B: message-id=<20061206005307.0B61D75407B@mail.satimis.freeddns.com>
Dec  6 08:53:07 #ubuntu
mail postfix/qmgr[5562]: 0B61D75407B: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 08:53:07 #ubuntu
mail postfix/local[6060]: fatal: gethostbyname: Success
Dec  6 08:53:08 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 08:53:08 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 08:53:08 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 08:53:08 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6060 exit status 1
Dec  6 08:53:08 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 08:53:08 #ubuntu
mail postfix/qmgr[5562]: 0B61D75407B: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 08:53:17 #ubuntu
mail postfix/smtp[6036]: connect to g.mx.mail.yahoo.com[206.190.53.191]: Connection timed out (port 25)
Dec  6 08:53:47 #ubuntu
mail postfix/smtp[6036]: connect to e.mx.mail.yahoo.com[216.39.53.1]: Connection timed out (port 25)
Dec  6 08:54:17 #ubuntu
mail postfix/smtp[6036]: connect to b.mx.mail.yahoo.com[66.196.97.250]: Connection timed out (port 25)
Dec  6 08:54:20 #ubuntu
mail postfix/smtpd[6033]: disconnect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  6 08:54:26 #ubuntu
mail postfix/cleanup[6035]: C9FF575407D: message-id=<20061206005426.C9FF575407D@mail.satimis.freeddns.com>
Dec  6 08:54:26 #ubuntu
mail postfix/qmgr[5562]: C9FF575407D: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 08:54:27 #ubuntu
mail postfix/local[6069]: fatal: gethostbyname: Success
Dec  6 08:54:28 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 08:54:28 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 08:54:28 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 08:54:28 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6069 exit status 1
Dec  6 08:54:28 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 08:54:28 #ubuntu
mail postfix/qmgr[5562]: C9FF575407D: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=2, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 08:54:47 #ubuntu
mail postfix/smtp[6036]: connect to g.mx.mail.yahoo.com[209.191.88.239]: Connection timed out (port 25)
Dec  6 08:55:17 #ubuntu
mail postfix/smtp[6036]: connect to f.mx.mail.yahoo.com[209.191.88.247]: Connection timed out (port 25)
Dec  6 08:55:47 #ubuntu
mail postfix/smtp[6036]: connect to c.mx.mail.yahoo.com[216.39.53.3]: Connection timed out (port 25)
Dec  6 08:56:17 #ubuntu
mail postfix/smtp[6036]: connect to a.mx.mail.yahoo.com[209.191.118.103]: Connection timed out (port 25)
Dec  6 08:56:47 #ubuntu
mail postfix/smtp[6036]: connect to f.mx.mail.yahoo.com[68.142.202.247]: Connection timed out (port 25)
Dec  6 08:57:17 #ubuntu
mail postfix/smtp[6036]: connect to c.mx.mail.yahoo.com[68.142.237.182]: Connection timed out (port 25)
Dec  6 08:57:47 #ubuntu
mail postfix/smtp[6036]: connect to d.mx.mail.yahoo.com[216.39.53.2]: Connection timed out (port 25)
Dec  6 08:57:47 #ubuntu
mail postfix/smtp[6036]: 5DB06754079: to=<satimis@yahoo.com>, relay=none, delay=357, status=deferred (connect to d.mx.mail.yahoo.com[216.39.53.2]: Connection timed out)
Dec  6 09:06:26 #ubuntu
mail postfix/qmgr[5562]: 9245F754072: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 09:06:26 #ubuntu
mail postfix/qmgr[5562]: 9951F754075: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 09:06:26 #ubuntu
mail postfix/qmgr[5562]: 5BD12754078: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 09:06:26 #ubuntu
mail postfix/qmgr[5562]: AAA0A75406D: from=<satimis@satimis.freeddns.com>, size=428, nrcpt=1 (queue active)
Dec  6 09:06:27 #ubuntu
mail postfix/local[6093]: fatal: gethostbyname: Success
Dec  6 09:06:27 #ubuntu
mail postfix/local[6091]: fatal: gethostbyname: Success
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 09:06:28 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6093 exit status 1
Dec  6 09:06:28 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: 9951F754075: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1095, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: 5BD12754078: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1076, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 09:06:28 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6091 exit status 1
Dec  6 09:06:28 #ubuntu
mail postfix/qmgr[5562]: 9245F754072: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1267, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 09:06:34 #ubuntu
mail postfix/smtp[6092]: AAA0A75406D: to=<satimis@yahoo.com>, relay=mail.netvigator.com[218.102.48.213], delay=1456, status=bounced (host mail.netvigator.com[218.102.48.213] said: 554 Emails sent by non-NETVIGATOR domains cannot be processed. Please visit http://cs.netvigator.com/smtp (English) / http://cs.netvigator.com/smtpc (Chinese) for details (in reply to end of DATA command))
Dec  6 09:06:34 #ubuntu
mail postfix/cleanup[6099]: 9A460754080: message-id=<20061206010634.9A460754080@mail.satimis.freeddns.com>
Dec  6 09:06:34 #ubuntu
mail postfix/qmgr[5562]: 9A460754080: from=<>, size=2661, nrcpt=1 (queue active)
Dec  6 09:06:34 #ubuntu
mail postfix/qmgr[5562]: AAA0A75406D: removed
Dec  6 09:06:37 #ubuntu
mail postfix/smtp[6092]: 9A460754080: to=<satimis@satimis.freeddns.com>, relay=mail.netvigator.com[218.102.48.214], delay=3, status=bounced (host mail.netvigator.com[218.102.48.214] said: 550 relaying mail to satimis.freeddns.com is not allowed (in reply to RCPT TO command))
Dec  6 09:06:37 #ubuntu
mail postfix/qmgr[5562]: 9A460754080: removed
Dec  6 09:23:06 #ubuntu
mail postfix/qmgr[5562]: 5DB06754079: from=<satimis@satimis.freeddns.com>, size=428, nrcpt=1 (queue active)
.....
mail postfix/qmgr[5562]: C9FF575407D: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 09:23:07 #ubuntu
mail postfix/local[6134]: fatal: gethostbyname: Success
Dec  6 09:23:07 #ubuntu
mail postfix/local[6135]: fatal: gethostbyname: Success
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 09:23:08 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6134 exit status 1
Dec  6 09:23:08 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: 0B61D75407B: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=1801, status=deferred (delivery temporarily suspended: unknown mail transport error)
....
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 09:23:08 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6135 exit status 1
Dec  6 09:23:08 #ubuntu
mail postfix/qmgr[5562]: CD5DC754055: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=3688, status=deferred (delivery temporarily suspended: unknown mail transport error)
Dec  6 09:23:14 #ubuntu
mail postfix/smtp[6133]: 5DB06754079: to=<satimis@yahoo.com>, relay=mail.netvigator.com[218.102.23.141], delay=1884, status=bounced (host mail.netvigator.com[218.102.23.141] said: 554 Emails sent by non-NETVIGATOR domains cannot be processed. Please visit http://cs.netvigator.com/smtp (English) / http://cs.netvigator.com/smtpc (Chinese) for details (in reply to end of DATA command))
Dec  6 09:23:14 #ubuntu
mail postfix/cleanup[6142]: 34CF875407C: message-id=<20061206012314.34CF875407C@mail.satimis.freeddns.com>
Dec  6 09:23:14 #ubuntu
mail postfix/qmgr[5562]: 34CF875407C: from=<>, size=2661, nrcpt=1 (queue active)
Dec  6 09:23:14 #ubuntu
mail postfix/qmgr[5562]: 5DB06754079: removed
Dec  6 09:23:20 #ubuntu
mail postfix/smtp[6133]: 34CF875407C: to=<satimis@satimis.freeddns.com>, relay=mail.netvigator.com[218.102.23.140], delay=6, status=bounced (host mail.netvigator.com[218.102.23.140] said: 550 relaying mail to satimis.freeddns.com is not allowed (in reply to RCPT TO command))
Dec  6 09:23:20 #ubuntu
mail postfix/qmgr[5562]: 34CF875407C: removed
Dec  6 09:36:57 #ubuntu
mail postfix/cleanup[6179]: E816475407A: message-id=<20061206013657.E816475407A@mail.satimis.freeddns.com>
Dec  6 09:36:57 #ubuntu
mail postfix/qmgr[5562]: E816475407A: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  6 09:36:58 #ubuntu
mail postfix/local[6181]: fatal: gethostbyname: Success
Dec  6 09:36:59 #ubuntu
mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  6 09:36:59 #ubuntu
mail postfix/qmgr[5562]: warning: private/local socket: malformed response
Dec  6 09:36:59 #ubuntu
mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 09:36:59 #ubuntu
mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6181 exit status 1
Dec  6 09:36:59 #ubuntu
mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 09:36:59 #ubuntu
mail postfix/qmgr[5562]: E816475407A: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=2, status=deferred (delivery temporarily suspended: unknown mail transport error)
Now indicating "connect to e.mx.mail.yahoo.com[216.39.53.1]: Connection timed out (port 25)"

Tks

B.R.
satimis
 
Old 12-05-2006, 11:20 PM   #23
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
> # iptables -L[code]
> sudo: unable to lookup #ubuntu
> mail.satimis.freeddns.com via gethostbyname()

Check your /etc/resolv.conf. It should have a line like this on top to consult
first /etc/hosts before BIND if there is.

lookup file bind

> mail postfix/local[6008]: fatal: gethostbyname: Success
> mail postfix/qmgr[5562]: warning: premature end-of-input on private/local socket while reading input attribute name
> mail postfix/qmgr[5562]: warning: private/local socket: malformed response
> mail postfix/qmgr[5562]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
> mail postfix/master[5064]: warning: process /usr/lib/postfix/local pid 6008 exit status 1
> mail postfix/master[5064]: warning: /usr/lib/postfix/local: bad command startup -- throttling

The above indicates something is wrong with your postfix configuration.

> added "relayhost = mail.netvigator.com" on /etc/postfix/main.cf
> (netvigator.com is ISP)

relayhost = [mail.netvigator.com]

Here is my master.cf for you to compare:

Code:
smtp      inet  n       -       n       -       -       smtpd
#submission inet n      -       n       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission   inet    n       -       n       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       n       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
scache    unix  -       -       n       -       1       scache
Your are still reachable from my place.

@mxwall:/etc/postfix$ ping satimis.freeddns.com
PING satimis.freeddns.com (219.79.145.110) 56(84) bytes of data.
64 bytes from n219079145110.netvigator.com (219.79.145.110): icmp_seq=1 ttl=118 time=101 ms
64 bytes from n219079145110.netvigator.com (219.79.145.110): icmp_seq=2 ttl=118 time=103 ms
64 bytes from n219079145110.netvigator.com (219.79.145.110): icmp_seq=3 ttl=118 time=96.7 ms

Just for the sake of clarification, did you already executed "newaliases" and
postmap /etc/postfix/virtusertable? Though postfix should complain about this
right the time you started her.

Open a new ssh console and tail -f /var/log/mail.log while you are reloading postfix
and telneting/quitting to/from it to see if an error will occur few seconds after. If so,
this indicates misconfiguration and postfix is specifically verbose about an error to give
hints to administrators working on problems.
 
Old 12-06-2006, 05:39 AM   #24
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi gani,

Tks for your advice.

I found it difficult getting on a page of this server in these 2 days. I noticed a mail advising a response on this thread arrived, several hours before. But I could not get onto this server.

Quote:
Check your /etc/resolv.conf. It should have a line like this on top to consult
first /etc/hosts before BIND if there is.

lookup file bind
$ cat /etc/resolv.conf
Code:
search com
nameserver 208.67.222.222
nameserver 208.67.220.220
#nameserver 204.11.126.131
#nameserver 64.125.134.133
#nameserver 64.125.134.132
#nameserver 208.185.179.218
Shall add that line? Tks

Quote:
> added "relayhost = mail.netvigator.com" on /etc/postfix/main.cf
> (netvigator.com is ISP)

relayhost = [mail.netvigator.com]
Noted with tks.

Quote:
Here is my master.cf for you to compare:
......
Your main.cf differs from mine. Maybe you are running FreeBSD and I'm running "Ubuntu"

Quote:
Just for the sake of clarification, did you already executed "newaliases"..
Sorry I can't recall. Neither I found it on the notes taken download during installing this LAMP-server. What command to execute "newaliases"?

[quote]
.... and
postmap /etc/postfix/virtusertable? Though postfix should complain about this
right the time you started her.[/code]
On the notes I found;
Code:
$ sudo postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
$ sudo postmap /etc/postfix/virtusertable
have been run.

Quote:
Open a new ssh console and tail -f /var/log/mail.log while you are reloading postfix
and telneting/quitting to/from it to see if an error will occur few seconds after. If so,
this indicates misconfiguration and postfix is specifically verbose about an error to give
hints to administrators working on problems.
Whether you meant;
# cp /var/log/mail.log /var/log/mail.log.1

and wipe out the complete content of the file.

Then run;
# /etc/init.d/postfix restart

and

# telnet localhost 25
etc.

Tks

Remark:
mail.err is an empty file


B.R.
satimis
 
Old 12-06-2006, 06:42 AM   #25
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
>> search com
>> nameserver 208.67.222.222
>> nameserver 208.67.220.220


That's why you're having an error from gethostbyname() function call and this could be contributing for
postfix since postfix will refuse to work properly if she can't reoslve her own hostname.

This what your postfix is telling us that might be related to this:

mail postfix/local[6008]: fatal: gethostbyname: Success

>> Shall add that line? Tks

Without second thought, YES!
Remember that mail.satimis.freeddns.com is an internal host that we defined through /etc/hosts file to be
able for your system to resolve it properly. So 'file' is the first that postfix and your system will consult
when resolving hosts before it will consult through BIND server if you have. And 'file' is /etc/hosts and
and definitely your ISP's nameservers can't answer you for that.

/etc/resolv.conf

lookup file bind
nameserver 208.67.222.222
nameserver 208.67.220.220
search urns.yourdomain.com ns.otherdomain.com # if you have your own NS so usually this is not required

>> Your main.cf differs from mine. Maybe you are running FreeBSD and I'm running "Ubuntu"

Maybe your talking about master.cf?
NO. Just BSD-like, Slackware 10.2. Our only difference is that I've compiled everything from source.

Try to modify your master.cf accordingly one step at time while testing. That is what Postfix offers by
default that works without changing anything unless your adding other staff like amavisd-new, dkim-milter,
maildrop, etc, or chrooting postfix processes.

>> What command to execute "newaliases"?

$ which newaliases

Usually it is in /usr/sbin. So,

$ sudo newaliases

>> Whether you meant;
>> # cp /var/log/mail.log /var/log/mail.log.1

>> and wipe out the complete content of the file.

>> Then run;
>> # /etc/init.d/postfix restart

$ sudo tail -f /var/log/mail.log

Will immediately display the last 10 lines and show you interactively what's happening.

>> I found it difficult getting on a page of this server in these 2 days.

The same here starting last night.
 
Old 12-06-2006, 09:05 AM   #26
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
HI gani,

Quote:
That's why you're having an error from gethostbyname() function call and this could be contributing for
postfix since postfix will refuse to work properly if she can't reoslve her own hostname.

This what your postfix is telling us that might be related to this:

mail postfix/local[6008]: fatal: gethostbyname: Success

>> Shall add that line? Tks

Without second thought, YES!
Remember that mail.satimis.freeddns.com is an internal host that we defined through /etc/hosts file to be
able for your system to resolve it properly. So 'file' is the first that postfix and your system will consult
when resolving hosts before it will consult through BIND server if you have. And 'file' is /etc/hosts and
and definitely your ISP's nameservers can't answer you for that.

/etc/resolv.conf

lookup file bind
nameserver 208.67.222.222
nameserver 208.67.220.220
search urns.yourdomain.com ns.otherdomain.com # if you have your own NS so usually this is not required
# cat /etc/resolv.conf
Code:
lookup file bind
nameserver 208.67.222.222
nameserver 208.67.220.220
$ cat /etc/postfix/main.cf
Code:
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
myhostname = mail.satimis.freeddns.com
mydomain = satimis.freeddns.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
relayhost = [mail.netvigator.com]
mynetworks = 127.0.0.0/8, 192.168.0.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command =
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
Quote:
Try to modify your master.cf accordingly one step at time while testing. That is what Postfix offers by
default that works without changing anything unless your adding other staff like amavisd-new, dkim-milter,
maildrop, etc, or chrooting postfix processes.
Sorry, I can't follow. Pls explain in more detail.

Quote:
>> What command to execute "newaliases"?

$ which newaliases
Usually it is in /usr/sbin. So,
$ sudo newaliases
$ sudo newaliases
No printout

$ sudo /etc/init.d/postfix restart
Code:
sudo: unable to lookup ubuntu
mail.satimis.freeddns.com via gethostbyname()
Password:
 * Stopping Postfix Mail Transport Agent postfix            [ ok ]
 * Starting Postfix Mail Transport Agent postfix            [ ok ]
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.satimis.freeddns.com.
Escape character is '^]'.
220 mail.satimis.freeddns.com ESMTP Postfix (Ubuntu)
ehlo satimis.freeddns.com
250-mail.satimis.freeddns.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from: satimis@satimis.freeddns.com
250 Ok
rcpt to: satimis@yahoo.com
250 Ok
data
354 End data with <CR><LF>.<CR><LF>

Subject: Test

This is a test
.
250 Ok: queued as 5FA65754095
quit
221 Bye
Connection closed by foreign host.
Still failed. No mail received

$ sudo tail -f /var/log/mail.log
sudo: unable to lookup ubuntu
mail.satimis.freeddns.com via gethostbyname()
Password:
Code:
Dec  6 22:57:39 ubuntu
mail postfix/qmgr[6454]: warning: private/local socket: malformed response
Dec  6 22:57:39 ubuntu
mail postfix/qmgr[6454]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  6 22:57:39 ubuntu
mail postfix/master[6452]: warning: process /usr/lib/postfix/local pid 6502 exit status 1
Dec  6 22:57:39 ubuntu
mail postfix/master[6452]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  6 22:57:39 ubuntu
mail postfix/qmgr[6454]: F3F5E75409A: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=2, status=deferred (delivery temporarily suspended: unknown mail transport error)
$ cat /etc/hosts
Code:
#127.0.0.1      localhost.localdomain   localhost
127.0.0.1      localhost.satimis.freeddns.com   localhost
192.168.0.100   mail.satimis.freeddns.com mail
ubuntu
#mail.satimis.freeddns.com

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
$ cat /etc/hostname
Code:
mail.satimis.freeddns.com
ubuntu
Other noted with tks.


B.R.
satimis
 
Old 12-06-2006, 10:08 AM   #27
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Delete "ubuntu" from /etc/hostname.
Code:
# echo "mail.satimis.freeddns.com" > /etc/hostname"
Also, open /etc/hosts and remove the line that says "ubuntu".

That will most likely fix your transport problem. Also, post the contents of your master.cf in addition to main.cf.

The ShieldsUp scan was meaningless. Your ISP is blocking outbound mail, what you scanned for was inbound connections.

Last edited by chort; 12-06-2006 at 10:09 AM.
 
Old 12-06-2006, 10:55 AM   #28
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi chort,

Quote:
Delete "ubuntu" from /etc/hostname.
# cat /etc/hostname
Code:
mail.satimis.freeddns.com
Remark:
after adding this line here starting Xfce4 desktop complained;
Code:
Could not load up Internet address for mail.satimis.freeddns.com.
This will prevent Xfce from operating correctly.
It may be possible to correct the problem by adding mail.satimis.freeddns.com
to the file /etc/hosts on your system"
# cat /etc/hosts
Code:
127.0.0.1      localhost.satimis.freeddns.com   localhost
192.168.0.100   mail.satimis.freeddns.com mail

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Quote:
Code:
# echo "mail.satimis.freeddns.com" > /etc/hostname"
# echo "mail.satimis.freeddns.com" > /etc/hostname"

# /etc/init.d/networking restart
Code:
 * Reconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:13:d4:fe:da:87
Sending on   LPF/eth0/00:13:d4:fe:da:87
Sending on   Socket/fallback
Plugin rp-pppoe.so loaded.
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:13:d4:fe:da:87
Sending on   LPF/eth0/00:13:d4:fe:da:87
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 16
No DHCPOFFERS received.
No working leases in persistent database - sleeping.    [ ok ]
# pon dsl-provider
Code:
Plugin rp-pppoe.so loaded.
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.satimis.freeddns.com.
Escape character is '^]'.
220 mail.satimis.freeddns.com ESMTP Postfix (Ubuntu)
ehlo satimis.freeddns.com
250-mail.satimis.freeddns.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from: satimis@satimis.freeddns.com
250 Ok
rcpt to: satimis@yahoo.com
250 Ok
data
354 End data with <CR><LF>.<CR><LF>

Subject: Test

This is test
.
250 Ok: queued as 7B41B7540A9
quit
221 Bye
Connection closed by foreign host.
Mail not received. Still failed.

$ sudo tail -f /var/log/mail.log
Code:
sudo: unable to lookup mail.satimis.freeddns.com
#ubuntu via gethostbyname()
Dec  7 00:41:25 mail postfix/smtpd[6482]: 7B41B7540A9: client=localhost.satimis.freeddns.com[127.0.0.1]
Dec  7 00:41:44 mail postfix/cleanup[6474]: 7B41B7540A9: message-id=<20061206164125.7B41B7540A9@mail.satimis.freeddns.com>
Dec  7 00:41:44 mail postfix/qmgr[6440]: 7B41B7540A9: from=<satimis@satimis.freeddns.com>, size=426, nrcpt=1 (queue active)
Dec  7 00:41:50 mail postfix/smtpd[6482]: disconnect from localhost.satimis.freeddns.com[127.0.0.1]
Dec  7 00:41:52 mail postfix/smtp[6485]: 7B41B7540A9: to=<satimis@yahoo.com>, relay=mail.netvigator.com[218.102.23.140], delay=49, status=bounced (host mail.netvigator.com[218.102.23.140] said: 554 Emails sent by non-NETVIGATOR domains cannot be processed. Please visit http://cs.netvigator.com/smtp (English) / http://cs.netvigator.com/smtpc (Chinese) for details (in reply to end of DATA command))
Dec  7 00:41:52 mail postfix/cleanup[6474]: 1CC9C7540AD: message-id=<20061206164152.1CC9C7540AD@mail.satimis.freeddns.com>
Dec  7 00:41:52 mail postfix/qmgr[6440]: 1CC9C7540AD: from=<>, size=2659, nrcpt=1 (queue active)
Dec  7 00:41:52 mail postfix/qmgr[6440]: 7B41B7540A9: removed
Dec  7 00:41:54 mail postfix/smtp[6485]: 1CC9C7540AD: to=<satimis@satimis.freeddns.com>, relay=mail.netvigator.com[218.102.48.214], delay=2, status=bounced (host mail.netvigator.com[218.102.48.214] said: 550 relaying mail to satimis.freeddns.com is not allowed (in reply to RCPT TO command))
Dec  7 00:41:54 mail postfix/qmgr[6440]: 1CC9C7540AD: removed
Dec  7 00:42:05 mail postfix/pickup[6439]: EF5207540AB: uid=1000 from=<satimis>
Dec  7 00:42:05 mail postfix/cleanup[6474]: EF5207540AB: message-id=<20061206164204.EF5207540AB@mail.satimis.freeddns.com>
Dec  7 00:42:05 mail postfix/qmgr[6440]: EF5207540AB: from=<satimis@mail.satimis.freeddns.com>, size=536, nrcpt=1 (queue active)
Dec  7 00:42:05 mail postfix/local[6491]: fatal: gethostbyname: Success
Dec  7 00:42:06 mail postfix/qmgr[6440]: warning: premature end-of-input on private/local socket while reading input attribute name
Dec  7 00:42:06 mail postfix/qmgr[6440]: warning: private/local socket: malformed response
Dec  7 00:42:06 mail postfix/qmgr[6440]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
Dec  7 00:42:06 mail postfix/master[5054]: warning: process /usr/lib/postfix/local pid 6491 exit status 1
Dec  7 00:42:06 mail postfix/master[5054]: warning: /usr/lib/postfix/local: bad command startup -- throttling
Dec  7 00:42:06 mail postfix/qmgr[6440]: EF5207540AB: to=<root@mail.satimis.freeddns.com>, orig_to=<root>, relay=none, delay=2, status=deferred (delivery temporarily suspended: unknown mail transport error)
Quote:
Also, post the contents of your master.cf in addition to main.cf.
# cat /etc/postfix/master.cf
Code:
#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#submission inet n      -       -       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n      -       -       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)#
# Other external delivery methods.
#
Others noted with tks.


B.R.
satimis
 
Old 12-06-2006, 11:31 AM   #29
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Your ISP's server requires authentication. Here's how to set it up.
Code:
/etc/postfix/main.cf:
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_type = cyrus

/etc/postfix/sasl_passwd:
    [mail.netvigator.com]            username:password
 
Old 12-06-2006, 08:17 PM   #30
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,400

Original Poster
Rep: Reputation: 53
Hi chort,

Quote:
Your ISP's server requires authentication. Here's how to set it up.
Code:
/etc/postfix/main.cf:
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_type = cyrus

/etc/postfix/sasl_passwd:
    [mail.netvigator.com]            username:password
$ cat /etc/postfix/main.cf
Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mail.satimis.freeddns.com
mydomain = satimis.freeddns.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost
relayhost = [mail.netvigator.com]
mynetworks = 127.0.0.0/8, 192.168.0.0/24
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_type = cyrus

smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
mailbox_command =
home_mailbox = Maildir/
virtual_maps = hash:/etc/postfix/virtusertable
# touch /etc/postfix/sasl_passwd
Edited the file
# cat /etc/postfix/sasl_passwd
Code:
[mail.netvigator.com]            satimis:xxxxx
# updatedb
# /etc/init.d/postfix restart
Code:
 * Stopping Postfix Mail Transport Agent postfix                         [ ok ]
 * Starting Postfix Mail Transport Agent postfix                         [ ok ]
# telnet localhost 25
Code:
Trying 127.0.0.1...
Connected to localhost.satimis.freeddns.com.
Escape character is '^]'.
220 mail.satimis.freeddns.com ESMTP Postfix (Ubuntu)
ehlo satimis.freeddns.com
250-mail.satimis.freeddns.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from: satimis@satimis.freeddns.com
250 Ok
rcpt to: satimis@yahoo.com
250 Ok
data
354 End data with <CR><LF>.<CR><LF>

Subject: Test

This is a test
.
250 Ok: queued as 87065754052
quit
221 Bye
Connection closed by foreign host.
# tail -f /var/log/mail.log
Code:
Dec  7 10:09:24 mail postfix/master[6171]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Dec  7 10:10:24 mail postfix/smtp[6205]: fatal: open database /etc/postfix/sasl_passwd.db: No such file or directory
Dec  7 10:10:25 mail postfix/master[6171]: warning: process /usr/lib/postfix/smtp pid 6205 exit status 1
Dec  7 10:10:25 mail postfix/master[6171]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Dec  7 10:11:25 mail postfix/smtp[6208]: fatal: open database /etc/postfix/sasl_passwd.db: No such file or directory
Dec  7 10:11:26 mail postfix/master[6171]: warning: process /usr/lib/postfix/smtp pid 6208 exit status 1
Dec  7 10:11:26 mail postfix/master[6171]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Dec  7 10:12:26 mail postfix/smtp[6209]: fatal: open database /etc/postfix/sasl_passwd.db: No such file or directory
Dec  7 10:12:27 mail postfix/master[6171]: warning: process /usr/lib/postfix/smtp pid 6209 exit status 1
Dec  7 10:12:27 mail postfix/master[6171]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Still failed.

Tried changing "/etc/postfix/sasl_passwd" as "/etc/postfix/sasl_passwd.db" without result.

What is "smtp_sasl_type = cyrus"?

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Ping Issue - Can't ping localhost but can ping others on LAN code_slinger Linux - Networking 13 03-17-2011 02:47 AM
"ping xxx.abc.local" ok but "ping xxx" fail powah Linux - Networking 2 10-13-2006 08:16 PM
ping fail from local lan to IPCop mrpc_cambodia Linux - General 3 04-03-2006 04:32 PM
ping lab machine fail but internet ok powah Linux - Networking 1 10-11-2005 10:50 AM
Ping continues to fail after remote host recovers cahenesy Linux - Networking 7 04-19-2004 03:16 PM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration