LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 09-21-2011, 10:32 AM   #1
Eduardo Mena
LQ Newbie
 
Registered: Sep 2011
Posts: 15

Rep: Reputation: Disabled
Access website and send emails problem using shorewall as firewall and qmail as MTA


Hi everybody,

I don't have access to the www.forces.gc.ca website from our local network and I can't send emails to the domain forces.gc.ca.
In general I can to access any website and send emails without problem, but I don't understand what are happening with the domain forces.gc.ca.

I use shorewall as firewall in a linux 2.6.20.3 server
RAM : 255608 kB
CPU : Pentium II

To send email I use qmail at another server with Red Hat Enterprise Linux Server release 5
RAM : 4051620 kB
CPU : Intel(R) Xeon(R)

I have access to www.forces.gc.ca.website without using the firewall, then, maybe I need to modify the shorewall configuration.
This configuration has been working fine for some time.

Could you help me to fix this problem as soon as possible?

Thanks a lot.

Eduardo M.
 
Old 09-23-2011, 01:57 AM   #2
zackwasa
Member
 
Registered: Sep 2011
Posts: 52

Rep: Reputation: Disabled
Can you please show the output of these commands:
telnet forces.gc.ca 80
telnet forces.gc.ca 25

RMI

Last edited by zackwasa; 01-12-2012 at 01:06 AM.
 
Old 09-23-2011, 08:47 AM   #3
Eduardo Mena
LQ Newbie
 
Registered: Sep 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks zackwasa for your answer.

Display from my server (firewall)
root@serverh:~# telnet forces.gc.ca 80
telnet: forces.gc.ca: Temporary failure in name resolution
forces.gc.ca: Host name lookup failure

root@serverh:~# telnet forces.gc.ca 25
telnet: forces.gc.ca: Temporary failure in name resolution
forces.gc.ca: Host name lookup failure

I had in my network configuration (workstation) only a Primary DNS with IP local addresse(192.168.x.x)
and I added a Secondary and Tertiary DNS with addresse IP from my ISP
64.254.x.x
216.94.x.x.

Display from my workstation with Secondary and Tertiary DNS added :
bash-3.1# telnet forces.gc.ca 80
Trying 131.137.250.121...
Connected to forces.gc.ca (131.137.250.121).
Escape character is '^]'.

bash-3.1# telnet forces.gc.ca 25
Trying 131.137.250.121...
telnet: connect to address 131.137.250.121: Connection timed out
telnet: Unable to connect to remote host: Connection timed out

The mail server from forces.gc.ca is mx01.forces.gc.ca (131.137.245.201)

From my server :
root@serverh:~# telnet mx01.forces.gc.ca 25
telnet: mx01.forces.gc.ca: Temporary failure in name resolution
mx01.forces.gc.ca: Host name lookup failure

root@serverh:~# telnet 131.137.245.201 25
Trying 131.137.245.201...
Connected to 131.137.245.201.
Escape character is '^]'.
220 SMTP SMTP Proxy Service Ready

From my workstation
bash-3.1# telnet mx01.forces.gc.ca 25
Trying 131.137.245.201...
Connected to mx01.forces.gc.ca (131.137.245.201).
Escape character is '^]'.
220 SMTP SMTP Proxy Service Ready

I think that is a DNS problem. Modify all workstations(Windows) from my local area network adding a Secondary DNS is not a good idea. Maybe I could modify only /etc/resolv.conf file adding the IP addresses from my ISP :

search mydomain.com
127.0.0.1
nameserver 64.254.x.x
nameserver 216.94.x.x.

It is correct? I need restart any service ? or I need do another thing.

Thanks a lot.

E
 
Old 09-24-2011, 05:29 AM   #4
zackwasa
Member
 
Registered: Sep 2011
Posts: 52

Rep: Reputation: Disabled
Try adding the google resolver as your first one:
nameserver 8.8.4.4

Check if you can access all domains fine after that.

RMI

Last edited by zackwasa; 01-12-2012 at 01:06 AM.
 
Old 09-24-2011, 08:18 PM   #5
Eduardo Mena
LQ Newbie
 
Registered: Sep 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks zackwasa

Now, I can to access the website ! , I'm going to test the email.
 
Old 09-27-2011, 08:39 AM   #6
Eduardo Mena
LQ Newbie
 
Registered: Sep 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Hi,

The email is working very well.
The problem is fixed.

Thanks to everybody.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I send emails by PHP on FC3 (and configure the MTA)? murr4y Linux - Newbie 3 09-01-2005 04:20 PM
shorewall firewall problem wisdom Linux - Security 1 02-02-2005 08:27 PM
Cant access website behind firewall supertrout Linux - Networking 2 10-15-2004 01:10 AM
shorewall problem with firewall itself peter72 Linux - Networking 1 08-01-2004 01:09 PM
Can send but not receive any emails with Qmail. anorman Linux - Software 1 12-11-2003 02:51 PM


All times are GMT -5. The time now is 04:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration