LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 06-08-2004, 03:30 AM   #1
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
loop: can't open device /dev/loop0: No such device or address


I'm using slackware 9.1 with kernel 2.6.6 i have loop and crypto loop supported in the kernel, as well as some ciphers, when i checked /dev/ i have 16 loop devices present. but anything i try to use with losetup, gives me.


loop: can't open device /dev/loop0: No such device or address

i've loop and crypto loop both as modules and built in.. i'll keep trying, if anyone has any insight, please direct me to the right place..

THX
 
Old 06-08-2004, 05:55 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Try it as root. If that works you could change the permissions on the loop devices. I don't know what the implications are for security if you do this though.

Dave
 
Old 06-09-2004, 08:15 AM   #3
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Original Poster
Rep: Reputation: 30
Already Tried It.

I've tried it as root and a normal user. the loop devices exist. but don't work, leads me to believe theres something wrong in the kernel, i've read 25 different crypto howtos each of which assumes that these loop devices do work,... as i said i tried modules and built in but can't seem to have any luck..


Thx..
 
Old 06-09-2004, 09:24 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Can you mount ISO images on loop devices?
e.g.
mount -t iso9660 -o loop image.iso /mnt/loop
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xf86OpenSerial: Cannot open device /dev/psaux da_kidd_er Linux - General 5 01-24-2011 05:03 AM
dd: /dev/hda: No such device or address securehack Linux - General 97 06-04-2005 07:27 PM
Failed to open device /dev/usb/ttyUSB0: No such device efm Linux - Newbie 2 04-04-2005 08:46 PM
tar: /dev/nst0: Cannot open: No such device evallejo Linux - Software 4 09-02-2004 02:00 PM
Cannot open device /dev/psaux KnightChang Linux - Newbie 2 06-06-2001 04:41 PM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration