LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2005, 07:37 AM   #1
sijolinux
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
You don't have permission to access /~username on this server.


I'm trying to set up a home web server and have different accounts installed. This is proving to be more of a challenge than I first though.

Just installed linux last Sunday

Have the following installed on my machine: Fedora core 3. I 've no firewall as this machine is on a LAN, SElinux is switched off.

Apache is running ok when you type localhost or IP address of the server

Managed to install webmin, no problems

Problem is in that I can not view the new user accounts that I create.

The user" john" has a chmod of 755 and so does the directories underneath it, however when type the local IP of the machine 192.xxx.x.x/~john, I get the error.

I completely at a stand still.

Any suggestions please
 
Old 05-08-2005, 08:28 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
1) Make sure that john has a /home/john/public_html directory, at that this is both world-readable and world-executable:
Code:
ls -l /home/john/public_html
This code should give three 'r's and three 'x'es.

2) Make sure that UserDir is set to public_html in your config file.

3) Check what error is reported in /var/log/httpd/error_log when you try to access the file.

Edit: 4) Also make sure that the public_html directory contains an index.html file that is also world-readable (three 'r's with ls -l).
 
Old 01-03-2008, 12:44 PM   #3
patitoconejita
Member
 
Registered: Nov 2004
Location: Winnipeg, MB
Distribution: Debian
Posts: 42

Rep: Reputation: 15
Quote:
Originally Posted by rjlee View Post
1) Make sure that john has a /home/john/public_html directory, at that this is both world-readable and world-executable:
Code:
ls -l /home/john/public_html
This code should give three 'r's and three 'x'es.

2) Make sure that UserDir is set to public_html in your config file.

3) Check what error is reported in /var/log/httpd/error_log when you try to access the file.

Edit: 4) Also make sure that the public_html directory contains an index.html file that is also world-readable (three 'r's with ls -l).
Hi, I'm encountering the same issue with apache2, under Debian unstable. I had initially wanted to set up apache with SSL (apache-ssl package) and DAV module (via the libapache2-svn package), but later removed the apache-ssl package to get started (I'll enable SSL later). The public_html directoy is world-readable and executable, and contains index.html, yet the error still occurs. I can see that /etc/apache2/mods-enabled/userdir.conf has the following:

Code:
<IfModule mod_userdir.c>
UserDir disabled root
UserDir "WWW"

<Directory "/home/*/WWW">
AllowOverride AuthConfig FileInfo Limit
Options ExecCGI FollowSymLinks Indexes MultiViews SymLinksIfOwnerMatch
SSLRequireSSL 
Dav on
</Directory>
</IfModule>
despite having removed the apache-ssl package. That SSLRequireSSL directive is suspicious; why is it there despite no apache-ssl being installed? Thanks for any tips.
 
Old 01-03-2008, 05:58 PM   #4
lopoetve
Member
 
Registered: Aug 2001
Distribution: Too many.
Posts: 102

Rep: Reputation: 15
can you all get to the normal, root of the system? Such as: http://IPADDY/?
 
Old 01-03-2008, 06:10 PM   #5
patitoconejita
Member
 
Registered: Nov 2004
Location: Winnipeg, MB
Distribution: Debian
Posts: 42

Rep: Reputation: 15
Quote:
Originally Posted by lopoetve View Post
can you all get to the normal, root of the system? Such as: http://IPADDY/?
Yes, that works fine.

I solved the issue by removing/purging apache2 and reinstalling it. I reconfigured everything in webmin and now /etc/apache2/mods-enabled/userdir looks like:

Code:
<IfModule mod_userdir.c>
UserDir disabled root
UserDir "WWW"

<Directory "/home/*/WWW">
                AllowOverride FileInfo AuthConfig Limit
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>
</IfModule>
and can access the user directories just fine. Now I'm on to setting up the subversion directory.
 
Old 01-03-2008, 06:19 PM   #6
lopoetve
Member
 
Registered: Aug 2001
Distribution: Too many.
Posts: 102

Rep: Reputation: 15
Sounds like it was a config issue in Apache then. You might have deleted a bracket on part of the permissions config section without meaning to. Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suddenly i cannot access GUI thru my username karam_chand Red Hat 7 08-21-2004 12:36 AM
Apache Vhost( You don't have permission to access / on this server.) trekgraham Linux - Software 3 07-08-2004 11:01 AM
After file oops ? Forbidden You don't have permission to access / on this server. leongoogs Linux - Newbie 3 04-13-2004 10:27 AM
You don't have permission to access / on this server. jkpalmer52 Linux - General 4 01-27-2004 05:05 PM
You don't have permission to access / on this server jaydave Linux - Networking 1 03-15-2003 07:11 AM


All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration