LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-13-2006, 11:30 AM   #1
lesmyer
LQ Newbie
 
Registered: Jun 2006
Posts: 3

Rep: Reputation: 0
xorg.conf bizarre monitor section / obtaining 96dpi screen resolution for WinXP Font


Linux NOOB here - running the new Kubuntu 6.06 distro. Trying to install Windows XP 96dpi fonts to improve my KDE Desktop display quality. Been trying to set up the xorg.conf file to give a 96dpi screen resolution. Below is a copy after the Kubuntu install program's automatic setup of the xorg.cong file. The monitor section looks quite bizarre to me. I tried deleting the modeline entries and entering "DisplaySize xxx xxx" (appropriate for the resolution I was running at - can't remember right now). That worked initially - 96dpi when entering "xpdyinfo | grep resol" ....... that is, until I used the display manager in KDE to change resolutions and then back to the one I was using. At that time the xorg.conf reverted back to the original (below), with all the old modelline entries (and my manually entered displaysize line disappeared). Screen resolution switched back to 75x75dpi. Any ideas how to set this xorg.conf up properly, so I can switch display resolutions while keeping a 96 dpi screen resolution in all display resolutions? I know I will probably need multiple displaysize lines, one for each resolution - but how do I keep the modeline entries from reappearing, and my displaysize lines from disappearing when I switch resolutions in KDE? Is this something new to KDE, or something specific to my monitor or video card, or ?????? Am using an ATI AIW Radeon 7500 with 19" Samsung SyncMaster 997DF. OS is Kubuntu 6.06 Dapper Released Version. Thanks in advance for any help.
------------------------------------
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "type1"
Load "vbe"
load "glx"
load "GLcore"
load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
option "CoreKeyboard"
option "XkbRules" "xorg"
option "XkbModel" "pc104"
option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
option "CorePointer"
option "Device" "/dev/input/mice"
option "Protocol" "ExplorerPS/2"
option "ZAxisMapping" "4 5"
option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
option "Device" "/dev/wacom"# Change to
option "Type" "stylus"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
option "Device" "/dev/wacom"# Change to
option "Type" "eraser"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
option "Device" "/dev/wacom"# Change to
option "Type" "cursor"
option "ForceDevice" "ISDV4"# Tablet PC ONLY
# /dev/input/event
# for USB
EndSection

Section "Device"
identifier "ATI Technologies, Inc. Radeon RV200 QW [Radeon 7500]"
boardname "ati"
busid "PCI:1:0:0"
driver "ati"
screen 0
option "MergedFB" "off"
EndSection

Section "Monitor"
identifier "SyncMaster"
vendorname "Plug 'n' Play"
modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1152x768@54" 64.995 1152 1178 1314 1472 768 771 777 806 +hsync +vsync
modeline "1280x854" 80.0 1280 1309 1460 1636 854 857 864 896 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x960@85" 148.5 1280 1344 1504 1728 960 961 964 1011 +hsync +vsync
modeline "1280x1024@85" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1400x1050@75" 155.85 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@75" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1600x1200@70" 189.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
modeline "1792x1344@60" 204.8 1792 1920 2120 2448 1344 1345 1348 1394 -hsync +vsync
modeline "1856x1392@60" 218.3 1856 1952 2176 2528 1392 1393 1396 1439 -hsync +vsync
modeline "1920x1440@60" 234.0 1920 2048 2256 2600 1440 1441 1444 1500 -hsync +vsync
modeline "2048x1536@60" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -hsync +vsync
gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon RV200 QW [Radeon 7500]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
depth 24
virtual 2048 1536
modes "1280x960@85" "1280x1024@85" "1280x960@60" "1280x1024@60" "1280x1024@75" "1280x960@75" "1280x854" "1400x1050@60" "1152x768@54" "1400x1050@75" "1152x864@75" "1600x1200@65" "1024x768@43" "1600x1200@60" "1024x768@60" "1600x1200@75" "1024x768@70" "1600x1200@70" "1024x768@75" "1792x1344@60" "1024x768@85" "1856x1392@60" "832x624@75" "1920x1440@60" "800x600@60" "2048x1536@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
Section "ServerFlags"
EndSection
----------------------------------------------------
 
Old 06-13-2006, 01:30 PM   #2
lesmyer
LQ Newbie
 
Registered: Jun 2006
Posts: 3

Original Poster
Rep: Reputation: 0
[QUOTE=lesmyer] Below is a copy after the Kubuntu install program's automatic setup of the xorg.cong file.

This should have read...... "Below is a copy after the Kubuntu install program's automatic setup of the xorg.conf file." Sorry, it was a typo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Resolution problems connected with xorg.conf and xorgconfig with Slackware 10 tvisher Linux - Newbie 17 04-03-2007 07:39 AM
Xorg.conf, custom screen resolution tntcoder Linux - Newbie 3 05-12-2006 10:19 AM
how to change font resolution in xorg xserver? jr0 Linux - Newbie 2 10-27-2005 03:58 PM
Getting the resolution right in xorg.conf slimjim Linux - Software 1 04-26-2005 01:03 PM
Slack 10 xorg.conf font lines vrln Slackware 2 07-01-2004 03:56 AM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration