LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2012, 12:39 PM   #1
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Rep: Reputation: Disabled
xcompmgr error in Xmonad: No Composite Extension


I have been having a problem with xcompmgr since I moved from Debian 5 to Debian 6. While in Xmonad, if I try to run
Code:
xcompmgr -cf
I get the error
No composite extension
xcompmgr runs perfectly while I am running a gnome session - but it does not seem to want to run in a Xmonad Session.

I did not need this for gnome, but I have added the following to /etc/xorg.conf:
Code:
Section "Extensions" 
        Option "Composite" "True" 
        Option "RENDER" "True"
EndSection
I have read that some people have had success with Nvidia cards by adding:
Option "RenderAccel" "on"

but I am using an ATI card - and this seems to be a feature that is particular to Nvidia.
If it matters, I run xcompmgr in my ~/.xsessionrc with the following line:
Code:
xcompmgr -cf &
and it definitely is not running in the background since
Code:
ps -A | grep xcomp
returns nothing.

I was hoping that someone may have had a similar problem or had some suggestions. Thanks again,

Kaivai
 
Old 12-14-2012, 12:51 PM   #2
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
It seems like the issue is xinerama. Apparently xinerama and xcompmgr do not like playing together...

I don't suppose anyone knows how gnome manages to do this?

Last edited by kaivai; 12-14-2012 at 01:02 PM.
 
Old 12-14-2012, 03:09 PM   #3
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Nope - I was wrong. I could have sworn it was working in gnome, but xinerama and xcompmgr are incompatible.

I have however read that using the Catalyst drivers instead of the fglrx drivers enable you to do an eyefinity setup, which allows you to use a compositing tool. I need to finish the rest of my 'safe' installation before I break it again - but I'll post again if I can get it running and it works.
 
Old 12-20-2012, 08:14 AM   #4
kaivai
LQ Newbie
 
Registered: Nov 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Horay! The solution was indeed to use XRANDR. This is how I went about using XRANDR with the FGLRX drivers installed. As a complete side note, this solved my flickering conky as well.

1. use:
Code:
sudo amdcccle
to disable xinerama, and disable all but one monitor

2. open /etc/X11/xorg.conf, in the DISPLAY subsection of SCREEN add the heading Virtual; Set the resolution to be the total possible Width and Height of all monitors combined
(I am using 2 1920x1080 monitors)
ex: Virtual 3840 2160

3. restart X or restart

4.
Code:
xrandr -q
to list all available displays
xrandr --auto to activate second display
xrandr --output (DisplayName-seen-with xrandr -q) --left-of (Other-DisplayName-seen with xrandr -q)

Play with this until you know which monitor is on which side. Horay! It works for now - until you logout or restart.


Making the changes permanent:

1. open /etc/X11/xorg.conf

2. look for the monitor sections with the names detected by xrandr -q (I had 4 monitors listed - but fglrx only manages 2 of them. I think the ATI driver interacts with a virtual monitor which sends the changes to your actual monitor, but I could be wrong)

Under that heading you are going to add a modeline, and a preferred Mode for your resolution

3. generate a modeline for each "Monitor" section with
Code:
cvt width height
. this is the resolution you want per monitor, not combined. ex:
Code:
cvt 1920 1080
The second line returned is your modeline
Paste your modeline under each monitor with a name you recognize from xrandr -q

Under your modeline add:
Option "PreferredMode" and then the first section of your modeline that is in quotations
ex: Option "PreferredMode" "1920x1080_60.00"

4. Since this is a multi-display you need to make sure that the monitors are not disabled, and that their position is correct

Check to see if there is a Option "Disable" "True" listed, and if so change it to "false"
For the monitor that you want on the right hand side, set:
Option "Position" "width-of-first-display 0"
ex: Option "Position" "1920 0"

That's it! Restart X (or restart your machine) to see if it worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compiz: extension Composite: not present farzadfedora SUSE / openSUSE 1 01-19-2009 08:00 PM
slack12: X sluggish from composite extension? bioe007 Slackware 2 08-01-2007 11:39 PM
Eye-candy without composite extension? person132 Linux - Software 4 04-09-2007 11:36 PM
no composite extension X11R6.9 Komakino Linux - Software 1 05-14-2006 06:31 PM
xcompmgr No composite extension little_ball Slackware 7 11-26-2004 11:16 AM


All times are GMT -5. The time now is 05:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration