LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2005, 08:54 PM   #1
c--
Member
 
Registered: Sep 2004
Location: Oregon, USA
Distribution: Ubuntu/Debian
Posts: 82

Rep: Reputation: 15
x.org server problems on nvidia geforce 4


theres a bunch of minor weird things going on with my x server.
I started out with the .sh driver installer from nvidia, and installed the nvidia kernel module without any problems, went and modified my x config file etc. however, I can't run with depth at 24, only at 16, and my resolution is running at 1280x1024 even though my config file never mentions that resolution at all and is set to use 1024x768 as my first choice, then 800x600.

my xorg.conf file is:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "GLcore"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC CS500"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"

# SubSection "Display"
# Viewport 0 0
# Depth 16
# Modes "800x600" "640x480"
# EndSubSection
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 24
# Modes "1024x768" "800x600" "640x480"
# EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

my monitor is kind of old and really dosn't run high resolutions well, and this is driving me crazy because everything is very fuzzy. also, 16 bit color isn't so great and aulthough the driver seems to work, openGL screensavers I've tried don't work, just black.

Thanks in advance to anyone who can figure this out
 
Old 02-04-2005, 09:07 PM   #2
bushidozen
Member
 
Registered: Oct 2004
Posts: 215

Rep: Reputation: 30
Call me crazy, but it looks like you did not modify your xorg.conf file properly. According to the nvidia README file, after installing the driver you should remove ( or comment out )

Load "dri"

and

Load "GLcore"

and you should also replace
Driver "nv"

with

Driver "nvidia"
 
Old 02-04-2005, 09:14 PM   #3
jmcgarey
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake and Mepis
Posts: 9

Rep: Reputation: 0
I think you are totally on the right track looking in that file and its good that you posted it in it's entirety.

Try this quick fix for the resolution problems:
In the part of the file labelled:
Code:
Section "Screen"
Change the line that says:
Code:
Depth 16
to read:
Code:
Depth 24
then let us know what changes.


- John
 
Old 02-04-2005, 09:43 PM   #4
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by bushidozen
Call me crazy, but it looks like you did not modify your xorg.conf file properly. According to the nvidia README file, after installing the driver you should remove ( or comment out )
Yes, I agree with you.

Read the NVIDIA README that came with the driver. Also check this link out if you have any more problems (you probably will):

http://www.nvnews.net/vbulletin/showthread.php?t=40622
 
Old 02-04-2005, 09:44 PM   #5
c--
Member
 
Registered: Sep 2004
Location: Oregon, USA
Distribution: Ubuntu/Debian
Posts: 82

Original Poster
Rep: Reputation: 15
thats the problem, when I set it to 24, the server starts, and all I get is a black screen and my monitor shows no input (little orange instead of green light) so for some reason, it just won't do 24 bit color. as for the resolution being higher than what I set it to, no idea
 
Old 02-04-2005, 10:09 PM   #6
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by c--
thats the problem, when I set it to 24, the server starts, and all I get is a black screen and my monitor shows no input (little orange instead of green light) so for some reason, it just won't do 24 bit color. as for the resolution being higher than what I set it to, no idea
The nvidia driver isn't installed unless you change this:

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

To this:

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection
 
Old 02-04-2005, 10:23 PM   #7
c--
Member
 
Registered: Sep 2004
Location: Oregon, USA
Distribution: Ubuntu/Debian
Posts: 82

Original Poster
Rep: Reputation: 15
ok, I did do that before my last post, sorry I didn't explain well.
now the xorg.conf file is this:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "GLcore"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC CS500"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"

# SubSection "Display"
# Viewport 0 0
# Depth 16
# Modes "800x600" "640x480"
# EndSubSection
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 24
# Modes "1024x768" "800x600" "640x480"
# EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

and when I do set it to depth 24, it gives me the black screen.
and like I said, I still can't make it run at 1024x768, it runs much higher, 1280x1024 and looks very fuzzy and anoying on my screen.
 
Old 02-04-2005, 11:29 PM   #8
jmcgarey
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake and Mepis
Posts: 9

Rep: Reputation: 0
Keep Trying

Let's try this:

Remove the lines:
Code:
Load "GLcore"
Load "dri"
Then the NVidia driver should be fully active.

Next Step:
Replace the whole "Screen" section of that file with this:
Code:
Section "Screen"
	Identifier "Screen0"
	Device "Videocard0"
	Monitor "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport 0 0
		Depth      16
		Modes     "1024x768" "800x600" "640x480"
	EndSubSection
        SubSection "Display"
		Viewport 0 0
                Depth       24
                Modes      "1024x768" "800x600" "640x480" "320x240"
        EndSubSection
EndSection
then post the resulting file and try it out.
 
Old 02-05-2005, 01:34 AM   #9
c--
Member
 
Registered: Sep 2004
Location: Oregon, USA
Distribution: Ubuntu/Debian
Posts: 82

Original Poster
Rep: Reputation: 15
still no good

I tried that, the load dri and load GLcore lines were commented out so I just left them.
the resulting file is:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "GLcore"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "NEC CS500"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480" "320x240"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

and now for the incredibly weird part. after getting the blank screen, I tried setting the defultdepth to 16 again, and it didn't work. Then, I commented out the display subsection for depth 24, still didn't work. But then, if I have the depth 24 display subesction commented out, and the defaultdepth set to 24, it works fine, again at a much higer resolution than 1024x768

should I make it fail with the config file as you recomended and get the Xorg.0.log file from /var/log?
 
Old 02-05-2005, 08:53 AM   #10
jmcgarey
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake and Mepis
Posts: 9

Rep: Reputation: 0
Change resolution on the fly

Right now when I hold ctrl and alt at the same time and press "+" on the numpad my screen cycles through several resolutions then back to the original.

Try pressing ctrl-alt-+ (numpad +) and see what happens.


That will give us clues as to whether perhaps x.org is not allowing those resolutions and it may help you if it works. And then yes make it fail and then show us the Xorg.0.log file.

- John
 
Old 02-05-2005, 12:32 PM   #11
c--
Member
 
Registered: Sep 2004
Location: Oregon, USA
Distribution: Ubuntu/Debian
Posts: 82

Original Poster
Rep: Reputation: 15
the ctrl-alt-+ and - on num pad works, and I can get it to 1024x768 and other lower resolutions, but then it starts making me "scroll" arround my desktop, even if I log out and back in to reload the window manager. So, it sort of works. When I run with the config file:
Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
#	Load  "GLcore"
#	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "NEC CS500"
	HorizSync    30.0 - 70.0
	VertRefresh  50.0 - 90.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth    24 
	SubSection "Display"
		Viewport   0 0
		Depth    16 
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480" "320x240"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
heres the log from /var/log/Xorg.0.log after it gives me the blank screen

http://www.eugeneweb.com/~ian/xorglog.txt
 
Old 02-05-2005, 05:01 PM   #12
jmcgarey
LQ Newbie
 
Registered: Mar 2004
Distribution: Mandrake and Mepis
Posts: 9

Rep: Reputation: 0
Three new ideas:


1. Before logging in (or starting your x server), try typing
Code:
xhost +localhost
in a command prompt.


2. There is good information in that x.org log file. Also post the other one that is created after the desktop shows up and works but has the wrong resolution.

It is the last line and only the last line of that previous x.org log file that bothers me. Otherwise it looks like everything is configured properly.


3. Try starting the x server from a root account (this of course not recommended for everyday use).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse Nvidia Geforce 2 ti Problems btreb Linux - Hardware 1 02-22-2005 09:05 PM
NVIDIA GeForce on Fedora Core 3 problems alagenchev Linux - Hardware 1 01-20-2005 05:38 PM
Problems with Nvidia GeForce 4 with Mandrake 10 ctux Linux - Hardware 3 08-06-2004 01:59 PM
nVIDIA Geforce 4 Problems Veratien Linux - Software 2 02-25-2003 07:49 PM
problems with the xconfig with a NVidia Geforce 2 Go twitch_83 Linux - General 6 01-20-2003 07:52 PM


All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration