LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-26-2003, 02:04 PM   #1
intellscreen
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Rep: Reputation: 0
x does not start


i have used linux for about a week and i started to like it. but when i tried to config the vsftp server i think i edited a wrong file. i can not start linux at all now.

i have linux redhat 9. it starts x automaticly. when x starts it try's to change resolution(the screen go's of for a sec.) but it does not sucseed. it try's it about 3 times goes to the normal linux terminal login. stays there for half a sec and then it starts from the begin i can not do a thing.

does anybody know a solution?
 
Old 10-26-2003, 02:44 PM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
edit your bootconfig and change the runlevel so rh wont start x by default i think on red hat it was telinit 4 for text based boot without x so you can edit your failure
 
Old 10-26-2003, 04:21 PM   #3
Nimoy
Member
 
Registered: Jun 2003
Location: Currently Denmark
Distribution: Ubuntu 11.10
Posts: 334

Rep: Reputation: 30
Text login on redhat is Runlevel 3
 
Old 10-26-2003, 04:23 PM   #4
Nimoy
Member
 
Registered: Jun 2003
Location: Currently Denmark
Distribution: Ubuntu 11.10
Posts: 334

Rep: Reputation: 30
Start in rescue mode

start mc

go into etc

open initab by pressing F4


Find the bit below:

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault: <----- This line probably needs to be changed from 5 to 3
 
Old 11-02-2003, 08:20 AM   #5
intellscreen
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Original Poster
Rep: Reputation: 0
thanx
 
Old 11-02-2003, 12:00 PM   #6
Nimoy
Member
 
Registered: Jun 2003
Location: Currently Denmark
Distribution: Ubuntu 11.10
Posts: 334

Rep: Reputation: 30
You are most welcome - And remember you too can make a huge difference by solving somebody else's problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
disable cold start and warm start snmp traps chkisco Linux - Newbie 0 10-28-2005 03:58 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM
cannot start kdeas user ,can start icewm,fluxbox jackren Debian 1 03-01-2004 12:06 AM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration