LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-05-2007, 01:47 PM   #31
wauwha
LQ Newbie
 
Registered: Jun 2005
Location: Bronderslev, Denmark
Distribution: Slackware 12.1
Posts: 16

Rep: Reputation: 0

Posted some rubbish here before - please disregard this post

Last edited by wauwha; 09-05-2007 at 01:49 PM.
 
Old 09-05-2007, 03:12 PM   #32
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
If Ubuntu is like Fedora, you might need to set the driver properly in /etc/sysconfig/wpa_supplicant.

I've found (again, on Fedora), that the -Dndiswrapper setting does not work, and (at least for my bcm4318), I had to use wext
Code:
$ cat /etc/sysconfig/wpa_supplicant
INTERFACES="-ieth1"
DRIVERS="-Dwext"

Last edited by PTrenholme; 09-05-2007 at 03:14 PM.
 
Old 09-06-2007, 08:31 PM   #33
SyCo123
Member
 
Registered: May 2007
Posts: 96

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
You'll need to refresh my memory on how you're starting wpa_supplicant. It looks like it is getting started, but any flags you use might give a clue.
Honesty I'm a little embarrassed to say but I'm not sure. I was following various tuts to get as far as I have. I hope this helps to give you a better idea. This is the output immediately after rebooting.

Code:
simon@simon-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:32 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

simon@simon-laptop:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:D4:39:03:9C  
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::216:d4ff:fe39:39c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3072 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2762 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2232911 (2.1 MiB)  TX bytes:381651 (372.7 KiB)
          Interrupt:22 Base address:0xc400 

eth1      Link encap:Ethernet  HWaddr 00:14:A5:BD:00:60  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:21 Memory:c0204000-c0206000 

eth1:avah Link encap:Ethernet  HWaddr 00:14:A5:BD:00:60  
          inet addr:169.254.5.118  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Memory:c0204000-c0206000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)

simon@simon-laptop:~$ iwlist eth1 scan
eth1      Scan completed :
          Cell 01 - Address: 00:C0:49:F0:EE:0A
                    ESSID:"fortress"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:100/100  Signal level:-24 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (2) : CCMP TKIP 
                        Authentication Suites (1) : PSK  
                    IE: WPA Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (2) : CCMP TKIP 
                        Authentication Suites (1) : PSK  
          Cell 02 - Address: 00:18:F8:FE:E0:68
                    ESSID:"linksys"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.437 GHz (Channel 6)
                    Quality:12/100  Signal level:-88 dBm  Noise level:-96 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

simon@simon-laptop:~$ sudo /etc/init.d/networking restart
Password:
 * Reconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 4882
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:16:d4:39:03:9c
Sending on   LPF/eth0/00:16:d4:39:03:9c
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.2.1 port 67
RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.eth1.pid with pid 5304
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a5:bd:00:60
Sending on   LPF/eth1/00:14:a5:bd:00:60
Sending on   Socket/fallback
DHCPRELEASE on eth1 to 192.168.2.1 port 67
There is already a pid file /var/run/dhclient.eth0.pid with pid 6847440
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:16:d4:39:03:9c
Sending on   LPF/eth0/00:16:d4:39:03:9c
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.2.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.2.1
bound to 192.168.2.6 -- renewal in 1355 seconds.
eth2: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.eth2.pid with pid 6847440
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
eth2: ERROR while getting interface flags: No such device
eth2: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up eth2.
ath0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.ath0.pid with pid 6847440
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
ath0: ERROR while getting interface flags: No such device
ath0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up ath0.
wlan0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.wlan0.pid with pid 6847440
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up wlan0.
Error for wireless request "Set Encode" (8B2A) :
    invalid argument "hTvHAivbq1uj2KdPkPWTnHnl8bgTNUdk".
There is already a pid file /var/run/dhclient.eth1.pid with pid 6847440
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:14:a5:bd:00:60
Sending on   LPF/eth1/00:14:a5:bd:00:60
Sending on   Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
                                                                         [ OK ]
simon@simon-laptop:~$

Thanks again for getting back into this.
 
Old 09-07-2007, 08:35 AM   #34
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
So immediately after booting, it looks as if wpa_supplicant hasn't run or it has run, but isn't configured for eth1. If it had, you would see configuration information in the output of iwconfig. The command I would use to start it would be this:


wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -ieth1


Of course you would have to modify it to point to your wpa_supplicant.conf file if it is in a different location.
 
Old 09-07-2007, 11:26 AM   #35
SyCo123
Member
 
Registered: May 2007
Posts: 96

Original Poster
Rep: Reputation: 15
here's the result

Code:
simon@simon-laptop:~$ wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -ieth1
simon@simon-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:32 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

simon@simon-laptop:~$
 
Old 09-07-2007, 01:03 PM   #36
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Hm. Anything in the logs? Something obviously is going wrong with wpa_supplicant, but we need to find out what.
 
Old 09-07-2007, 05:43 PM   #37
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
I note you're using GNOME. See if a NetworkManager-gnome package is available on Ubuntu.

If it is, and if you install the package, you should get an applet you can put into a panel which you can use to configure and access any access point listed by a scan of available access points. Just left-click on the icon to see a list of APs, and then right-click on one to bring up the connection dialog.

It should also install the NetworkManager package, and, when you connect to a WPA-protected AP, the NetworkManager package will automatically start wpa_supplicant and use wpa_cli to configure the supplicant and access the network without needing a configuration file. I haven't checked this, but I think that the NetworkManager doesn't use your wpa_supplicant.config even if you've created one. On Fedora, though, it does use /etc/sysconfig/wpa_supplicant to get the interface and driver settings.

Last edited by PTrenholme; 09-07-2007 at 05:44 PM.
 
Old 09-07-2007, 07:12 PM   #38
SyCo123
Member
 
Registered: May 2007
Posts: 96

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Hangdog42 View Post
Hm. Anything in the logs? Something obviously is going wrong with wpa_supplicant, but we need to find out what.
Do you know which log and where it would be?


Hi PTrenholme

I have Network Manager installed and there is the wireless connection. I double click it and get the 'settings for eth1' window. There is a list of available networks ESSIDs which includes mine (fortress). The problem is the password type only gives the option of WEP ascii and WEP hex, nothing else. Connection settings are set at DHCP.
 
Old 09-07-2007, 11:37 PM   #39
snares
Member
 
Registered: Mar 2006
Distribution: Ubuntu Gusty Gibbon
Posts: 108

Rep: Reputation: 16
I scrolled through the post reading hear and there. For future refrence the Linksys WMP54GS uses the same chipset so you could have probally used those drivers. Also Fiesty has a utilly in Synaptic called ndiswrapper-utils that would have done the entire driver install process for you. Well aside from gettign the driver. Just download the driver open the Ndiswrapper Utillity and select the driver and done. But you got it to work anyways just thought you might like to know there is a easier way.

Now, correct me if i'm wrong but now you are trying to get WPA set-up. See if this helps. I use the Ubuntu Guide constantly.

snares

Last edited by snares; 09-08-2007 at 01:06 AM.
 
Old 09-08-2007, 07:53 AM   #40
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
Originally Posted by SyCo123 View Post
Do you know which log and where it would be?
That would be /var/log/syslog, /var/log/messages and the output of the dmesg command. It is probably best to look immediately after starting wpa_supplicant as then any errors are likely near the bottom of the files.
 
Old 09-08-2007, 10:40 PM   #41
handydan
Member
 
Registered: Mar 2005
Location: palmdale, california
Distribution: MEPIS 8; Debian (stable/testing)
Posts: 83

Rep: Reputation: 23
OK...

Quote:
Originally Posted by SyCo123 View Post
Look like I'm getting somewhere!!

Code:
simon@ubuntu:~$ ndiswrapper -l
bcmwl5 : driver installed
        device (14E4:4318) present (alternate driver: bcm43xx)
simon@ubuntu:~$
I've rebooted but no wireless light.
System>Administration>Network has no mention of a wireless connection either.
now, as previously noted, edit /etc/modprobe.d/blacklist to include an entry like this:

#interferes with ndiswrapper bcm4318
blacklist bcm43xx

I can guarantee it won't work until you do. Ask me how I know....
}:-(
 
Old 09-09-2007, 03:28 PM   #42
dan_slack
Member
 
Registered: May 2004
Location: Bucharest - Romania
Distribution: Slackware 12
Posts: 57

Rep: Reputation: 15
Smile Very good answer!

Quote:
Originally Posted by Hangdog42 View Post
@SyCo123,

You're mixing up the instructions from two drivers. Ndiswrapper requires itself and a Windows driver and nothing else. The bcm43xx driver requires firmware you create with fwcutter. The 4318 chipset you've got doesn't work very well with bcm43xx, so I would suggest that you use ndiswrapper. That means you need to do two things:

1) Visit the ndiswrapper wiki (see my sig for the link). They have excellent installation instructions there.

2) You need to blacklist the bcm43xx driver by adding the line blacklist bcm43xx to your /etc/modprobe.d/blacklist file. That prevents bcm43xx from being loaded at boot. The reason you need to do this is that bcm43xx and ndiswrapper can't be loaded at the same time. They will interfere with each other.
Very good, Hangdog!
Thank you!
 
Old 09-25-2007, 12:02 AM   #43
SyCo123
Member
 
Registered: May 2007
Posts: 96

Original Poster
Rep: Reputation: 15
Thanks for you help still, I'm still trying to get this to go but right now and am swamped with other crap getting in the way. Buying a house and a green card application due in a week is just the start.

Hopefully I'll be able to get going again soon.

On the plus side I found a cheap wireless USB adapter that works on boot but without any security. I hope the neighbors aren't using kazaa
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Wireless (BCM4306) Wireless problems: modprobe ndiswrapper freezes HP Laptop shthap3ns Linux - Hardware 11 02-11-2007 01:53 PM
Broadcom 4318 woes poblano Linux - Wireless Networking 4 11-13-2006 03:12 AM
[FC-6 x86_64] Broadcom Corporation Dell Wireless 1390 woes homer420 Linux - Laptop and Netbook 2 11-02-2006 02:54 PM
HP Laptop, Broadcom 54G Woes. Noctaire Mandriva 3 12-04-2005 12:50 PM
wireless problems; Broadcom 802.11G Mini PCI Wireless with redhat WS surfbass Linux - Laptop and Netbook 1 12-17-2004 01:48 PM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration