LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2004, 06:30 AM   #1
rjkfsm
Member
 
Registered: Apr 2004
Location: Charleston, SC
Distribution: Debian, Gentoo, Knoppix & DSL
Posts: 122

Rep: Reputation: 15
Why fstab doesn't mount smbfs


I was doing research on why my Windows box can't access the shares on my Linux box and ran across an article on fstab and smbfs. I've seen a lot of people post here about problems with mounting smbfs shares on boot and what I read made sense. DISCLAIMER: If this person was wrong, then I am wrong and I'm sure someone will correct me. What the article taught ended up working, so I'm assuming it's correct.

When your system boots, it goes through several runlevels. As you go through the boot sequence, the fstab is loaded before your ethernet card. As a result, the mounting fails. What you need to do is have the smbfs mount occur after the ethernet card is initialized.

There are two ways of doing this:

put a 'mount -t smbfs' command with options in the /etc/rc.d/rc.local file or put a uid=xxx option in your fstab like this:

//shelby/shareddocs /mnt/shared smbfs username=shunter,password=xxx,uid=000,users,exec,rw 0 0

Russ
 
Old 12-16-2011, 11:11 AM   #2
ironoxide
LQ Newbie
 
Registered: Sep 2003
Location: Vicenza, Italy
Posts: 4

Rep: Reputation: 0
I spent a long time to find the problem: STP - Spanning Tree Protocol.
When a host is attached such as a computer, printer or server the switch port will always go into the forwarding state, albeit after a delay of about 30 seconds while it goes through the listening and learning states. Full story: fstab mount error at boot.
 
Old 12-16-2011, 12:15 PM   #3
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 308

Rep: Reputation: 50
You can also try adding the _netdev option to your mount options. That is supposed to wait until the network is online before mounting the location.
 
Old 12-16-2011, 12:23 PM   #4
ironoxide
LQ Newbie
 
Registered: Sep 2003
Location: Vicenza, Italy
Posts: 4

Rep: Reputation: 0
_netdev doesn't work (if the problem is STP) because network it's online (but switch doesn't forward packets because of STP listening/learning state)

Last edited by ironoxide; 12-16-2011 at 12:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Delay fstab mount of smbfs during boot Iron City Linux - General 7 01-21-2009 02:58 PM
problems with smbfs mount-point in /etc/fstab - "mount -a" works, but not at boottime MarkSide Linux - Software 4 11-20-2005 03:30 PM
mounting an smbfs share using mount vs /etc/fstab sichen Linux - Networking 4 08-13-2004 06:40 PM
smbfs in fstab cpugeniusmv Linux - Networking 2 04-03-2004 01:29 PM
can anyone with rh9 mount multiple shares with smbfs in fstab? Falafel Linux - Networking 2 11-15-2003 08:15 AM


All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration