LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2011, 02:10 PM   #1
tsh3po
LQ Newbie
 
Registered: Mar 2010
Posts: 20

Rep: Reputation: 0
wget works but elinks wont go online, what could be happening?


Hi all,

I've got a bit of tricky situation with a Red Hat box, our network uses a proxy server to connect to the internet. I've exported its address using "export http_proxy=http://usernameassword@server_iport" and to test I ran a wget against www.google.co.za and got a response, but using elinks to connect to google gives a proxy requires authentication error. It cant possibly be the credentials as wget can connect. I've confirmed that the proxy was exported by running "env | grep -i proxy", I also tried appending that line on both "/etc/profile" and/or "/root/.bash_profile" with no luck. one other thing I noticed is that passing those arguments directly to elinks works, not only this but "ssh -X server_ip_address" then running firefox& and giving it the proxy address also works. Is the any other way to make this line global, meaning to tell all applications that require internet connection to use the proxy? The server is sitting at a remote location and I only have access to a shell.

Thanks and hope I gave enough info on the problem
 
Old 04-11-2011, 04:54 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Hi tsh3po,

Just put the following line in /etc/environment and then the proxy setting will be global:

http_proxy="http://userw@proxyaddressort"

Where, user will be the user name you will use for proxy authentication and pw will be the password for that user.

Edit: You can put the above line in /etc/profile to make it global for all users.

PS:-

: p is appearing as smiley :-)

Last edited by T3RM1NVT0R; 04-18-2011 at 05:42 PM.
 
Old 04-25-2011, 05:42 PM   #3
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

If you think that the issue has been fixed please mark the thread as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wget wont stay on domain timnp Linux - General 2 11-26-2008 06:23 AM
Problem resolving hostname with elinks / wget pk21 Linux - General 2 04-10-2006 09:22 PM
wget wont download ?? paul_mat Linux - Software 1 11-01-2005 12:45 AM
wget works but telnet [host] 80 does not connect ttonteri Linux - Networking 6 12-28-2004 09:57 AM
wget gives me 404 when IE works just fine...? ivj Linux - Software 7 07-24-2004 10:13 PM


All times are GMT -5. The time now is 10:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration