LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2008, 11:53 AM   #1
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Rep: Reputation: 0
Undo LDAP Authentication?


Hello -

I hope I can explain this correctly. I have a LAMP server (with MediaWiki) that was working until I ruined it.

I wanted MW to authenticate via LDAP, but my problem is a little more.

The eth0 is disabled at boot, and I must manually enable eth0 each time I reboot. (I thought it a minor inconvenience, and I would figure out a fix for that later...)

For ldap, I followed the directions here:
http://www.yolinux.com/TUTORIALS/LDA...ntication.html
to enable ldap authentication from a remote server. The last direction was to reboot to enable ldap. Which I did. (How dumb!)

The problem that resulted: authenticate using the network, but no working network connection.

The GUI doesn't fully load, though I can get a terminal window and log in.
There are two error messages:

Quote:
Error starting GNOME Settings Daemon.
Somethings such as themes, sounds or background settings may not work correctly. Last error message was:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
and

Quote:
The applet nm-applet has crashed
ifconfig eth0 returns

Link encap: Ethernet HWaddr 00:08:02040:7E:7D
BROADCAST MULTICAST MTU:1500 Metric: 1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RXbytes:0 (0.0 b) TX bytes:0 (0.0 b)

What is the location of the file for enabling eth0 ?
And /Or how can I disable ldap authentication?

Am I heading in the right direction to repair?

Thank you!

Best,
D
 
Old 03-19-2008, 12:21 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
How about you supply information about the distro you did this with?



Cheers,
Tink
 
Old 03-19-2008, 12:51 PM   #3
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks, Tink -

Fedora 8

Best,
D
 
Old 03-19-2008, 01:51 PM   #4
Linville79
Member
 
Registered: Nov 2006
Location: Indiana, U.S.A.
Distribution: Red Hat Enterprise Linux, Fedora, CentOS
Posts: 134

Rep: Reputation: 16
The config files for your ethernet adapters eth*, by default in Fedora, are located at /etc/sysconfig/network-scripts/

The files are named ifcfg-eth*

In order to have your eth0 interface enabled at boot, you will need to edit the ONBOOT line in your ifcfg-eth0 file. It will need to look like this:

ONBOOT=yes

Save the changes and restart the machine.
 
Old 03-19-2008, 02:15 PM   #5
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you -

I went to the ifcfg-eth0 file as you said.

ONBOOT=yes

was already in the file. Hmmm..

I looked in /var/log/messages

and saw repeated many times over a period of several minutes

dbus-daemon :nss_ldap :reconnecting to LDAP server
dbus-daemon :nss_ldap :failed to bind to LDAP server ldap://10.1.100.16/ Can't connect to LDAP server

where 10.1.100.16 is our network's (fully working) ldap server.

I would just like to cancel the ldap authentication within the terminal window, and go back to local authentication, I think.

Thanks,
D
 
Old 03-19-2008, 03:16 PM   #6
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Original Poster
Rep: Reputation: 0
Undo LDAP Authentication- Success!

Success with disabling ldap!

The log files and the lines for nss_ldap connection failed
sent me to the padl.com site.

I used the command
# authconfig --disableldapauth -- update
# authconfig --disableldap --update

I rebooted, and my machine booted normally!

I still have to look into the NetworkManager Applet, but that will be in a different thread.

Thanks!
D
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ldap authentication help ... sir-lancealot Linux - Server 2 10-11-2007 04:00 PM
help in LDAP authentication chickenjoy Linux - Server 3 06-14-2007 05:28 AM
LDAP Authentication and su da_kidd_er Linux - Networking 1 12-27-2005 11:24 AM
Ldap Authentication joeyBig Programming 1 08-25-2004 10:00 AM
ldap authentication box_l Mandriva 0 03-22-2004 03:24 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration