LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2009, 09:50 PM   #1
mcpoon
LQ Newbie
 
Registered: Jun 2009
Posts: 12

Rep: Reputation: 0
Unable to change/set time


Hi,

I have a dual boot XP and Fedora 10 and there are 2 problems that occurred which I think is due to the time setting. Can someone help me?
1) Fedora time is usually ahead of my current location setting. I have tried to set the time from system>administration>Date and Time setting but each time whenever I boot up, the time will be off again. This affected my XP time stamp as well. I am not sure why this happened
2) After I change the time setting, whenever I reboot my laptop, it will run a pre-boot testing to test out the hardware, memory etc. I suspect this has something to do with the time setting.
Can someone please help me?
Thank you.
 
Old 06-15-2009, 11:38 PM   #2
loonix
Member
 
Registered: Aug 2003
Location: Sydney Australia
Distribution: CentOS/archlinux
Posts: 40

Rep: Reputation: 16
This is a common problem when dual booting with Windows.
Windows wants the BIOS clock or system time to be in 'localtime' and linux is thinking it is in GMT/UTC and adjusting the clock to the system time in UTC + your timezone
.
To fix this you just need to edit
Code:
/etc/sysconfig/clock
and change
Code:
UTC = true
to
Code:
UTC = false
I would:
  • boot to linux and make the above change (don't change any other time settings)
  • boot to the bios and make sure the clock is set to your localtime
  • boot to Windows and check the time is correct
  • reboot into linux and check clock is now correct
 
Old 06-17-2009, 08:29 PM   #3
mcpoon
LQ Newbie
 
Registered: Jun 2009
Posts: 12

Original Poster
Rep: Reputation: 0
looinix,
Tq for your help. It works fine after I disabled the UTC. Many thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to set time : Permission denied dipuasks Linux - General 7 04-10-2010 05:10 PM
Time skew of 580 min when I set my time zone in Gentoo scooter2 Linux - Newbie 1 03-05-2009 10:27 AM
How can I change/set the MAC address at boot time under SuSE? Basel Linux - Networking 6 10-20-2006 12:23 AM
Where does RH8 daily set system time to hardware clock time smartnorman Red Hat 1 05-24-2006 02:42 PM
Unable to logon on as non-root user after update as unable to set executable context pls198 Fedora 2 04-09-2004 11:41 AM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration