LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2007, 07:35 AM   #1
jarred
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Rep: Reputation: 0
Unable to build the NVIDIA kernel module.


I really want some help as im new to linux, and i want to progress on. BUT there's a slight problem. I am trying to install my graphics card driver (GeForce 6200 pci) but as it tries to install i get errors. So can someone please help me! (below is the report) And thanks to those who will take the time to overcome my problem.

Linux dist: Mandriva Free 2007

Thanks,

Jarred

Quote:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Mar 18 23:21:27 2007

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /root/tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Kernel source path: '/lib/modules/2.6.17-5mdv/source'
-> Performing CC test with CC="cc".
-> Performing rivafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.17-5mdv/sou
rce SYSOUT=/lib/modules/2.6.17-5mdv/build'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.17-5mdv/build KBUILD_VERBOSE=1 -C
/lib/modules/2.6.17-5mdv/source SUBDIRS=/root/tmp/selfgz17610/NVIDIA-Linux-x
86-1.0-7167-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.17-5mdv/build \
KBUILD_SRC=/usr/src/linux-2.6.17-5mdv \
KBUILD_EXTMOD="/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src
/nv" -f /usr/src/linux-2.6.17-5mdv/Makefile modules
mkdir -p /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/.tm
p_versions
rm -f /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/.tmp_v
ersions/*

WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
is missing; modules will have no dependencies and modversions.

make -f /usr/src/linux-2.6.17-5mdv/scripts/Makefile.build obj=/root/tmp/self
gz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /root/tmp/selfgz176
10/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv
/.nv.o.d -nostdinc -isystem /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/incl
ude -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.17-5mdv/include -
include include/linux/autoconf.h -I/root/tmp/selfgz17610/NVIDIA-Linux-x86-
1.0-7167-pkg1/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -f
no-strict-aliasing -fno-common -O2 -fno-omit-frame-pointer -fno-optimize-sib
ling-calls -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -ffre
estanding -I/usr/src/linux-2.6.17-5mdv/include/asm-i386/mach-default -Iinclu
de/asm-i386/mach-default -Wdeclaration-after-statement -Wno-pointer-sign -I
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv -Wall -Wimpl
icit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpoint
er-arith -Wno-multichar -Werror -O -fno-common -MD -Wsign-compare -Wno-cast-
qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU_SO
URCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -D
NV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7167 -DNV_UNIX -DNV_
LINUX -DNV_INT64_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_MULTIPLE_BRID
GE_AGPGART_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRE
SENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv)" -D"KB
UILD_MODNAME=KBUILD_STR(nvidia)" -c -o /root/tmp/selfgz17610/NVIDIA-Linux-x8
6-1.0-7167-pkg1/usr/src/nv/nv.o /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7
167-pkg1/usr/src/nv/nv.c
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:559,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-linux.h:69,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv.c:14:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:246: warning: wrong type argument to increment
In file included from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv.c:14:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
33:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
61:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:6
83:2: warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c: At top
level:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:201: wa
rning: initialization from incompatible pointer type
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:223:5:
warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c: In fun
ction ‘nvos_get_agp_device_by_class’:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:404: wa
rning: implicit declaration of function ‘pci_find_class’
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:404: wa
rning: assignment makes pointer from integer without a cast
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:418: wa
rning: assignment makes pointer from integer without a cast
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c: In fun
ction ‘nvidia_init_module’:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:970: wa
rning: implicit declaration of function ‘pm_register’
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:970: wa
rning: assignment makes pointer from integer without a cast
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:1036: w
arning: implicit declaration of function ‘pm_unregister’
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:1167:5:
warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c: In fun
ction ‘nv_kern_mmap’:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:1541: w
arning: implicit declaration of function ‘remap_page_range’
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c: In fun
ction ‘nvos_count_devices’:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:3230: w
arning: assignment makes pointer from integer without a cast
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv.c:3235: w
arning: assignment makes pointer from integer without a cast
cc -Wp,-MD,/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv
/.nv-vm.o.d -nostdinc -isystem /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/i
nclude -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.17-5mdv/includ
e -include include/linux/autoconf.h -I/root/tmp/selfgz17610/NVIDIA-Linux-x
86-1.0-7167-pkg1/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs
-fno-strict-aliasing -fno-common -O2 -fno-omit-frame-pointer -fno-optimize-s
ibling-calls -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -ff
reestanding -I/usr/src/linux-2.6.
17-5mdv/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -Wdecl
aration-after-statement -Wno-pointer-sign -I/root/tmp/selfgz17610/NVIDIA-Li
nux-x86-1.0-7167-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wf
ormat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror
-O -fno-common -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_
NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__K
ERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7
167 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG
-DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_
DISABLE_DEVICE_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUI
LD_STR(nv_vm)" -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /root/tmp/selfgz
17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-vm.o /root/tmp/selfgz1761
0/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-vm.c
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:559,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-linux.h:69,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-vm.c:14:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:246: warning: wrong type argument to increment
In file included from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-vm.c:14:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
33:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
61:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:6
83:2: warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
cc -Wp,-MD,/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv
/.os-agp.o.d -nostdinc -isystem /usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/
include -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.17-5mdv/inclu
de -include include/linux/autoconf.h -I/root/tmp/selfgz17610/NVIDIA-Linux-
x86-1.0-7167-pkg1/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraph
s -fno-strict-aliasing -fno-common -O2 -fno-omit-frame-pointer -fno-optimize
-sibling-calls -pipe -msoft-float -mpreferred-stack-boundary=2 -march=i686 -
ffreestanding -I/usr/src/linux-2.6.17-5mdv/include/asm-i386/mach-default -Ii
nclude/asm-i386/mach-default -Wdeclaration-after-statement -Wno-pointer-sign
-I/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv -Wall -Wi
mplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpo
inter-arith -Wno-multichar -Werror -O -fno-common -MD -Wsign-compare -Wno-ca
st-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GNU
_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DN
V_MINOR_VERSION=0 -DNV_PATCHLEVEL=7167 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -D
NVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV
_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISA
BLE_DEVICE_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_S
TR(os_agp)" -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /root/tmp/selfgz176
10/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-agp.o /root/tmp/selfgz17610/
NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-agp.c
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:559,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-linux.h:69,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/os-agp.c:24:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:246: warning: wrong type argument to increment
In file included from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/os-agp.c:24:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
33:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
61:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:6
83:2: warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
cc -Wp,-MD,/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv
/.os-interface.o.d -nostdinc -isystem /usr/lib/gcc/i586-mandriva-linux-gnu/
4.1.1/include -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.17-5mdv
/include -include include/linux/autoconf.h -I/root/tmp/selfgz17610/NVIDIA-
Linux-x86-1.0-7167-pkg1/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-tr
igraphs -fno-strict-aliasing -fno-common -O2 -fno-omit-frame-pointer -fno-op
timize-sibling-calls -pipe -msoft-float -mpreferred-stack-boundary=2 -march=
i686 -ffreestanding -I/usr/src/linux-2.6.17-5mdv/include/asm-i386/mach-defau
lt -Iinclude/asm-i386/mach-default -Wdeclaration-after-statement -Wno-pointe
r-sign -I/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv -W
all -W
implicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wp
ointer-arith -Wno-multichar -Werror -O -fno-common -MD -Wsign-compare -Wno-c
ast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -D_GN
U_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -D
NV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7167 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -
DNVCPU_X86 -UDEBUG -U_DEBUG -DNDEBUG -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -D
NV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DMODULE -D"KBUI
LD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(os_interface)" -D"KBUILD_MODNAM
E=KBUILD_STR(nvidia)" -c -o /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-
pkg1/usr/src/nv/os-interface.o /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-71
67-pkg1/usr/src/nv/os-interface.c
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:559,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/nv-linux.h:69,
from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/os-interface.c:26:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:246: warning: wrong type argument to increment
In file included from /root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv/os-interface.c:26:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
33:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:2
61:5: warning: "NV_ENABLE_MEM_TRACKING" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/nv-linux.h:6
83:2: warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-interface
.c:667:5: warning: "DEBUG" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-interface
.c:679:5: warning: "DEBUG" is not defined
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-interface
.c: In function ‘os_set_mlock_capability’:
/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/nv/os-interface
.c:1260: error: ‘struct task_struct’ has no member named ‘rlim’
make[4]: *** [/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/usr/src/n
v/os-interface.o] Error 1
make[3]: *** [_module_/root/tmp/selfgz17610/NVIDIA-Linux-x86-1.0-7167-pkg1/u
sr/src/nv] Error 2
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
THIS HAS BEEN EDITED: Mon 19 Mar, 16:39 EST

Last edited by jarred; 03-19-2007 at 01:39 AM.
 
Old 03-18-2007, 08:19 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
That version (5336) is over two years old!!! Why not try with something newer as a start? http://www.nvidia.com/object/unix.html
 
Old 03-18-2007, 11:42 AM   #3
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
additionally, you will also have to have the "kernel-sources" (a.k.a. kernel headers, but from memory mandriva should probably have them listed as kernen-sources) installed.

It may be that you need to check what kernel version you have installed. Open a terminal/konsole window and type the command
Code:
uname -r
That gives you the installed kernel name - then you'd need to go into the package manager (again from memory, it's in "configure my computer" and called "rpmdrake+" but they may have changed that). In any case you want to see if the kernel-sources package is installed - if not, install it - you must ensure that the numbers part of the package name are EXACTLY the same as the kernel version that you got earlier, if they are higher, then theres usually a new kernel version available for install that match the kernel-sources.

Only then will you find that the nvidia driver installs OK. It's not that it's "picky", but as you might have seen from the error that you posted, theres no pre-compiled version available for the kernel that you have, so it needs both the kernel and kernel-sources so it can build one.

Arow is correct in the presumption that 5336 is quite old - it's only the latest version for IA64 and I'm guessing that you probably won't be using that particular architecture (but it's not completely impossible though was only for Itanium processors). So for most 9755 is gonna do the trick.

regards

John
 
Old 03-19-2007, 01:40 AM   #4
jarred
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks BUT

The error i posted wasnt mine. Sorry.

I dont know why i pasted that and how i got it. But please read it now as i edited it and hopefully that one makes more sense lol. Thanks!

Jarred
 
Old 03-19-2007, 06:14 AM   #5
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Version 7167 => March 2005...same answer as before.
 
Old 03-20-2007, 02:15 AM   #6
jarred
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks

Okay got the latest one, installed FINE and is working had the white cube screen but fixed it. But one last thing i need to get working is WoW (World of Warcraft). I have been able to run UT99 + Ut2k4 but when i try to run wow, nothing happens or anything. Any possibilities why? am i missing some packages? Please help.

Thanks

Jarred
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to build nvidia kernel module Cyber Maid Linux - Software 10 01-28-2007 07:44 AM
Error: Unable to build the NVIDIA kernel module. Dachy Slackware 3 02-17-2006 03:46 AM
Unable to build nvidia module martincho Linux - Hardware 3 05-21-2005 08:49 PM
Unable to build the NVIDIA kernel module subaruwrx Linux - General 2 03-12-2005 09:15 PM
Unable to build NVIDIA kernel module / determin kernel version Night Ink Fedora 2 05-31-2004 05:54 PM


All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration