LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2004, 06:57 AM   #1
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Rep: Reputation: 15
Turn on ACPI on boot


Found a hint on Inet that you must add "acpi=on" to grub.conf in the kernel parameters to turn on ACPI on boot...

is it the file /etc/grub.conf?

in the grub.conf there is a line :
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet

do I simply add "acpi=on" at the end of this line, so that it becomes:
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet acpi=on
??

Don't want to mess up a correct booting


smokylux
 
Old 05-23-2004, 07:20 AM   #2
Axo
Member
 
Registered: May 2003
Distribution: Debian
Posts: 153

Rep: Reputation: 17
I dont use Grub but this should work
Code:
append= acpi=on
 
Old 05-23-2004, 07:23 AM   #3
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
first of all you must know that ACPI is enabled in your kernel; this isn't a fact always. but you'll see it when you add the line and if it doesn't become enabled, you know you'll have to deal with the kernel first....anyway, let's assume your kernel has enabled ACPI.

usually Grub's "config" file should in my opinion be in your boot partition...and called menu.lst (at least on my pc). so, as root,

cd /boot/grub

and if you don't get any errors telling you that you don't have such dir, do

ls

and see if you have menu.lst or grub.conf or something. if you do, that's our file...now open it with some text editor and locate the line that tells grub about your linux kernel, like

kernel /boot/bzImage root=/dev/discs/disc0/part1 hdd=ide-scsi

or similar (it looks a bit different on your config, of course), and then apply the option at the end of the line like this (using the example line above)

kernel /boot/bzImage root=/dev/discs/disc0/part1 hdd=ide-scsi acpi=on

then save and reboot..grub doesn't need to be re-run/re-installed like lilo after making changes, so that should be enough. and again, if this won't help, then you don't have ACPI support compiled in your kernel..

if you don't have /boot/grub/menu.lst or /boot/grub/grub.conf or like that, you have to search for where your grub is installed..I guess it is usually in /boot/grub, so that's why using some /etc/grub.conf doesn't help I think. except, of course, if you have installed your grub into /etc, but that'd be somehow weird.. so see your /boot/

and one more thing: if you happen to accidentally edit a wrong file, or make a typing error and save it in the real config file, it shouldn't stop your booting...the last option then just (I think) gets ignored, and perhaps you get an error message telling you it's not ok. so you can't mess up your boot with this, unless you really work hard for it
 
Old 05-23-2004, 07:32 AM   #4
muxman
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 203

Rep: Reputation: 32
When your computer first boots and you are at the grub menu press the e key. This will put grub into edit mode. Choose the line you want to edit and press enter, in this case you kernel line. Add your extra settings to that line and try it out. This will only be in effect for this boot. This allows you to try out an option without making a permant chage to your grub settings and that way if the change does not work, reboot and you are back to the settings you had before you changed anything. If all works out then make a change to your menu.lst or grub.conf so the new settings will be permanent.
 
Old 05-23-2004, 07:44 AM   #5
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Original Poster
Rep: Reputation: 15
thx to all for help!

the menu.lst is just a symbolic link to grub.conf by the way...

got it working, got starting acpi deamon in boot sequence!
 
Old 05-23-2004, 08:39 AM   #6
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
good
 
Old 05-24-2004, 09:35 PM   #7
ratishkurian
LQ Newbie
 
Registered: Apr 2003
Posts: 9

Rep: Reputation: 0
thanks guys..needed to use the option acpi=off in GRUB

and this was just the right answer

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off ACPI to use Linux, Linspire 5.0 stevenpowers Linux - Hardware 0 09-12-2005 05:36 PM
Turn off screensaver on boot ericcarlson Linux - Software 1 03-11-2005 06:22 PM
How to turn off ACPI MRK Fedora 2 12-13-2004 03:28 PM
ACPI: edit lid.sh to blank screen, turn backlight off, no-suspend ????? Outabux Debian 5 11-15-2004 09:11 AM
How do I turn off startx a boot up? gw1500se Mandriva 4 03-13-2004 08:32 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration