LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2012, 03:55 PM   #1
esornep
Member
 
Registered: Jun 2012
Posts: 48

Rep: Reputation: Disabled
Trouble using LFS .......


installing the package Glibc-2.14.1

the ./configure runs fine and makes a 'make' file

then the running the make file gives the following error ....

In file included from ../sysdeps/unix/sysv/linux/syslog.c:10:0:
../misc/syslog.c: In function '__vsyslog_chk':
../misc/syslog.c:144:9: warning: variable 'prioff' set but not used [-Wunused-but-set-variable]
../misc/syslog.c:123:1: sorry, unimplemented: inlining failed in call to 'syslog': function body not available
../misc/syslog.c:155:9: sorry, unimplemented: called from here
make[2]: *** [/home/strings/LFS/sources/glibc-2.14.1/glibc-build/misc/syslog.o] Error 1
make[2]: Leaving directory `/home/strings/LFS/sources/glibc-2.14.1/misc'
make[1]: *** [misc/subdir_lib] Error 2
make[1]: Leaving directory `/home/strings/LFS/sources/glibc-2.14.1'
make: *** [install] Error 2

but it creates a install file which runs and ends at the same point ......

first question : how to solve it

second question : when the make file is itself how can a install file come up

thanks
 
Old 06-26-2012, 06:20 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,587

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
Don't the instructions say to make a glibc-build instruction?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] pure 32 bit LFS Version SVN-20110110 trouble installing libX11 in BLFS mcamp73 Linux From Scratch 4 01-22-2011 04:42 AM
[SOLVED] LFS 6.7 : $LFS/sources and $LFS/tools folders missing prakashsince92 Linux From Scratch 5 12-09-2010 03:26 PM
Trouble compiling Binutils in LFS step. rosster Linux - Newbie 1 07-20-2008 05:21 PM
LFS install trouble -- using debian sarge as host gremesh Linux From Scratch 1 11-23-2004 07:53 PM
LFS install trouble -- using Knoppix 3.6 as host hell_carnage Linux From Scratch 3 11-18-2004 08:09 AM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration