LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2009, 04:09 PM   #1
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Rep: Reputation: 0
Trouble Install Autoconf package


Trouble installing AutoConf (Red Hat 5.2).

I downloaded autoconf-2.10.tar.gz from the gnu.org and followed the directions in the accompanying "INSTALL" file, but I don't see any sign that it works. When I type "autoconf" in the command prompt, my shell says there is no such command. I'm not sure of the proper syntactical usage of autoconf either.

So the questions are how do I install autoconf and confirm that it was successfully installed?
 
Old 03-30-2009, 04:16 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
what did you do?
did you recieved error messages?
did you need to compile?
what is the output from
Code:
whereis autoconf
 
Old 03-30-2009, 04:19 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,926

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by djpme View Post
Trouble installing AutoConf (Red Hat 5.2).

I downloaded autoconf-2.10.tar.gz from the gnu.org and followed the directions in the accompanying "INSTALL" file, but I don't see any sign that it works. When I type "autoconf" in the command prompt, my shell says there is no such command. I'm not sure of the proper syntactical usage of autoconf either.

So the questions are how do I install autoconf and confirm that it was successfully installed?
Do you mean RedHat 5.2, or RedHat ENTERPRISE SERVER 5.2? RH5.2 is very, VERY old....

How do you install it? Follow the instructions, which you did. You don't say whether or not you got any errors or messages, though. If you didn't, chances are it worked and installed. You probably don't have autoconf in your PATH, which is why it's not found.

As root, type in "find / -name autoconf*". It'll chew on this for a bit, watch what it returns. Then type in "/path/to/where/autoconf", to run it. You can also add whatever directory name to your existing PATH.

And if you're using RHEL5.2, you should be able to use "yum install autoconf", and it'll do it for you.
 
Old 03-30-2009, 04:32 PM   #4
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
what did you do?
did you recieved error messages?
did you need to compile?
what is the output from
Code:
whereis autoconf
Repo, I did not receive any error messages. The output from whereis autoconf is /usr/local/bin/autoconf. So now that I know its there how do I get it to run?

My $PATH variable contains /usr/local/bin and the privileges are -rwxr-xr-x.

When i type man autoconf I get not "no manual entry for autoconf". Is that normal?

Last edited by djpme; 03-30-2009 at 04:42 PM.
 
Old 03-30-2009, 04:34 PM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
what happens when you type
Code:
/usr/local/bin/autoconf
 
Old 03-30-2009, 04:40 PM   #6
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TB0ne View Post
Do you mean RedHat 5.2, or RedHat ENTERPRISE SERVER 5.2? RH5.2 is very, VERY old....

How do you install it? Follow the instructions, which you did. You don't say whether or not you got any errors or messages, though. If you didn't, chances are it worked and installed. You probably don't have autoconf in your PATH, which is why it's not found.

As root, type in "find / -name autoconf*". It'll chew on this for a bit, watch what it returns. Then type in "/path/to/where/autoconf", to run it. You can also add whatever directory name to your existing PATH.

And if you're using RHEL5.2, you should be able to use "yum install autoconf", and it'll do it for you.

TB0ne, you are right it looks like I may have installed but how do I determine if I did installed it correctly. I ran "find / -name autoconf*" and got these results
Code:
/proc/sys/net/ipv6/conf/eth0/autoconf
/proc/sys/net/ipv6/conf/default/autoconf
/proc/sys/net/ipv6/conf/all/autoconf
/proc/sys/net/ipv6/conf/lo/autoconf
/autoconf-folder/autoconf-2.10/autoconf
/usr/local/share/autoconf
/usr/local/bin/autoconf
My $PATH variable does contain the very last entry /usr/local/bin.

And the Red Hat/Linux version is Red Hat Enterprise Linux Server release 5.2 (Tikanga)
 
Old 03-30-2009, 04:42 PM   #7
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
what happens when you type
Code:
/usr/local/bin/autoconf
This is what I get
Code:
[root@machineABC bin]# /usr/local/bin/autoconf
autoconf: configure.in: No such file or directory
 
Old 03-30-2009, 05:03 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Seems to me you need this one
/autoconf-folder/autoconf-2.10/autoconf
 
Old 03-30-2009, 05:50 PM   #9
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
Seems to me you need this one
/autoconf-folder/autoconf-2.10/autoconf
Code:
[root@g500-machineABC bin]# cd /autoconf-folder/autoconf-2.10/
[root@gs500L-alfproto autoconf-2.10]# autoconf 
[root@gs500L-alfproto autoconf-2.10]# man autoconf
No manual entry for autoconf
[root@g500-machineABC autoconf-2.10]#
So when I run the autoconf instance /autoconf-folder/autoconf-2.10/ nothing happens, which may be better than a error...I don't know. If I add /autoconf-folder/autoconf-2.10 to my $PATH then I get same error
Code:
[root@gs00L-machineABC bin]# autoconf
autoconf: configure.in: No such file or directory
Is this an installation error or am I just using autoconf incorrectly?
 
Old 03-30-2009, 08:27 PM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
i would uninstall then rebuild but this time use the --prefix option so that it dose NOT install in the unused " /usr/local"
Code:
cd /to/where/you/put/autoconf-2.10
su 
make uninstall 
make distclean
exit
./configure --prefix=/usr
make
su
make install
please see
Code:
./configure --help
for ALL the build options that you need to pass to "configure"
 
Old 03-31-2009, 02:18 PM   #11
djpme
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by John VV View Post
i would uninstall then rebuild but this time use the --prefix option so that it dose NOT install in the unused " /usr/local"
Code:
cd /to/where/you/put/autoconf-2.10
su 
make uninstall 
make distclean
exit
./configure --prefix=/usr
make
su
make install
please see
Code:
./configure --help
for ALL the build options that you need to pass to "configure"

I tried this and got the same results..."man autoconf" I still get "no manual entry for autoconf".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2. arubin Slackware 6 09-24-2008 04:31 AM
Trouble installing Autoconf 2.59 shadowsliver Linux - Software 0 01-30-2005 01:31 PM
Autoconf doesn't install properly MockieMoo Linux - Newbie 5 04-12-2004 06:34 AM
gcc/autoconf tools/ package question wr3ck3d Programming 0 04-08-2004 02:11 AM
Need autoconf 2.5 but can't install old one TCv1 Mandriva 2 03-25-2004 06:39 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration