LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2003, 11:27 PM   #1
hanleychan
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Rep: Reputation: 0
Total linux newbie I don't know anything and need help


Hi,
I just installed mandrake linux v9.1 just to see how it was like. I am having problems trying to get the sound to work. I get no sound at all for some reason. Does anyone know how to fix this. Also the scroll wheel on my mouse doesn't seem to work. I tried to look for linux drivers on the logitech website but they only have the drivers for windows. I don't know anything about linux because I use windows so I am sorry if I said anything stupid.

Thanks
 
Old 09-28-2003, 11:33 PM   #2
je_fro
Member
 
Registered: Nov 2002
Location: /texas/austin/home/desk
Distribution: Gentoo
Posts: 341

Rep: Reputation: 30
The first thing you need to do is start reading. I hate to give RTFM replies, but you're going to have to do it.
To fix your mouse you'll need to edit the file /etc/X11/XF86Config to look similar to mine:
# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5" <--------ADD THIS LINE

As for sound, you need to find out what kind of soundcard, and whether your distro is using ALSA or OSS or aRTs or what...
search this site for your card+mandrake and I'm sure you'll find your answer...
http://www.google.com/linux

Good Luck!!
 
Old 09-28-2003, 11:50 PM   #3
hanleychan
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Original Poster
Rep: Reputation: 0
when I try to edit it it says the file cannot be saved please check if you have write permission
 
Old 09-29-2003, 12:39 AM   #4
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Rep: Reputation: 16
Log in as root to edit the file.
 
Old 09-29-2003, 12:43 AM   #5
hanleychan
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Original Poster
Rep: Reputation: 0
how do i do that? sorry I don't know much.

at least I managed to get the sound to work. stupid me i had the volume set to mute
 
Old 09-29-2003, 12:45 AM   #6
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
vi
 
Old 09-29-2003, 12:52 AM   #7
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
ratz wrong button


what i meant to say was

open terminal

su
<enter password>
vi /etc/X11/XF86Config
*************be very careful ***************

look at the part you want to change

press "a" this is the insert key -gets you into editing mode

use the arrow keys to move around
bakspace to remove lines

when it looks right
hit the esc key a coupla times till it beeps at ya

*******now the important part **************************

if you think it looks good ----
type
:wq!

( stand for write quit now )

if you have any doubts as to whether you have flubbed it up

type

:q!
( stand for quit now without saving )
 
Old 09-29-2003, 12:57 AM   #8
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
I would expect that Mandrake has GUIs to be able to set the scroll wheel. On the mute front, I don't know why, but it does seem to get installed that way. Ahhh, here is the link.

http://doc.mandrakelinux.com/Mandrak...ousedrake.html

See if your's is listed and selecting it works for you. Open the Control Panel, Peripherals Mouse. There you can configure the mouse wheel, etc.

RO
 
Old 09-29-2003, 01:03 AM   #9
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
Quote:
Originally posted by je_fro
The first thing you need to do is start reading. I hate to give RTFM replies, but you're going to have to do it.
To fix your mouse you'll need to edit the file /etc/X11/XF86Config to look similar to mine:
# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5" <--------ADD THIS LINE

As for sound, you need to find out what kind of soundcard, and whether your distro is using ALSA or OSS or aRTs or what...
search this site for your card+mandrake and I'm sure you'll find your answer...
http://www.google.com/linux

Good Luck!!
My mouse configuration is:

# Pointer section
# **********************************************************************

Section "Pointer"
Protocol "IMPS/2"
Device "/dev/psaux"
ZAxisMapping 4 5

# For wheel support - can not be used with Emulate3Buttons
#
# ZAxisMapping 4 5

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
# Protocol "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice
# BaudRate 9600
# SampleRate 150

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
# Emulate3Buttons
Emulate3Timeout 50

# ChordMiddle is an option for some 3-button Logitech mice
# ChordMiddle

EndSection

But i still can't scroll with my mouse. What is the problem?
 
Old 09-29-2003, 01:27 AM   #10
je_fro
Member
 
Registered: Nov 2002
Location: /texas/austin/home/desk
Distribution: Gentoo
Posts: 341

Rep: Reputation: 30
Quotes.

Option "ZAxisMapping" "4 5" <--------ADD THIS LINE EXACTLY
 
Old 09-29-2003, 02:46 PM   #11
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
Quote:
Originally posted by je_fro
Quotes.

Option "ZAxisMapping" "4 5" <--------ADD THIS LINE EXACTLY
I did, and still can't scroll.
 
Old 09-29-2003, 03:48 PM   #12
hanleychan
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Original Poster
Rep: Reputation: 0
doesn't work for me either
 
Old 09-29-2003, 03:58 PM   #13
WhiteChedda
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Mandrake 9.1 for now
Posts: 205

Rep: Reputation: 30
Quote:
Originally posted by hanleychan
doesn't work for me either
Which logitech mice are you using? It might be that button 4 and 5 are not the scroll wheel with some of the newer Logitech umpteen button mice.
 
Old 09-29-2003, 04:52 PM   #14
edu2
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
Mine is a Logitech cordless MouseMan optical.
 
Old 09-29-2003, 09:37 PM   #15
hanleychan
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Original Poster
Rep: Reputation: 0
I got it to work. I went into mouse configuration and changed it to usb wheel mouse then I unplugged the mouse from my ps/2 port and plugged my mouse into the usb port and rebooted linux and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Total Linux Programming Newbie binarybob0001 Programming 4 04-01-2005 04:12 PM
Total newbie interested in linux Kushan Linux - Newbie 17 08-14-2004 10:22 PM
Total linux Newbie Shibby Slackware 21 10-01-2003 11:28 AM
Total newbie to Linux needs help. Please jarget Linux - Software 3 08-24-2003 08:31 PM
Total Linux Newbie Ghengis_Khan LinuxQuestions.org Member Intro 2 05-19-2003 02:48 PM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration