LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2014, 02:13 AM   #1
jobart08
Member
 
Registered: Sep 2014
Posts: 72

Rep: Reputation: Disabled
Tomcat 8 + JRE 8 on Debian Wheezy


Good day folks,

Im new to debian and was installing Tomcat 8 and JRE1.8.0 on Wheezy. When I start tomcat, I get this output. It says started but no tomcat process is displayed when I ps -ef | grep tomcat. Google is not much of help.

tomcat8@BDOULXU469:~$ ./apache-tomcat-8.0.12/bin/startup.sh
Using CATALINA_BASE: /home/tomcat8/apache-tomcat-8.0.12
Using CATALINA_HOME: /home/tomcat8/apache-tomcat-8.0.12
Using CATALINA_TMPDIR: /home/tomcat8/apache-tomcat-8.0.12/temp
Using JRE_HOME: /usr/local/src/jre1.8.0
Using CLASSPATH: /home/tomcat8/apache-tomcat-8.0.12/bin/bootstrap.jar:/home/tomcat8/apache-tomcat-8.0.12/bin/tomcat-juli.jar
Tomcat started.
tomcat8@BDOULXU469:~$ tail -f apache-tomcat-8.0.12/logs/catalina.out
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap
Error: Could not find or load main class org.apache.catalina.startup.Bootstrap

Any help would be greatly appreciated.

Thanks
 
Old 10-06-2014, 10:29 PM   #2
jobart08
Member
 
Registered: Sep 2014
Posts: 72

Original Poster
Rep: Reputation: Disabled
Turns out the Tomcat package given to me was incomplete. I downloaded a new one and it worked perfectly. Noob.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Now I've done it - Debian dual boot (Sid, Wheezy) grub overwritten, lost Wheezy? ShaneRoach Debian 23 02-02-2014 02:28 PM
LXer: Debian Linux vs. Debian kFreeBSD With Squeeze & Wheezy LXer Syndicated Linux News 0 12-12-2012 10:00 PM
[SOLVED] Newly installed debian sid & saved debian wheezy home would like to transfer files EDDY1 Linux - Newbie 11 01-20-2012 07:43 PM
LXer: Debian to offer MultiArch support with Debian Wheezy 7 in 2013 LXer Syndicated Linux News 0 08-11-2011 01:50 AM
LXer: Debian looking at a June 2012 freeze for Debian Wheezy LXer Syndicated Linux News 0 08-10-2011 10:00 AM


All times are GMT -5. The time now is 02:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration