LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-27-2016, 04:01 PM   #1
jzoudavy
Member
 
Registered: Apr 2012
Distribution: Ubuntu, SUSE, Redhat
Posts: 180

Rep: Reputation: Disabled
tcp kernel setting for rmem_max and wmem_max not taking effect instantaneously


Hi all

Recently I am working on some SFTP throughput issue and found that by increasing the rmem_max and wmem_max at the receiving server we were able to boost from a SFTP rate of 400KBps to 8.9MBps.

But what's weird is during the test, right after I ran echo command,

Code:
echo "16777216" > /proc/sys/net/core/rmem_max
echo "16777216" > /proc/sys/net/core/wmem_max
The speed increase was small. We got 1.5MBps. Then I had some other stuff to do and left the server along for like an hour. During which I know for sure no one touched it as it was a temp setup that I made just for that test. Then when we tried the test again we were able to get 8.9MBps now pretty consistently.

I was under the impression when I make such changes to kernal params it should take effect instantaneously. But clearly this is not the case here.

We are running Arch Linux, but when we tried the same thing on a SUSE10 server we got the same result. Immediately after applying the new kernel param we do not see the speed increase that we are expecting.
 
Old 04-27-2016, 10:55 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,599

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
Quote:
Originally Posted by jzoudavy View Post
Hi all

Recently I am working on some SFTP throughput issue and found that by increasing the rmem_max and wmem_max at the receiving server we were able to boost from a SFTP rate of 400KBps to 8.9MBps.

But what's weird is during the test, right after I ran echo command,

Code:
echo "16777216" > /proc/sys/net/core/rmem_max
echo "16777216" > /proc/sys/net/core/wmem_max
The speed increase was small. We got 1.5MBps. Then I had some other stuff to do and left the server along for like an hour. During which I know for sure no one touched it as it was a temp setup that I made just for that test. Then when we tried the test again we were able to get 8.9MBps now pretty consistently.

I was under the impression when I make such changes to kernal params it should take effect instantaneously. But clearly this is not the case here.

We are running Arch Linux, but when we tried the same thing on a SUSE10 server we got the same result. Immediately after applying the new kernel param we do not see the speed increase that we are expecting.
Almost instantly - there is a delay imposed by existing open connections. There may be other things that can cause delays that I'm not familiar with.

The amount of delay depends on the parameter, and what may be active using the facility controlled by the parameter.
 
  


Reply

Tags
kernel, sftp, tcp, throughput


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] XFCE 4.12 not taking effect aditya.mukundan Linux - Software 6 07-16-2015 12:51 AM
[SOLVED] umask change not taking effect mufy AIX 2 01-10-2010 12:39 AM
[SOLVED] umask change not taking effect mufy Linux - Newbie 3 01-10-2010 12:37 AM
Changes to GRUB menu.lst not taking effect blair Mandriva 4 06-04-2005 10:52 AM
/etc/crontab adjustment not taking effect :-( furrie *BSD 4 10-08-2002 01:33 PM


All times are GMT -5. The time now is 12:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration