LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2005, 06:51 PM   #1
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Rep: Reputation: 30
Suse 10.0 usb mousewheel


Hi,

I use Suse 10.0, I have tried to use yast to enable the usb mouse wheel, but nothing happens, event after vtrl-alt-backspace.

Can I do something manually, or can someone explain me in detail where to press to make it work ??

The correct X86Config entry would also do fine :-)
 
Old 11-20-2005, 07:23 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
Option "ZAxisMapping" "4 5"

This works for me.
 
Old 11-20-2005, 10:39 PM   #3
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
this is my configuration when it does not work:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "Name" "PS/2 on USB"
Option "Protocol" "PS/2"
Option "Vendor" "USB-Mouse"
Option "ZAxisMapping" "4 5"
EndSection
 
Old 11-21-2005, 06:04 AM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
Due to fact mouse(s) have always worked for me I've never investigated what is the difference between protocols. Perhaps you should try another protocol. My working conf is below.

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection
 
Old 11-21-2005, 06:33 PM   #5
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
Lightbulb

Worked perfectly :-)

Thanks!!
 
Old 02-01-2006, 03:51 PM   #6
ghandi3737
LQ Newbie
 
Registered: Aug 2004
Location: Lancaster
Distribution: slackware 10.0
Posts: 3

Rep: Reputation: 0
mousewheel configuration

and which configuration file should that line go into? I'm using knoppix that i've installed to HD.
 
Old 02-01-2006, 04:26 PM   #7
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,959

Rep: Reputation: Disabled
/etc/X11/xorg.conf

This is where mine is and AFAIK this is the first place where X server looks for it. It may be elsewhere in Knoppix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mousewheel in x drigz Linux - Hardware 4 05-16-2004 04:42 AM
IntelliMouse USB Mousewheel mopron Linux - Hardware 1 10-22-2003 09:08 AM
Wheres the mousewheel? Boom Linux - Newbie 6 02-16-2003 07:02 AM
mousewheel MrPolite Linux - General 5 11-03-2002 02:52 PM
MouseWheel? MrPolite Linux - General 1 08-25-2002 10:34 PM


All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration