LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2008, 09:19 AM   #1
htetnaing
LQ Newbie
 
Registered: Aug 2008
Posts: 16

Rep: Reputation: 0
"su" commands not working properly


Hi everyone,

I'm new to this forum and Linux. I'm using Suse Linux OS. It worked fine as if it's always but this morning I left my computer on and went off somewhere. When I got back and run "su" command then I found out that it's not working anymore even though I supplied the right password. I found a similar post here in this forum. I've tried that solution too though it's still not working. I changed /bin/su permission to 777 and I also checked /etc/passwd and also /etc/group , both of them are in readable format too. If I wanna be root I need to reboot and log in as root again and this is the only way I can be root at this moment and it's very inefficient. Please help me out of this.

Thanks all in advance.

P.S The error message is "su: cannot set groups: Operation not permitted", it appears whenever I run su.

Last edited by htetnaing; 08-15-2008 at 09:24 AM.
 
Old 08-15-2008, 10:23 AM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
777 are the wrong permissions for su, they should either be 04750 or 04755, the first is if you want to do a group wheel kind of thing and restrict access to su via a group.
 
Old 08-15-2008, 10:52 AM   #3
htetnaing
LQ Newbie
 
Registered: Aug 2008
Posts: 16

Original Poster
Rep: Reputation: 0
hi estabroo,

When that problem happened, I didn't know what to do and changed that permission to 777. . Thought it might have to do something with the group permission. Just now I've changed back to 755 but the same problem is occurring. I still can't use su. I've no idea what's happened to this. I didn't install any software nor changed any settings. Any idea that would lead to solve this problem would be very much appreciated. Thanks all.
 
Old 08-15-2008, 11:21 AM   #4
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
your missing the 4

04755

the 4 is the setuid bit, its what allows su to assume root privileges, su also needs to be owned by root.
 
Old 08-15-2008, 11:30 AM   #5
htetnaing
LQ Newbie
 
Registered: Aug 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Omg ! Thanks estabroo. a "4" makes difference . It's solved. I think I might need to read through changing file permission part in my Linux tutorial.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
my Fedora Box not working properly with the message " INPUT NOT SUPPORTED" siri.siri143 Linux - Newbie 3 04-15-2008 11:16 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 08:11 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
"w" command not working properly blizunt7 Linux - General 3 12-17-2005 05:07 PM
commands "init" and "modprobe" not working Diagmato Fedora 2 07-23-2005 12:44 AM


All times are GMT -5. The time now is 01:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration