LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-22-2010, 07:11 AM   #1
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Rep: Reputation: 0
start KDE from command line (Debian Lenny on iMac)


Hello,


my first posting here! I have a nearly 10 years old iMac at home and installed Lenny on (somehow, I had to thrash Mac OS 9.2 :-P). Everything was successful until now, but on entering "startkde", the screen fills with

kpersonalizer: cannot connect to X server

lines. Upon looking at other threads here I tried mdetect, installing X11... but to no avail.


Best thanks for your help!


David

Last edited by turtle21; 01-22-2010 at 07:14 AM.
 
Old 01-22-2010, 08:10 AM   #2
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
try
Code:
startx
 
Old 01-22-2010, 09:17 AM   #3
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Agrouf View Post
try
Code:
startx

Thank you... I'll try it.

And it failed, here's the console output...

Code:
X.Org X Server 1.4.2

[...]

Invalid IO Allocation b: ... e: ... correcting
end of block range ... < begin ...
Unable to find a valid framebuffer device
R128: Failed to open framebuffer device, consult warnings and/or errors...
Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

waiting for X server to begin accepting connections
giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
"..." were hexadecimal numbers (pointers, I believe you call them).

How can I resolve this problem?

Last edited by turtle21; 01-22-2010 at 09:18 AM.
 
Old 01-22-2010, 09:48 AM   #4
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
What is your graphic card?
In any case, you can use the subobtimal vesa driver (that won't use the advanced features of your graphic card if any)
Edit /etc/X11/xorg.conf
In the [Device] section, change the driver to "vesa"
 
Old 01-22-2010, 10:07 AM   #5
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
According to this site:

Video Card: Rage 128 VR 2D/3D VRAM Type: SDRAM
Details: ATI Rage 128 VR 2D/3D video with 8 MB of VRAM.

I'm trying now with the VESA configuration...
 
Old 01-22-2010, 10:15 AM   #6
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
I believe you should use the "r128" driver then
The command "lspci" will tell you what card is actually present in the box.
 
Old 01-22-2010, 10:57 AM   #7
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Hi again,


with nano I've changed the line you mentioned to "vesa". Before, it already was "r128".

Either way, with "vesa" or "r128", it still gives the errors I have written above:

Code:
X.Org X Server 1.4.2

[...]

Invalid IO Allocation b: ... e: ... correcting
end of block range ... < begin ...
Unable to find a valid framebuffer device
R128: Failed to open framebuffer device, consult warnings and/or errors...
Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

waiting for X server to begin accepting connections
giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.
 
Old 01-22-2010, 11:04 AM   #8
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Are you sure you changed the file and saved the changes? I still see the r128 driver complaining in that output, not the vesa one.

However, your best option is to upload these two files to a service like pastebin.ca:

Code:
/etc/X11/xorg.conf
/var/log/Xorg.0.log
So we can review them and see what's happening.

About kde, you need to put this line into a file called ~/.xinitrc:

Code:
startkde
Otherwise, the "startx" command will start the default session (usually twm and a few xterm's), or whatever you have configured in your distro by default, which will surely not be kde. But, if X is failing to start, that's the first thing to worry about. Kde will not work without X, of course.
 
Old 01-22-2010, 01:09 PM   #9
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
http://www.pastebin.ca/1761800 here are is the log and also the xorg.conf file...

By the way, you forced me to look up how to mount an USB stick and copy these files. Until now, I have 30 minutes of Linux experience... learning by doing.
 
Old 01-22-2010, 01:13 PM   #10
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
About kde, you need to put this line into a file called ~/.xinitrc:

Code:
startkde
Otherwise, the "startx" command will start the default session (usually twm and a few xterm's), or whatever you have configured in your distro by default, which will surely not be kde. But, if X is failing to start, that's the first thing to worry about. Kde will not work without X, of course.
Hm, and where do I put .xinitrc?
 
Old 01-22-2010, 01:37 PM   #11
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by turtle21 View Post
Hm, and where do I put .xinitrc?
In your home directory. What I wrote above is a shortcut for that. '~' means the home dir, just like $HOME. So, '~/.xinitrc' is a file called '.xinitrc' which is located in your home directory.

I will review the logs above as soon as I can. I have no idea if that will be today, real life always gets in the middle :P , but other members around might be able to help as well.
 
Old 01-22-2010, 01:44 PM   #12
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
On a quick look, I can see that your video card section has no "Driver" line on it. So, your Xorg is using using autodetection, and picking what it thinks is the best available driver, which in your case is the r128 one. That driver is throwing a few warnings (WW) and some error messages (EE) in the Xorg.0.log file. My inexperience with this concrete driver prevents me from being able to give further insight on what the problem is until I can research a bit more.

In any case, if you want to try the vesa driver, you can try to modify your video driver section, just add one line, so it looks like this:

Code:
#
Section "InputDevice"
#
        Identifier      "Generic Keyboard"
#
        Driver    "kbd"
#
        Option    "XkbRules"        "xorg"
#
        Option    "XkbModel"        "pc104"
#
        Option    "XkbLayout"       "us"
#
EndSection
#
 
#
Section "InputDevice"
#
        Identifier      "Configured Mouse"
#
        Driver    "mouse"
#
EndSection
#
 
#
Section "Device"
#
        Identifier      "Configured Video Device"
        Driver          "vesa"
#
EndSection
#
 
#
Section "Monitor"
#
        Identifier      "Configured Monitor"
#
EndSection
#
 
#
Section "Screen"
#
        Identifier      "Default Screen"
#
        Monitor  "Configured Monitor"
#
EndSection
After that, save the xorg.conf file and try again. Look at the log file and see if it's picking the vesa driver instead of the r128 one.
 
Old 01-22-2010, 03:43 PM   #13
turtle21
LQ Newbie
 
Registered: Jan 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you, but the problem is still not solved...

After "startx", it says

Code:
Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found
I hope I can get this old machine running.. some time...
 
Old 01-23-2010, 04:08 AM   #14
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
You might need to install the X vesa driver. I am not familiar with debian lenny so I am not sure what the package name is. Maybe this one?

http://packages.debian.org/lenny/xse...org-video-vesa
 
Old 01-23-2010, 09:57 AM   #15
racepres
Member
 
Registered: Feb 2009
Location: central Michigan
Distribution: Puppy/Debian/Mandriva
Posts: 56

Rep: Reputation: 18
Every thing you need to get going
http://forums.debian.net/viewtopic.php?f=16&t=20481
Worked for me "first Try"
HTh
RP

Last edited by racepres; 01-23-2010 at 10:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Lenny + Nvidia Quadro FX 380 LP -> black screen on iMac 27" siriri Linux - Hardware 1 01-26-2010 07:19 AM
how to start gnome or kde? command line? playa4002 Debian 18 11-06-2006 01:54 PM
On booting Suse 10.1 KDE doesn't start - all I can get is the command line ScoobySnacks SUSE / openSUSE 6 10-27-2006 02:04 PM
start kde-panel from command line ankur_linuxfan Linux - General 3 02-09-2005 03:12 PM
when i start slackware i only have a command line, how do i get to kde Longinus Slackware 8 12-13-2003 11:23 AM


All times are GMT -5. The time now is 11:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration