LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2012, 08:26 AM   #16
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 106

Rep: Reputation: Disabled

Hi,

Last edited by mandyapenguin; 09-07-2012 at 08:43 AM.
 
1 members found this post helpful.
Old 09-07-2012, 08:33 AM   #17
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 106

Rep: Reputation: Disabled
/etc/nologin !!!

Last edited by mandyapenguin; 09-07-2012 at 08:43 AM.
 
Old 09-07-2012, 08:41 AM   #18
mandyapenguin
Member
 
Registered: Nov 2011
Location: India
Distribution: RedHat, Cent OS, Fedora, Debian, Ubuntu
Posts: 106

Rep: Reputation: Disabled
Quote:
I checked the /etc/nologin and it was empty but I removed it anyway.

A whereis nologin found another in /usr/sbin/
this was full of hexcode. I removed it without remorse (actually renamed)
Usually the /etc/nologin file will be empty, but you have to remove it, if non-root user wanted access on ssh server. I think they had intendedly created this file on ready NAS to prevent non-root user from accessing the server. The people use this file for various purposes, the one I had used it while migrating the old server(users, groups, data, repositories etc) to new server.
You no need to delete/rename /usr/sbin/nologin file.

Quote:
Still username@nas couldnt log in. This user account was created by the readynas web interface and placed in folder /c/home/username/ but my anotheruser was placed in folder /home/anotheruser/
Removed username and recreated it in the shell. Copied authorized_keys to /home/username/.ssh/authorized_keys
Now this one works as well.
Since I never used NAS I can't say the exact problem that why ssh username@nas was not working, but can guess that there might be permission/ownership issue /c/home/username/ directory.
If your problem is solved now, then mark this thread as solved from thead tools to help others.
 
1 members found this post helpful.
Old 09-07-2012, 12:02 PM   #19
torchnw
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu, Debian, Mint, Fedora, Arch
Posts: 23

Rep: Reputation: 4
Did you check for any DenyGroup entries in /etc/ssh/sshd_config?
 
Old 09-07-2012, 05:57 PM   #20
petost
LQ Newbie
 
Registered: Sep 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Yes. There was nothing that obvious in the sshd_config.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH access problems: Can only allow users SSH access by adding to root group dhupke Slackware 10 12-21-2008 10:48 AM
SSH Problems mjchin Linux - Newbie 1 03-18-2008 10:39 PM
SSH problems newbie21209 Linux - Networking 10 06-17-2005 01:01 AM
ssh problems aizkorri Linux - Networking 6 06-07-2004 11:06 AM
ssh problems Lanmate Linux - Software 2 01-23-2004 03:05 PM


All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration