LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-24-2012, 12:20 AM   #1
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Rep: Reputation: 0
ssh and alsa


Why does ALSA refuse to work with a normal user over SSH? I use mplayer and when I use it to play an audio files from my laptop I get errors unless I run it as root and thats only if I'm doing this over SSH. If I am sitting at the computer and I use mplayer I can as either user use it and work like it should. alsa in general seems to not work over SSH as a normal user but knows it exist because it tells me the followeing

cannot open mixer: No such file or directory

Any help on this issue would be appreciated

Last edited by fatalerror0x00; 11-25-2012 at 12:57 AM. Reason: Fixed error mistake and made it more noticeable
 
Old 11-24-2012, 08:39 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,560

Rep: Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433
I just ssh'd into my laptop (Dell 1545n, Slackware 32--Current) and was able to start and manipulate alsamixer as user. Then, still as user, I started an *.mp3 with mplayer from the command line and it started playing through the laptop's speakers.

Is that the behavior you are trying for?

Are there any error messages or other output to the terminal that you could post here that might help us understand what's going on?
 
Old 11-24-2012, 09:33 PM   #3
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
I want it to output through the linux box as if I was sitting at the computer typing the command in but it won't yes there are errors but like i said thats an error I get from alsamixer exactly as I typed it to you :P give me time to type out the error in here since it's only when I'm sshed in and I will have to type it manually -.-

Last edited by fatalerror0x00; 11-25-2012 at 12:56 AM. Reason: Misread previous post
 
Old 11-24-2012, 09:42 PM   #4
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
[AO_ALSA] alsa-lib: conf.c:4246: (_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:392: (snd_func_concat) error evaluating strings
[AO_ALSA] alsa-lib: conf.c:4246 (_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
[AO_ALSA] alsa-lib: confmisc.c:1251: (snd_func_refer) error evaluating name
[AO_ALSA] alsa-lib: conf.c:4246: (_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
[AO_ALSA] alsa-lib: conf.c:4725: (snd_config_expand) Evaluate eerror: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2217snd_pcm_open_noupdate) Unknown PCM default
[AO SDL] Unable to open audio: No available audio device
---------------------------------------------------------------
no sure if the rest applies to my issue or is just something else but here it is just in case
---------------------------------------------------------------
DVB card number must be between 1 and 4
AO: [null] 44100Hz 2ch s16le (2 bytes per sample)


well theres all the stuff that could have anything to do with it not working everything else I know should be there
thanks

remember everything with alsa works fine as a normal user if i run it on my desktop directory in a terminal but soon as I ssh in and do this over the network it doesn't work unless I run the program as root

Last edited by fatalerror0x00; 11-24-2012 at 09:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Slackware 9 12-04-2008 07:29 AM
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Linux - Hardware 2 11-12-2008 12:48 PM
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 04:32 AM
broke gentoo after installing alsa-driver & alsa-utils snakeo2 Linux - Newbie 1 01-26-2006 08:05 AM


All times are GMT -5. The time now is 10:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration