LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-12-2009, 11:49 AM   #1
ashish1983
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
Unhappy Squid server not giving access to my local machine to internet


Hi,
I ma facing some problem with my squid server. I am unable to connect to internet for the lcoal machine as well as on other machines. Here is the conf file for my squid server.

cat /etc/squid/squid.conf

http_port 8080

acl oracle src 10.178.92.0/255.255.252.0
http_access allow localhost
http_access allow oracle


firewall and the selinux are off

cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
BOOTPROTO=static
BROADCAST=10.178.95.255
HWADDR=00:0C:29:68:F7:AE
IPADDR=10.178.92.121
NETMASK=255.255.252.0
NETWORK=10.178.92.0
ONBOOT=yes


and I have made the necessasy changes in my firefox by entering the squid server and the port nummber in that.

browser is showing:
access denied.
"Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect."



Please suggest what needs to be done in this case
Waiting for the reply.
 
Old 05-13-2009, 05:18 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Where have you put the http_access option?
Are they below http_access deny all?
 
Old 05-13-2009, 09:43 AM   #3
ashish1983
LQ Newbie
 
Registered: May 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Unhappy squid.conf file

yes this is below http_access deny all

my conf file for squid.conf contains :------


[root@linuxsvr15 ~]# grep -v "^#" /etc/squid/squid.conf | sed -e '/^$/d'
http_port 8080
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
cache deny QUERY
acl apache rep_header Server ^Apache
broken_vary_encoding allow apache
access_log /var/log/squid/access.log squid
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern . 0 20% 4320
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT
acl mylan src 10.178.92.0/255.255.252.0
http_access allow manager localhost
http_access deny manager
http_access allow localhost
http_access allow mylan
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_reply_access allow all
icp_access allow all
coredump_dir /var/spool/squid


Please check and let me know if any thing else needs to be done in this.
 
Old 05-14-2009, 01:15 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
You should have http_access allow options on top and then deny all others with
http_access deny all. But this option should be at the bottom.
 
  


Reply

Tags
error, server, squid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to access internet on linux clients By our Squid Proxy server farrukhndm Linux - Server 2 03-07-2009 07:22 AM
domain user authentication for squid proxy server for internet access manabJyoti Linux - General 1 05-10-2008 10:08 AM
download restriction over internet access using squid (proxy server) pankajkarde Linux - Server 4 03-21-2007 02:04 AM
Local network can't access Internet (Server can) Notwerk Linux - Networking 2 12-15-2005 04:19 AM
config squid so some IP can access internet, and others just the server? 4mix Linux - Networking 5 07-20-2004 06:08 PM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration