LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2003, 02:05 PM   #1
malcolm
LQ Newbie
 
Registered: Jan 2002
Location: newcastle u.k
Distribution: RH 8.0
Posts: 16

Rep: Reputation: 0
soundblaster live in rh8.0 (sound but no sound)


I am running rh8 and using gnome. The system detected my sb 128 live as an ensoniq card type es1370, I get all the normal sytem sounds (startup tunes etc) but if I try to use a music cd although the cd player starts up and plays the cd I never hear any music. It goes down a black hole. So I have sounds but no music. Volume is set high. Any ideas about this woul;d be appreciated. n.b It is currently still a dual boot machine and all is ok if I boot xp i.e no hardware issues.
 
Old 01-16-2003, 02:20 PM   #2
kmistry
Member
 
Registered: Sep 2002
Distribution: Debian 3.0 (Sid)
Posts: 67

Rep: Reputation: 15
log into root and in the command line type this:

insmod emu10k1

by that im guessing your chipset is that of the command SB Live! ones, the PCI 512 versions share the same chipset also.

if you dont get anywhere search for more information about kernel modules, in debian we got a little thing called modconf, not sure if its in rh8.
 
Old 01-24-2003, 01:44 PM   #3
malcolm
LQ Newbie
 
Registered: Jan 2002
Location: newcastle u.k
Distribution: RH 8.0
Posts: 16

Original Poster
Rep: Reputation: 0
in this ver of rh i dont seem to have sndcfg not according to my search anyway, I have tried also to load alsa without success.
 
Old 01-24-2003, 02:55 PM   #4
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
If you're getting system sounds then it's not a problem with your soundcard or sound server right? I bet if you played an mp3 from your hard drive it would work fine.

You need to create a symlink from the actual device name of your cdrom (ie /dev/hdd or whatever) to /dev/cdrom, then make sure you have permission to use it: chmod 666 /dev/cdrom

Last edited by bulliver; 01-24-2003 at 02:56 PM.
 
Old 01-24-2003, 04:19 PM   #5
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Did the CD drive ever play music CDs in another OS successfully? There happens to be a little wire inside your computer that goes from the CD drive to the soundcard, some computers don't have it wired up right or at all. It is also possible to disable the CD input on the soundcard, see if your mixer program has it listed.
 
Old 01-24-2003, 07:31 PM   #6
Quixotic
LQ Newbie
 
Registered: Jan 2003
Posts: 16

Rep: Reputation: 0
darin, youre a smart man. everyone else is telling him to use all these configs, and i'm thinking, they CDrom is obviously not hooked up to the sound card, since the sound works. I may not know linux, but i know computers
 
Old 01-24-2003, 10:29 PM   #7
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Quote:
they CDrom is obviously not hooked up to the sound card, since the sound works
Uh huh, then how come it works for him in Windows. Five bucks says my solution is the correct one
 
Old 01-24-2003, 10:50 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I'm in. 5 bux, whoever loses has to donate their 5 bux to either affero under on behalf of the winner, or directly to LQ.

I'm bettin the audio cable is simply not connected from the drive to the soundcard.

Bulliver, the reason I'm bettin on this is because Win doesn't need this cable, it streams the music via the IDE cables if needed IIRC. I'll happily donate my 5 bux if I am wrong though

Cool
 
Old 01-24-2003, 10:52 PM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Also, I believe it's not a permissions or symlink problem because they said they can see a CD player playing the music, they just can't hear it. More evidence to lead me to believe it's just the audio cable from the ROM to the Sound card.

Cool
 
Old 01-24-2003, 11:00 PM   #10
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Jeez, I gotta keep my mouth shut. I didn't know windows used the ide ribbons! Sherlock I isn't.

Akims razor: the simplest solution is usually the correct one.

BTW: I can't donate money because I don't have a credit card. That's why I keep bugging Jeremy to take money orders

Last edited by bulliver; 01-24-2003 at 11:02 PM.
 
Old 01-25-2003, 11:21 AM   #11
Quixotic
LQ Newbie
 
Registered: Jan 2003
Posts: 16

Rep: Reputation: 0
stchoooolen from hackers "mess with the best, die like the rest"
 
Old 01-25-2003, 12:37 PM   #12
malcolm
LQ Newbie
 
Registered: Jan 2002
Location: newcastle u.k
Distribution: RH 8.0
Posts: 16

Original Poster
Rep: Reputation: 0
well more details are obviously required here.
masterc is correct in that ide will allow music to be played via ide in the latest versions of windows (I'm running XP as dual boot)
however masterc is wrong this time about my sound cable not being connected, it is definitly connected to my CD player.
fstab for this device reads.../dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,r o 0 0
when an audio cd is inserted, linux wakes up, launches the cd player and the counter counts up to the heavens, but no music is ever heard. Volumes is set to blow my head off, no mutes etc.
 
Old 01-25-2003, 01:03 PM   #13
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Did you try the symlink? There's five bucks riding on this one

Okay, forget that. The only thing I can think of is that the other end of that cable is plugged into your onboard soundcard(if you have one) and linux is using your pci soundcard, or vice versa.

Just a lark: run "ls -l /dev/dsp" and "ls -l /dev/mixer" and post the results here.

Do mp3s play from your HDD? If you don't have any download one and try. Actually, you said you were getting system sounds right?

Last edited by bulliver; 01-25-2003 at 01:10 PM.
 
Old 01-25-2003, 01:51 PM   #14
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Don't forget...

Quote:
Originally posted by Darin
... It is also possible to disable the CD input on the soundcard, see if your mixer program has it listed.
There is kmix in KDE and some distros have a command line mixer called....mixer, it's possible one of these has muted the CD input on your soundcard. Someone chime in with how you access the mixer in gnome, I'm a hardware/network guy and can't even get my mouse wheel working in X so I'm the wrong one to ask about this kinda schtuff. <--

P.S. I didn't think the IDE cable carried sound either, I know some programs like MP3 rippers can do DAE which pulls the bits off the CD like a file and then turns em into sound info but audio signals through IDE that don't sound right. I'll blame MasterC when my roomie gets mad that I ripped open his XP box to check

P.S.S. Creative gobbled up some el-cheapo soundcard companies around the time of the SB128 so it could be that the SB128 uses an ensonic chip.

P.S.S.S. When linux plays music CDs it doesn't really mount the drive since it's not reading files, it just sends commands to the drive to pump data off track x through the audio wires.
 
Old 01-25-2003, 05:52 PM   #15
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Pretty much we won't need to worry about your fstab. I'm still shooting for the audio cable (and am saving 5 bux just in case it's not ) I think it may either be plugged in to the wrong card, or the wrong port.

How to open up a mixer in gnome, type kmix, gmix or aumix (or some others). All mixers work in all environments as long as they are installed. (Off note: Darin, have you tried adding ZAxisMapping 4,5 to your /etc/X11/XF86Config file? )

And you said there is a cable, is it digital or analog audio cable from the drive to the soundcard?

Still pretty sure the driver he'll need is emu10k1.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundblaster Live! and no sound jscerb Linux - Hardware 47 04-28-2004 02:16 AM
No Sound using SoundBlaster Live rhawthorne Linux - Hardware 2 03-08-2004 01:19 PM
Soundblaster Live = no sound? linuxgamer09483 Linux - Software 6 02-18-2004 11:15 PM
No sound with soundblaster live koboldmann5 Linux - General 7 06-05-2003 02:35 AM
no sound w/ soundblaster live jiplen Linux - General 9 07-03-2001 11:55 AM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration