LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-22-2006, 12:54 PM   #1
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Rep: Reputation: 15
Question sound question with details


I read a thread saying I should post all the following info when asking a sound question so here it goes..
_______________________________________________________
When running /sbin/lsmod i got:

Module Size Used by
snd_mixer_oss 17536 0
nvidia 4081712 12
ipv6 230784 12
ipt_mac 1792 1
ipt_LOG 6400 1
iptable_filter 3200 1
ip_tables 15744 3 ipt_mac,ipt_LOG,iptable_filter
nls_iso8859_1 3968 1
nls_cp437 5632 1
sg 29472 0
vfat 11520 1
ntfs 105328 0
msdos 7552 0
isofs 32568 0
zlib_inflate 17280 1 isofs
fat 36512 2 vfat,msdos
ext3 125448 0
jbd 50072 1 ext3
forcedeth 14464 0
snd_intel8x0 28064 0
snd_ac97_codec 72032 1 snd_intel8x0
snd_pcm 80904 2 snd_intel8x0,snd_ac97_codec
snd_timer 20228 1 snd_pcm
snd 45924 5 snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore 7136 1 snd
snd_page_alloc 7684 2 snd_intel8x0,snd_pcm
usb_storage 65344 0
ehci_hcd 28804 0
ohci_hcd 18824 0
uhci_hcd 29968 0
agpgart 28328 1 nvidia
psmouse 20104 0
___________________________________________________

When Running sbin/lspci I got:

00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:06.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04)
02:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
__________________________________________________________

Alsamixer does run, sound knobs up, Master, PCM, are all un-muted and at reasonable levels.
__________________________________________________________

I dont have a laptop, my sound card is a Creative Labs model CT4750. I also have integrated sound on my mobo which may be causing a conflict.
__________________________________________________________

Running cat/dev/urandom > /dev/dsp returns:
-bash: /dev/dsp: No such device
__________________________________________________________

The only other info I have for you is a friend of mine set up a lot of stuff for me. So this is an effort in trying to learn something. If you ask me hey have you done this or that, my answer will be I'm not sure whats happened on my system thus far.
__________________________________________________________

Also, my distro is Slackware if that is also needed. Any help will be greatly appreciated.
 
Old 03-22-2006, 01:18 PM   #2
jessdog9001
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian Unstable
Posts: 14

Rep: Reputation: 0
The "cat /dev/urandom > /dev/dsp" trick won't work for ALSA (Advanced Linux Sound Architecture), since /dev/dsp is only created if you are running OSS drivers. Generally, ALSA has superceded OSS and supports many more sound cards. If you want to test your sound system, I would recommend installing a program like mpg123 and using it to play something back... then you will be able to tell if it is working or not.
 
Old 03-22-2006, 02:27 PM   #3
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
Isn't it enough that when i play a song in gxine or xmms, that it doesnt play? Is that enough to tell that it isnt working? Also i forgot to mention that i know my friend had recently changed kernel versions on my system. Sound worked before that, now it doesn't. Could it be that i have to recompile the kernel (which i dont know how to do) with some different options or something?
 
Old 03-23-2006, 12:21 PM   #4
jessdog9001
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian Unstable
Posts: 14

Rep: Reputation: 0
Okay, I see. Well, since your sound dissapeared after a kernel reconfigure, then your friend most likely didn't compile in the right drivers. If you're feeling brave, you can attempt to recompile your kernel with the right drivers. It isn't that hard, really

So if you want to recompile your kernel, here's what you probably should do (you should be superuser for this, so type "su" if needed):
Code:
cd /usr/src/linux
Note: if you get an error like "bash: cd: /usr/src/linux: No such file or directory", then do the following:
Code:
cd /usr/src
ls
ln -s (insert name of kernel folder here) linux
cd linux
Okay, now you're set to run the configuration. Type:
Code:
make menuconfig
This should bring up a menu that will allow you to configure your kernel. If you've never done it before, it might be overwhelming, but for your purposes you probably won't have to configure everything.

Select the option "Device Drivers", then arrow down and select "Sound", make sure that "Sound Card Support" is enabled (it should either show a <*> or <M>). Now you should select "Advanced Linux Sound Architecture", and make sure that there is at least an <M> or <*> next to "Advanced Linux Sound Architecture" (if there isn't, space bar toggles this.) You probably want to make sure the other options in this menu have a <M> also, since OSS support can be handy for older applications.

The last step for configuring your kernel will be to select the drivers for your specific sound card. It will most likely be under "PCI Devices". Since your sound card is a Creative, you should probably enable any of the Creative drivers, along with Ensoniq drivers as well. It won't hurt to enable extra drivers, even if they aren't for your specific card. Once you've enabled all of this, you're ready to compile your new kernel. Use the right arrow key to select "Exit" and hit enter, and you'll have to do this a few times until it asks you whether you want to save your new kernel configuration. You should answer Yes here, and hit enter. Now, the next step depends on whether you are compiling a 2.4 or a 2.6 kernel. If you aren't sure, type
Code:
uname -r
and go by what that says. If you are running a 2.6.x kernel, you should now do the following:
Code:
make && make modules_install
If it is a 2.4.x kernel, then the following should work:
Code:
make dep && make && make modules_install
This will probably take a while, but when its done you may have to do one of the following things:
If you chose to compile your drivers as modules (<M>), you probably will be able to reboot your system and see if things are working. If you compiled them into the kernel (<*>), then you will have to copy your new kernel into your boot folder by doing this:
Code:
cp arch/i386/boot/bzImage /boot/kernel-2.x.x
, replacing the x's with your kernel version (uname -r). Your last step is to make sure that your bootloader loads this kernel on startup. Most likely you're using GRUB, but you might have Lilo. To find out,
Code:
cd /boot/grub
. If this works, then you probably have GRUB. Once in the grub folder, use your favorite text editor to open menu.lst like so:
Code:
vim menu.lst
Now you should add your new kernel by adding the following lines (at the bottom of the file):
Code:
title Linux-2.6.15
root (hd0,0)
kernel /boot/kernel-2.6.15 root=/dev/hda1
Of course, you'll have to adjust this depending on your kernel version, your boot partition location, and your root partition location. If you want to find these out, you should "cat /etc/fstab" and see what locations your root and boot partitions are. If your boot partition is different, you'll need to adjust the "root (hd0,0)" part of the above. For example, if your boot partition is /dev/hda3, then the line should read "root (hd0,2)". If the root partition is different, you should change the "root=/dev/hda1" part to whatever it is. If you need additional help here, let me know...

Anyway, the result of this should be that you can reboot, choose the new kernel, and hopefully have sound. If not, you might need to tweak your /etc/modules or /etc/modules.autoload.d file to load the new sound card driver modules. I guess what I would say is give the above a go, and if it still doesn't work, let me know and I'll try to help you out some more. Good luck!
 
Old 03-23-2006, 12:35 PM   #5
jessdog9001
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian Unstable
Posts: 14

Rep: Reputation: 0
Actually, I just found a guide that might help you out a bit: http://www.linuxquestions.org/questions/answers/408
This is specifically for Slackware, and probably is better than my above guide, since it addresses Lilo, which Slack uses by default, I think. So feel free to follow either one...
 
Old 03-23-2006, 05:20 PM   #6
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
alright, thank you very much I will indeed try that tomorrow, and let you know how it goes
 
Old 03-23-2006, 06:09 PM   #7
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Rep: Reputation: 15
It looks like you have two sound cards. When you run alsaconfig, make sure to select the proper sound card. I had a problem with that on one of my computers. I didn't know which one I was plugged into. When I chose the wrong one, everything seemed fine but no sound came out. I probably could have just switched the speakers to the other sound card now that I think about it. Instead I re-ran alsaconfig with the other sound card and everything is great.
 
Old 03-23-2006, 11:44 PM   #8
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
wait, so I can just run alsaconfig without recompiling my kernel? or is alsaconfig part of the kernel configuring process? Sorry I'm pretty new to Linux
 
Old 03-24-2006, 12:19 AM   #9
jessdog9001
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian Unstable
Posts: 14

Rep: Reputation: 0
You should be able to run alsaconfig without recompiling anything. Hopefully that works! I don't know why I didn't think of that... I guess because I haven't dealt much with more than one sound card in my setup.
 
Old 03-24-2006, 12:24 AM   #10
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Rep: Reputation: 15
You are on the right forum then.

From what I understand when I set up my systems, the Alsa drivers can be compiled directly into the kernel either directly or in modules. They can also be installed separately, mine are. In either case, the system will need to be configured.

Oh, and checking my documentation, the command is actually
Code:
# alsaconf
Sorry for the typo.
 
Old 03-24-2006, 10:04 PM   #11
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
where is the command alsaconf located? I can't find it in /sbin or /bin anywhere, is it a standard command in every distro? Sorry for being such a pain
 
Old 03-25-2006, 12:53 AM   #12
pilatus666
Member
 
Registered: Mar 2006
Location: cyprus
Distribution: Mandriva 2009.0;
Posts: 263

Rep: Reputation: 30
Login as root or start a command line utillity as root and just type: alsaconf
 
Old 03-25-2006, 02:15 AM   #13
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
Wow, im slow. Thanks a ton, I ran alsaconf, it gave me two options:
1) intel8x0 nVidia Corporation nForce2 AC97 Audio Controler (MCP)(rev a[then it gets cut off the screen]
2) Probe legacy ISA (non-Pnp) chips

When i did option one, my motherboard integrated sound worked. I was really trying to get my actual sound card to work (not that im complaining - some sound is better than none). However when i tried the second option which i assumed to be my sound card, it said "No legacy drivers are available" and exited the command. Any ideas on how to get the actual sound card working? If not thanks a ton for helping me get some sound
 
Old 03-25-2006, 11:43 AM   #14
wakeboarder3780
Member
 
Registered: Mar 2006
Distribution: Ubuntu 6.10
Posts: 112

Original Poster
Rep: Reputation: 15
also, sound only works in gxine and XMMS however when i try to use something like madplay from the command line, i get an error reading audio: /dev/dsp: No Such Device What does this mean and how might i remedy it? Again it would be nice if i could run from my soundcard instead of integrated sound..

Last edited by wakeboarder3780; 03-26-2006 at 01:09 PM.
 
Old 03-26-2006, 04:24 PM   #15
jessdog9001
LQ Newbie
 
Registered: Mar 2006
Distribution: Debian Unstable
Posts: 14

Rep: Reputation: 0
It looks as if your computer isn't detecting your Sound Blaster card. My best guess is that you don't have the driver compiled for it. You might have to do the kernel recompile mentioned earlier. I'm pretty sure you don't have an ISA card, so option 2) in alsaconf won't do much good. As for madplay, etc. not detecting /dev/dsp, it means that you don't have OSS support compiled in. For most, OSS support is not necessary and is deprecated from the kernel. Try running those commands using "aoss COMMAND". Aoss is the ALSA wrapper for OSS applications, letting them run as if you had OSS support. If you run that command and it isn't found, you might have to install it. It is probably under the "alsa-oss" or "alsa-utils" package.

Anyway, I hope that you can sort this out with a kernel recompile. Beyond that, I'm clueless... Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
at command details shukla_chanchal Linux - General 2 11-21-2005 10:06 PM
BSD Details hinetvenkat Linux - Software 2 05-30-2005 12:20 PM
Mount in details cyrius Linux - General 3 12-15-2004 12:46 PM
hardware details noir911 *BSD 5 08-05-2004 02:23 PM
Details of Port53 saravanan1979 Linux - Networking 2 05-16-2002 05:35 AM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration