LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2004, 04:59 PM   #1
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Rep: Reputation: 30
Sound not working in Slackware


I am using slackware 9.1.
My soundcard is an ISA PnP, and I am using the isapnp tool to configure it. I finally found a combination of I/Os and IRQs that doesn't give any conflict warning, but still I get no sound.

I suspect that I have not sound support in my kernel. How can I check? Which other checks can I do to tackle the problem? Sorry for the simple questions, but I am really a newbye...
 
Old 01-02-2004, 05:05 PM   #2
zer0python
Member
 
Registered: Sep 2003
Posts: 104

Rep: Reputation: 20
unless you changed the default kernel that slackware 9.1, comes with, you *should* have sound support; and have you tried using alsaconf ?
 
Old 01-02-2004, 05:16 PM   #3
libranikki
Member
 
Registered: Nov 2003
Location: Florida in a town not on the weather map
Distribution: back to Fedora
Posts: 115

Rep: Reputation: 15
i had the same prob iqbala ( and i actually fixed it with help from these boards ). and even tho i am brand new to Slack and Linux, what I did was check my alsamixer and it turned out that none of my settings were being saved. and they still dont save so i am constantly fixing it when i want sound. but anyways, i know ur probably like "ugh ok dumbass" but i just wanted to share .

much love,
nikki
 
Old 01-02-2004, 05:34 PM   #4
Guayacan
LQ Newbie
 
Registered: Dec 2003
Location: Caracas, Venezuela
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
When you boot, you should get a message like: ALSA Settings turnned off... or something. There it says something about how to save your settings, alsaconf store or something like that... Not sure about the exact sintaxys, i'm a newbie myself, but the same happened to me
 
Old 01-02-2004, 05:38 PM   #5
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 540

Rep: Reputation: 32
Alsa mixer is mute by default.
You must first set up the mixer (from the X server if you like) and the run as root
alsactl store
Your mixer set-up will be loaded at boot.
Ciao
 
Old 01-05-2004, 04:07 PM   #6
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
OK, thank you very much, I will try all your suggestions in the next days, then I'll let you know the results.

To libranikki: your observation brought in this thread some suggestion about how to save the settings, so thank you very much for your wish to share.
 
Old 01-06-2004, 04:16 PM   #7
iqbala
Member
 
Registered: Dec 2003
Location: Milano (ITALY)
Distribution: Kubuntu 12.04
Posts: 237

Original Poster
Rep: Reputation: 30
OK, alsaconf solved my problems, even if after the first attempt my GNOME didn't start any more. After some attempt I managed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 Module snd-intel8x0, sound not working! naimslim89 Linux - Hardware 3 08-21-2005 04:13 AM
sound not working slackware blitzX Linux - Laptop and Netbook 10 04-25-2005 02:33 PM
sound not working under slackware install blackgenesis Linux - Newbie 4 01-05-2005 01:56 AM
Sound not working on a7n8x motherboard, slackware orbitalnerd Linux - Hardware 9 02-13-2004 01:53 PM
Sound not working in Slackware 9.1 rsamurti Slackware - Installation 6 12-19-2003 08:51 PM


All times are GMT -5. The time now is 02:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration