LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2003, 05:50 AM   #1
Kix
Member
 
Registered: Mar 2003
Location: UK
Distribution: PCLINUXOS
Posts: 34

Rep: Reputation: 15
Sony DW10A DVD is not a DVD in SuSE 8.1


My DVD drive - Sony DW10A will act as a CD-RW drive but will not play DVD with mplayer.

Any ideas?
 
Old 03-25-2003, 06:19 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
do you have a symlink from the actual ide device entry (e.g /dev/hdc) to /dev/dvd. without having an obvious place to look for a dvd drive programs aren't going to start guessing, so if there's no /dev/dvd then try "ln -s /dev/hdc /dev/dvd" IF your drive IS on hdc (secondary master)

if that doesn't solve it then provide the full output from mplayer as you have provided no real useful information
 
Old 03-25-2003, 06:30 AM   #3
Kix
Member
 
Registered: Mar 2003
Location: UK
Distribution: PCLINUXOS
Posts: 34

Original Poster
Rep: Reputation: 15
I think you have nailed it. Sorry for the lack of info though. /dev/dvd does not exist, I'll give that a try. Thanks for that.

 
Old 03-25-2003, 02:56 PM   #4
Kix
Member
 
Registered: Mar 2003
Location: UK
Distribution: PCLINUXOS
Posts: 34

Original Poster
Rep: Reputation: 15
acid_kewpie - I started up my box to try your suggestion, I noticed the messages at the login prompt:

linux kernel: ide-scsi: hdc unsupported command in request queue (0)0)0))
linux kernel :ide-scsi: hdc end_request: I/O error, dev 16:00 (hdc), sector 64

The message repeats to sector 78

When I ltry to play a dvd mplayer reports:

Sorry this file format not recognized/supported
If this file is an AVI, ASF or MPEG stream, please contact the author!

Next I tried you suggestion:

ln -s /dev/hdc /dev/dvd

And recieved the same message from mplayer.

I removed /dev/dvd and tried

ln -s /dev/sr0 /dev/dvd

The palyer resizes and displays noise for a couple of seconds then gives the same error message.

If I then just press play I get the same video noise and:
Error: Could not open direct show codec: qdv.dll

I checked the SuSE site and checked that the kernel had the correct modules.

reiserfs cdrom ide-cd ide-scsi

Hmmmm. More google.

Cheers.




Thanks for reading.

Last edited by Kix; 03-25-2003 at 03:43 PM.
 
Old 03-25-2003, 03:58 PM   #5
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
I get the same exact errors except I can access any files off a cd, but can't do any writing of any kind.
 
Old 03-25-2003, 05:49 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well it looks ok really, but you've not said how you are running mplayer
 
Old 03-25-2003, 08:25 PM   #7
Kix
Member
 
Registered: Mar 2003
Location: UK
Distribution: PCLINUXOS
Posts: 34

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
well it looks ok really, but you've not said how you are running mplayer
From KDE as su, right click DVD ROM icon select play(reports as above), or launch mplayer, right click main window "MPlayer interrupted by signal 6 in module: open_stream" then "fatal error....or a bug in mplayer or in your drivers or in your gcc version.etc", or open mplayer and use play button on the deck, nothing happens just title scroll "no media opened".

Replaced mplayer and still the same symptoms.

Can't play Div-x or VCD either. Works fine as cd-rom and cd-audio.



 
Old 03-26-2003, 12:56 PM   #8
aherm
Member
 
Registered: Jan 2003
Location: upNorth
Distribution: openSuSE/uBuntu
Posts: 410

Rep: Reputation: 30
Try run

cdrecord -scanbus

If your DVD / CDRW devices appears once like this for example:

scsibus0:
0,0,0 0) 'YAMAHA ' 'CRW-F1E ' '1.0c' Removable CD-ROM
0,1,0 1) 'SONY ' 'DVD-ROM DDU1621 ' 'S1.6' Removable CD-ROM
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

Than you should be fine. If not (e.g. does not appear, appears multiple times) then this link should help:

http://sdb.suse.de/en/sdb/html/aoezcan_cdrom.html


Have a lot of fun :-)
 
Old 03-26-2003, 01:05 PM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please provide the full output from mplayer
 
Old 03-26-2003, 01:05 PM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please provide the full output from mplayer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
which DVD player can play DVD from hard drive *and* support DVD Menu ? tho_x_tran Linux - Software 16 11-16-2006 03:00 PM
dvd drive not found/ install suse 9.2 dvd caffemusse Linux - Laptop and Netbook 0 07-06-2005 06:30 AM
Every DVD Player Fails to Play DVD Movie in SuSE 9.2 Pro....Please Help ! ! ! bedi-beparwah SUSE / openSUSE 2 03-14-2005 07:08 PM
how-to install suse 9.2 dvd version without dvd drive?? alkali SUSE / openSUSE 7 01-05-2005 08:05 AM
Sony DVD DDU1612. /dev/dvd no such file lamedavis Linux - Hardware 2 03-30-2004 07:06 PM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration