LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2011, 01:46 PM   #1
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Rep: Reputation: 0
Somehow I changed my desktop folder to my home folder


I'm a newbie to Fedora and need some help. I must have messed up some config somewhere because all my contents in my home folder is now showing up on my desktop. My guess is that somehow, I've changed my Desktop folder be my home folder. In other words, my desktop folder should be: /home/username/Desktop, but I think it is now /home/username. Is there a config file that I can view to see if my guess is correct?
 
Old 04-04-2011, 02:04 PM   #2
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,699
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Wow!

This must be overwhelming...

Okay, well, I guess (GUESS!) that you eagerly over-clicked and accidentally dragged/moved the contents of your home folder to your desktop. Did that too once...nothing to be eaaked about.

You still (must) have a /home/user/Desktop or your stuff would'nt show on the ... desktop. Just clean the folder out (cut-n-paste wise) and I guess you'll be fine.

Since you're somewhat un-seasoned (dont like the word newbe ) some tips...

- open TWO file browsers, arrange them on the screen...
- point one to the /home/user/ folder, the other one to the /home/user/desktop folder
- keeping the ctrl key pressed, click anything you want to move
- let go of everything when done, right-click on the selection
- cut-n-paste....

No sweat! Luck!

Thor
 
Old 04-04-2011, 02:24 PM   #3
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks Thor for the quick reply,

But I don't think that's the answer for my problem. In Windows, there is a "desktop" folder. Anything you put into the desktop folder shows up on your desktop (similar to fedora). But how does the system know to show the contents of my desktop folder on my desktop, not some other folder. In Windows there is probably some registry that says "hey John Doe's desktop folder is located on c:\users\JohnDoe\Desktop". Then it shows the contents of that on my desktop. Similarly, in Linux system, there must be somewhere that says the contents of my desktop is located on folder /home/username/Desktop.

Another way of stating the same problem is this... If I put a file called my.file on my desktop, it will show up in the folder /home/username/my.file instead of /home/username/Desktop/my.file.
 
Old 04-04-2011, 02:35 PM   #4
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,699
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
I think it's far easier that that . You have a home folder, in that folder are several special folders, Desktop is one of them. Go on, copy-n-paste something in that folder, and presto, it'll show on the desktop...

Quote:
Another way of stating the same problem is this... If I put a file called my.file on my desktop, it will show up in the folder /home/username/my.file instead of /home/username/Desktop/my.file.
But this...is weird...have you even got a folder called Desktop?

Okay, try this:

1) open gconf-editor inthe console (just type it in)
2) browse to /apps/nautilus/preferences entry in it
3) set desktop_is_home_dir flag down, I suspect that one is checked...

Keep me/us all posted, please...

Thor

Last edited by ButterflyMelissa; 04-04-2011 at 02:57 PM.
 
Old 04-04-2011, 02:37 PM   #5
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
That is precisely my problem. It doesn't.
 
Old 04-04-2011, 02:42 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Look in the system settings from your desktop
In KDE it's
Code:
system settings => Account details => paths
Kind regards

Last edited by repo; 04-04-2011 at 02:43 PM.
 
Old 04-04-2011, 02:47 PM   #7
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,699
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
eh...

Quote:
That is precisely my problem. It doesn't.
what does'nt? Show? Hmm, possibly your home folder is the desktop...what did the settings in the gconf-editor say?

Thor
 
Old 04-04-2011, 02:52 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
For gnome it's
Code:
open gconf-editor
browse to /apps/nautilus/preferences
Kind regards
 
Old 04-04-2011, 03:00 PM   #9
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
There doesn't seem to be "find desktop_is_home_dir" in /apps/nautilus/preferences
 
Old 04-04-2011, 03:02 PM   #10
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
My mistake. I found it, but it is unchecked.
 
Old 04-04-2011, 03:30 PM   #11
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Thor_2.0 View Post
I think it's far easier that that . You have a home folder, in that folder are several special folders, Desktop is one of them. Go on, copy-n-paste something in that folder, and presto, it'll show on the desktop...


But this...is weird...have you even got a folder called Desktop?

Okay, try this:

1) open gconf-editor inthe console (just type it in)
2) browse to /apps/nautilus/preferences entry in it
3) set desktop_is_home_dir flag down, I suspect that one is checked...

Keep me/us all posted, please...

Thor
I didn't answer your question fully. I do have Desktop folder in my home/username/ folder. When I put files in this Desktop folder, it doesn't show up on my desktop. When I put a file in my home/username/ folder, it shows up on my desktop. And it turns out that I do have the option "desktop_is_home_dir" in /app/nautilus/preferences unchecked.
One other potentially useful information. Normally, when you delete the Desktop folder, it comes back. But it doesn't come back on my system. Could this be something?
 
Old 04-04-2011, 03:33 PM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Permissions?

Kind regards
 
Old 04-04-2011, 04:27 PM   #13
mandu
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
Permissions?

Kind regards
repo, if you mean to ask if I have permissions to change setting. I have permission to change things. I've tried to set the config, log out, then log back in to see if anything had changed. Then check to see if setting is still set (and it is). Then change the setting back, re-login. Nothing seems to be helping.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
All of my folder icons changed to the Downloads folder icon? Supreme1012 Linux - Software 1 08-17-2010 04:45 PM
want to copy an inode folder from acdrom to a home directory (folder). nhbob Linux - Newbie 8 12-20-2009 11:12 AM
mixed mounting of automount and fstab in one folder? &different home folder using NIS herofmm Linux - Software 0 04-06-2009 11:00 AM
Folder Max Size and Limiting SSH access to home folder. Mefistofeles Linux - General 4 11-26-2005 02:09 PM
accidentally changed permissions on home folder Cinematography Linux - General 7 05-15-2005 04:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration