LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2005, 05:07 PM   #1
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
slow behaviour


I recently reformatted, just for kicks. Before that I could be doing anything and the computer would still run fine, extracting archives, compiling a couple of programs at once and it was all the same, you'd never know it. Now, extract anything over 10MB, copy a decent sized file and the mouse pointer gets all jerky, sound stops and farts around, it's crap. This shouldn't be happening, I'm running fluxbox 0.9.12 on a P4 3.2GHz with 1.5GB RAM.

Any ideas what could be causing this? I'm using the nvidia drivers, not nv which have traditionally run like shit for me. Any help would be very much appreciated as this is driving me insane
 
Old 03-23-2005, 06:10 PM   #2
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
It sounds to me like DMA might be turned off on your drive. Type:
Code:
hdparm -d /dev/your_drive_here
to see if DMA is enabled.

example:
Code:
box # hdparm -d /dev/hdc

/dev/hdc:
 using_dma    =  1 (on)
box #
 
Old 03-23-2005, 06:19 PM   #3
xowl
Member
 
Registered: Jan 2005
Distribution: Slackware current (and others)
Posts: 188

Rep: Reputation: 30
Do U have HT??

It is enabled??
 
Old 03-24-2005, 05:02 PM   #4
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Original Poster
Rep: Reputation: 57
I do have HT and it's all setup right in the kernel I'm 99.9% sure. Had a play under the SMP section and it all looked good.

visaris: DMA is not enabled, problem found How would I go about turning it on? I checked Google and tried hdparm -d1 /dev/hda but got this error
Code:
[root@sylvester ~]# hdparm -d1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)
Should I be doing this at boot or something else?

Ta
 
Old 03-24-2005, 05:30 PM   #5
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Original Poster
Rep: Reputation: 57
Never mind, I recompiledmy kernel enabled some drivers that I didn't before and it's working fine now. Thanks heaps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 12:17 PM
vi Behaviour! dlublink SUSE / openSUSE 5 09-20-2006 09:14 AM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 01:55 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 07:19 PM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration