LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2004, 06:27 PM   #1
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Rep: Reputation: 15
Slackware and old partitions


Here is the deal, I run a slackware 9.1 box and I have 4 partitions, one for /, one for /music, swap space and lastly boot. I recently had to reinstall slack, (my fault don't ever try and upgrade you kernel without backing up your old one and leaving it as a boot option). i did not touch fdisk and just went ahead with the install, i did not reformat the /music partition, and now i cannot see it. Is there anyway i can mount the partition? if so what is it?
At any rate, I have learned lots about linux from this little adventure.........
mike
 
Old 03-12-2004, 06:38 PM   #2
synapse
Member
 
Registered: Jan 2004
Location: On Planet Earth.
Distribution: Slackware 12
Posts: 244

Rep: Reputation: 30
ok mike

first you have to determine what drive or you are using hda b c or d

then the partition number

Or can you say how many hd you have installed this would help

cheers
 
Old 03-12-2004, 06:40 PM   #3
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
what does fdisk -l return?
 
Old 03-12-2004, 07:24 PM   #4
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
it returns
Device Boot Start End Blocks Id System
/dev/hda1 * 1 31 248976 83 Linux
/dev/hda2 32 883 6843690 83 Linux
/dev/hda3 884 4741 30989385 83 Linux
/dev/hda4 4742 4864 987997+ 82 Linux swap

/dev/hda2 is the partition i want to mount
thanks,mike
 
Old 03-12-2004, 07:46 PM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
looks like it's recognized. have you tried

mount /dev/hda2 /mnt/yourdirectory
 
Old 03-13-2004, 07:57 PM   #6
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
yea i have, i get:
/dev/hda2 not found in etc/fstab
soooo i tried to edit /etc/fstab to include /dev/had2, still the same problem..... i know the partiton still exsits and that the stuff on it is there, i am just baffled as to why it does not want to mount...
thanks, mike
 
Old 03-13-2004, 08:49 PM   #7
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
i'll be off soon so it may take a while to get back to you, but, post the output of

cat /etc/fstab

we'll have a look at that and try to decipher what's going on.
good luck.
 
Old 03-14-2004, 06:22 PM   #8
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
cat /etc/fstab does not show /dev/hda2 i would post the entire thing, but alas, i have to use a windows computer (boo) to post this since i am at home, and have no modem on my laptop. The /etc/fstab looks somthing like this
/dev/hda1 / ext3 linux
/dev/hda3 boot boot boot
/dev/hda4 swap swap swap

that is not verbatim but the general idea (i dont have the laptop around) so now what..... i tried to edit it using pico, however the same error occured.... weird.... any way thanks for the help
mike
 
Old 03-14-2004, 06:49 PM   #9
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
try adding this to your /etc/fstab

from a terminal as root

pico /etc/fstab

/dev/hda2 /dirname yourfilesys umask=000,rw 1 0

save and exit.
good luck.
 
Old 03-15-2004, 01:15 AM   #10
synapse
Member
 
Registered: Jan 2004
Location: On Planet Earth.
Distribution: Slackware 12
Posts: 244

Rep: Reputation: 30
Hi Mike

Just folloewing along here this was suggested
mount /dev/hda2 /mnt/yourdirectory
but try this as well with the various filesystems
mount -t reiserfs /dev/hda2 /mnt/yourdirectory

note the -t for the type this is assuming your hd has a reiserfs or just put the filesystem that you used in its place.

Cheers
 
Old 03-15-2004, 04:31 AM   #11
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
ok, so i modify fstab so it look like this
/dev/hda2 /music ext3 umask=000,rw 10
/dev/hda4 swap swap defaults 00
/dev/hda3 / ext3 defaults 11
/dev/cdrom /mnt/cdrom iso966- noauto,owner,ro 00

and i still cant mount the thing, so i tried "mount -t reiserfs /dev/hda2 /mnt/yourdirectory" both with the mod to /etc/fstab and without and it returns:
"mount: wrong fs type, bad option, bad superblock on /dev/hda2, or too many mounted file sysems"
thanks
mike
 
Old 03-15-2004, 06:17 AM   #12
synapse
Member
 
Registered: Jan 2004
Location: On Planet Earth.
Distribution: Slackware 12
Posts: 244

Rep: Reputation: 30
Hi Mike

One thing , did you try this as root?
Dont worry about modifying your fstab file just yet.

just change to the /mnt directory and try mounting your filesystems there
try the following as root

mount -t reiserfs /dev/hda2 /dev/music
mount -t ext2 /dev/hda2 /dev/music
mount -t ext3 /dev/hda2 /dev/music

this is assuming that you have a directory called music in your /mnt directory.
One thing, you dont have to put an entry in the fstab file to make the filesystem work, if you cant moun't the filesystem as root manually, then fstab wont be able to mount the filesystem either.

cheers
 
Old 03-15-2004, 11:57 AM   #13
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
i get:
"mount point /dev/music does not exsit"
for all three comands..... still stumped....
thanks,
mike
 
Old 03-15-2004, 12:33 PM   #14
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
should be

mount -t reiserfs /dev/hda2 /mnt/music
mount -t ext2 /dev/hda2 /mnt/music
mount -t ext3 /dev/hda2 /mnt/music

providing you have created the directory /mnt/music

from a terminal as root

cd /mnt
mkdir music

now you have the specified /mnt/music directory.
 
Old 03-15-2004, 01:14 PM   #15
celticselph
Member
 
Registered: Jan 2004
Distribution: Slack 9.1!!!
Posts: 37

Original Poster
Rep: Reputation: 15
Ok so i did that, then
mount -t reiserfs /hda2 /dev/music retrurns Mount point /dev/music does not exsist....
thanks, mike
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Installation - Partitions! dodz Linux - Newbie 1 05-31-2004 11:07 PM
slackware partitions mortal Slackware - Installation 2 03-16-2004 09:04 PM
Slackware, cfdisk, partitions, etc.. philY Slackware 7 11-02-2003 10:17 AM
Slackware 9.0 & missing partitions Weatherboy Slackware 4 08-01-2003 10:01 PM
Partitions for slackware installation Ed-Slack Slackware 13 01-01-2003 09:03 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration