LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2003, 05:26 PM   #1
MedalOfHonor
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Rep: Reputation: 0
slackware 8.1


i just installed slackware 8.1 after an unsuccessful experience with manrake. the installation went very smooth and i installed with everything (2gig install), i also enabled gpm, i would like to now disable it. how would i go about disabling gpm? also, i cannot get X to start, when u type startx it looks like its about to start but it gets most of the way through and returns with an error. also my mouse which is a logitech mx300 connected via a USB add on card and it doesnt turn on when i boot slackware and basically slackware doesn't detect it as even existing. any help?? im not totally new to linux but im completely new to slackware.
 
Old 03-25-2003, 05:51 PM   #2
tellezj
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
MOH,

gpm:

In the /etc/rc.d directory there are several scripts that start various services. Most of these work by executing the script followed by a start|stop|restart type input. For gpm, as root type:

/etc/rc.d/rc.gpm stop

This will stop the gpm process. To keep it from being started at startup in /etc/rc.M towards the end there is a section that calls that same rc.gpm script to start it. Just comment this out and you'll be good. (When you think about it this is pretty slick and straightfoward, one of the nice things about slack)


startx:

Before you run startx for the first time you need to configure xfree86. The first thing you should try is "/usr/X11/bin/xfree86setup". Run this as root. It should ask some questions and try to setup your x server. You can also try xf86config, xf86cfg, or simply editing /etc/X11/XF86Config by hand. I haven't used a USB mouse before, but I'm sure you can find some useful stuff at the xfree86.org website.


usb card:

In the /etc/rc.d/rc.modules script there are several commented out lines concerning both USB Host Controllers and USB Devices. My first guess would be the Open Host Controller for the former and the "Human Interface Device" for the latter. As I haven't done this before I'm not 100% certain. You can test these by running the "/sbin/modprobe <I>device</I>" at the command line. Once you get it right then uncomment the appropriate rc.modules line.


Good Luck
 
Old 03-25-2003, 05:52 PM   #3
tellezj
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 26

Rep: Reputation: 15
Correction:

"/etc/rc.M" should be "/etc/rc.d/rc.M"
 
Old 03-26-2003, 02:41 PM   #4
MedalOfHonor
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Original Poster
Rep: Reputation: 0
ok x still will not start, im gettin some help from a friend today hopefully who is pretty experienced with the distro i am using. also jus to let you all know, the LED on my optical mouse does not even turn on when slackware boots to command line, i guess i need to get x started and see what happens. the USB card i am using is a VIA USB Universal Host Controller
 
Old 03-26-2003, 05:58 PM   #5
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Did you install the bare.i kernel or the usb one? You also probably have to configure your /etc/X11/XF86Config file for use with your usb optical mouse. You will most likely need to install the drivers for it as well if you haven't already. I don't use a usb mouse so I can't really tell you exactly what modules to use, but I know there's many threads here at LQ with USB mouse problems. A search for these threads will probably get you really good results. When you get the proper module (driver) names for your mouse, you'll need to do as root:

modprobe <modulename>

You'll need to edit your /etc/X11/XF86Config file with the proper protocol and options as well. If it's at all possible, please post your mouse section of your XF86Config file for us.

To get X running, you'll need to set it up. As root, in command line, type the following (if you haven't already):

xf86config

This should get you well on your way to getting X to run. Keep us posted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 01:49 PM
Slackware 10 RC2 released; Slackware 10 imminent... SBing Slackware 22 06-22-2004 08:53 AM
Newer Slackware Packages on older slackware version pengStudent Slackware 2 11-12-2003 01:47 PM
wine and winesetuptk working well with slackware 9.0 and slackware 9.1 oobe Linux - Software 0 10-19-2003 01:29 PM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration