LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-17-2006, 04:02 AM   #1
crunchyuncle
LQ Newbie
 
Registered: Mar 2006
Location: NE Iowa
Distribution: SuSE 10.0
Posts: 16

Rep: Reputation: 0
Setting User and Access Permissions


I have installed and played a game...with major glitches due to some error of some sort..a buddy of mine recompiled the code for me and sent me the file to replace the original .bin now i am having troubles setting the permissions.
i need to make this where i can execute from root

linux:/home/crunchyuncle/EL # la -ls el.x86.linux.bin
825 -r--rw-r-- 1 crunchyuncle users 841489 Mar 17 02:51 el.x86.linux.bin
linux:/home/crunchyuncle/EL #


ive been going at it for about 6 hours now and cant seem to get it right. the error is my own i just need to know where i need correction


825 -rwxrwxr-x 1 crunchyuncle users 841489 Mar 17 02:51 el.x86.linux.bin
linux:/home/crunchyuncle/EL # chmod -x -c el.x86.linux.bin
mode of `el.x86.linux.bin' changed to 0664 (rw-rw-r--)
linux:/home/crunchyuncle/EL # la -ls el.x86.linux.bin
825 -rw-rw-r-- 1 crunchyuncle users 841489 Mar 17 02:51 el.x86.linux.bin
linux:/home/crunchyuncle/EL # chmod -w el.x86.linux.bin
linux:/home/crunchyuncle/EL # la -ls el.x86.linux.bin
825 -r--rw-r-- 1 crunchyuncle users 841489 Mar 17 02:51 el.x86.linux.bin
linux:/home/crunchyuncle/EL # ./el.x86.linux.bin
-bash: ./el.x86.linux.bin: Permission denied
linux:/home/crunchyuncle/EL # chown [crunchyuncle]:[users0] el.x86.linux.bin
chown: `[crunchyuncle]:[users0]': invalid user


please help

crunchy

Last edited by crunchyuncle; 03-17-2006 at 04:17 AM.
 
Old 03-17-2006, 04:53 AM   #2
muha
Member
 
Registered: Nov 2005
Distribution: xubuntu, grml
Posts: 451

Rep: Reputation: 37
the last one is incorrect:
Code:
chown crunchyuncle:users0 el.x86.linux.bin
/edit: also, make sure you can execute it:
Code:
chmod +x el.x86.linux.bin
Be sure to exit, to log off user root in your shell and try running the bin as crunchyuncle ..

Last edited by muha; 03-17-2006 at 04:57 AM.
 
Old 03-17-2006, 07:39 AM   #3
crunchyuncle
LQ Newbie
 
Registered: Mar 2006
Location: NE Iowa
Distribution: SuSE 10.0
Posts: 16

Original Poster
Rep: Reputation: 0
i understand the last is incorrect i just dont know how to correct it...how do u declare the owner and user in my case. its right in here that i need clarification

linux:/home/crunchyuncle/EL # chown [crunchyuncle]:[users0] el.x86.linux.bin

i mean is the "[" part incorrect or the names i am using or both? sorry if i ask too much, i just switched fro XP within the week, so this is all still foreign to me

thanks
 
Old 03-17-2006, 08:05 AM   #4
muha
Member
 
Registered: Nov 2005
Distribution: xubuntu, grml
Posts: 451

Rep: Reputation: 37
just remove the [ ] like so:
Code:
chown crunchyuncle:users0 el.x86.linux.bin
to make sure you are using the right username and usergroup:
Code:
id <username>
So for you probably: id crunchyuncle
Cause i think that you want 'users' instead of 'users0'

/edit:
from rute: http://rute.2038bug.com/node7.html.gz

[ ] brackets in man pages of commands mean that the stuff in between is optional. The brackets are not to be typed.
The ellipses ... mean that <file> can be given repeatedly, and these also are never actually typed.
< > mean the you have to replace your own text with <something>.

Last edited by muha; 03-17-2006 at 08:15 AM.
 
Old 03-17-2006, 11:41 AM   #5
crunchyuncle
LQ Newbie
 
Registered: Mar 2006
Location: NE Iowa
Distribution: SuSE 10.0
Posts: 16

Original Poster
Rep: Reputation: 0
im sorry to bother with this im sure its basic as hell but im still stuck
at this point

-rwxrwxr-x 1 crunchyuncle users 841489 Mar 17 02:51 el.x86.linux.bin
linux:/home/crunchyuncle/EL # ./el.x86.linux.bin
./el.x86.linux.bin: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory
linux:/home/crunchyuncle/EL #
-----------------------------------------------------------
at the website for this particular game "Eternal Lands" it says to chmod to 775 which i tried that but i still get this same error.
here:
----------------------------------------------------------
To play in Linux:
Download the zip file, and unzip it.
cd to the directory where you installed it.
chmod to 775 and execute el.x86.linux.bin
edit el.ini and change datadir to where you unzip everything
Also, the zip file has no base directory, so you should unzip it in a new directory you create.

thanks for the help

Last edited by crunchyuncle; 03-17-2006 at 11:44 AM.
 
Old 03-18-2006, 09:52 AM   #6
crunchyuncle
LQ Newbie
 
Registered: Mar 2006
Location: NE Iowa
Distribution: SuSE 10.0
Posts: 16

Original Poster
Rep: Reputation: 0
anyone?

anyone?
 
Old 03-18-2006, 12:32 PM   #7
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,108

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
You need the libopenal.so.0 shared library; this has nothing to do with file permissions. The game's Web site should tell you where to get all of the dependencies needed to run the game. Alternatively, a Google search for libopenal should prove fruitful.
 
Old 03-18-2006, 11:16 PM   #8
crunchyuncle
LQ Newbie
 
Registered: Mar 2006
Location: NE Iowa
Distribution: SuSE 10.0
Posts: 16

Original Poster
Rep: Reputation: 0
thank you everyone for helping out a newbie works great and in the process ivve learned quite a lot...Linux and lovin it

thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems setting user permissions kyro_02 Linux - Newbie 4 07-08-2005 11:27 AM
Setting user permissions PeteWieland Linux - Newbie 2 04-16-2005 06:35 AM
Setting User Permissions macgyver007 Linux - Newbie 3 04-12-2005 10:21 AM
Setting user network permissions beforemath Linux - Networking 2 02-28-2005 03:53 PM
Setting default permissions for user loadedmind Slackware 3 11-05-2003 03:24 PM


All times are GMT -5. The time now is 10:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration