LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2010, 05:50 AM   #1
digity
Member
 
Registered: Apr 2005
Posts: 105

Rep: Reputation: 15
rsync still copies with ignore existing option


I'm trying to set up rsync to only copy new songs from my computer to another. I'm using the "--ignore-existing" argument, but it appears to copy all files anyway. The client (source) is Windows 7 64-bit running DeltaCopy Client and the server (destination) is Synology DS410 (running rsyncd). Here is the syntax:

rsync.exe -v -rlt -z --chmod=a=rw,Da+x -u --ignore-existing "/cygdrive/M/media library/music/" "digity@blahblah.dyndns.org::music/"

Any ideas?
 
Old 07-01-2010, 07:46 AM   #2
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 41
Read the manual part which explains the times where -u works, and don't.

It has to do with several factors.. one is time-stamps.. if the files on your source disk are newer than the destination.. then they will keep copying them over and over.

Also if you are using two different file systems.. I *think* this can be a factor, because rsync will consider this a change, even tho time-stamps are the same, or older on the source.

If you have file systems that have switches which shut off the updating of time stamps to the file system (ie. noatime in linux).. then this might be an issue tooo.

Changes of sizes (which can show up over different file systems I believe) will also FORCE a copy being made.

Again, this is spelled out in the rsync manual.. worth a good read if you want to reallly utilize this awesome program


Lettuce know..
 
Old 07-14-2010, 01:12 PM   #3
digity
Member
 
Registered: Apr 2005
Posts: 105

Original Poster
Rep: Reputation: 15
I found the solution in adding the --size-only option. Now only the new stuff is copied over.

And yes it is two different file systems, NTFS (client) to EXT3 (server).

Thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] what is the rsync flag to ignore permissions replica88 Linux - Newbie 3 04-21-2015 10:51 PM
Rsync copies my SSH key over when I don't want it to Raze Programming 3 07-27-2009 12:40 AM
rsync with -d option tate_harmann Linux - Newbie 2 09-20-2006 01:58 PM
rsync ignore files Eazy-Snatch Linux - Networking 3 09-18-2006 06:45 AM
cp command: except or ignore option? C-RAF. Programming 9 02-28-2006 03:23 AM


All times are GMT -5. The time now is 05:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration