Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-31-2005, 08:44 AM   #1
LQ Newbie
Registered: Oct 2005
Posts: 5

Rep: Reputation: 0
Resolution -> Xorg.conf & Sound

Hey, I've just installed Linux Kubuntu on my computer and it's working OK, except for two things:[list][*]Even though I have a 17" screen (which, in Windows at least, let's me have a 1280x1024 screen resolution), the max. resolution I can get is 1024x786, and it's pretty annoying. I've been told that it could be due to a badly configured Xorg.conf file, so I ran the "sudo dpkg-reconfigure xserver-xorg" command, and a wizard popped up.

As you may have already guessed, I'm a total Linux Newbie (although willing to learn :P) and I don't understand exactly what I have to type in each time it asks me for info. I'll post exactly what I typed in, to see if I'm doing anything wrong (I'm obviously doing something wrong, because I can't get 1280x1024 resolution):
  1. I let it auto-detect my video card.
  2. I select "nv" when it asks me to select the "desired X server driver" (I'm assuming "nv" = nVidia; I have an nVidia 6600GT)
  3. I leave the identifier for my video card the way it is (it automatically says "NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]")
  4. When it asks for my Video Card's bus identifier, I have no idea what to write, so I leave it as it is (PCI:1:0:0 - Maybe this is incorrect, because my video card is AGP )
  5. When it asks for the ammount of memory my card has, I type in 131072 (it's a 128MB video card, and it wants it in KB --> 1024 * 128 = 131072).
  6. User kernel framebuffer device interface? -> Yes
  7. (Some stuff about the keyboard, which I understand)
  8. I write "xorg" as the XKB rule, as it says "If you don't know what rule set to use, enter "Xorg""
  9. I type 'pc104' as my keyboard model.
  10. I have no idea what to type in when it asks for a "Keyboard variant", so I leave it blank.
  11. Again, I have no idea what "Keyboard Options" to type in, so I leave it blank.
  12. (Some stuff about the mouse, which I understand)
  13. It then asks me which modules I want Xorg to load up by default. All of the modules are selected, except for "dbe", "record", and "v4l", and since I don't know what this does, I leave it as it is.
  14. I say "yes" when it asks me if I want it to... "Write default Files section to configuration file?", because before, it says "In most cases, you should enable it."
  15. Same as before, but with the "DRI Section"...
  16. When it asks for my monitor's name, I just leave it at "Generic Monitor", because I'm not sure exactly what model I have.
  17. When it asks for which Video Modes I want it to use, I select 1280x1024 and everything below it.
  18. I then choose "1280x1024 @ 60Hz" as my default Video Mode, and a color depth of 24 bits.[/list=1]

    After doing all of that, and restarting the X server (control + alt + backspace), it freezes at "Checking battery..." I'm not using a laptop, so I have no idea why it's even checking something it doesn't have I have to load up the recovery console and replace Xorg.conf with the backup I made before modfiying it.
  19. The other problem is that I can't hear anything: no music, videos, or even system sounds. If I click on System > KInfoCenter > Sound, I get
    Sound Driver: 3.8.1a-980706 (ALSA v1.0.9 emulation code)
    Kernel: Linux kubuntu 2.6.12-9.686 # Mon Oct 10 13:25:32 BST 2005 i686
    Config Options: 0
    Installed drivers:
    Type 10: ALSA emulation
    Card config:
    Intel ICH5 with AD1980 at 0xfebffa00, irq17
    Audio devices:
    0: Intel ICH5 (DUPLEX)
    Synth devices: NOT ENABLED IN CONFIG
    Midi devices: NOT ENABLED IN CONFIG
    7: system timer
    0: Analog Devices AD1980

BTW, here's the content of my xorg.conf, if it's of any help:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"es"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"

Section "Device"
	Identifier	"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Option		"RenderAccel"		"true"
	Option		"NvAGP"			"1"

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	28-51
	VertRefresh	43-60

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

Section "DRI"
	Mode	0666
Hope this thread isn't too long, and I hope someone can help this

Old 10-31-2005, 02:12 PM   #2
Senior Member
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
you installed nvidia driver from nvidia website ? or trying to use just what came with ?
Old 10-31-2005, 02:29 PM   #3
LQ Newbie
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Originally posted by foo_bar_foo
you installed nvidia driver from nvidia website ? or trying to use just what came with ?
I downloaded the nVidia drivers using the Unofficial Ubuntu Guide ( I finally managed to fix it... doing what this website said.

Although I've still got the sound problem
Old 10-31-2005, 08:40 PM   #4
LQ Guru
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
Make a backup of your xorg.conf file, then edit the original.

in the "Display" section add the resolution you want.. you can also remove the ones you will never use (like 640x480 for instance...)

SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
also look up the specs of your monitor and verify the horizontal and vertical range settings are correct...
I'm guessing you have a LCD Display from the small ranges listed here, but since you didn't specify type manuafacturer or model I can only guess..

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60

as for sound check to make sure the output is not muted in the mixer.. seems to be a common problem for people. everythig actually works but the volume control is muted..

check for a mixer application, or open a shell and type alsamixer after verifying the settings you can run speaker-test which will play what sounds like static .. Ctrl-c to stop the test.

Last edited by farslayer; 10-31-2005 at 08:48 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf and 1440x900 resolution mrsolo Linux - Software 6 11-15-2010 10:32 PM
X11 Resolution - not read from xorg.conf felixc Linux - Newbie 3 10-24-2005 04:27 PM
xorg.conf - video && touchpad problem * (Dell C640) Pear-i Linux - Laptop and Netbook 2 07-27-2005 08:12 AM
Getting the resolution right in xorg.conf slimjim Linux - Software 1 04-26-2005 01:03 PM
Changing resolution in FC3. Which xorg.conf line do I edit? ColKurtz Linux - Newbie 2 02-18-2005 12:09 PM

All times are GMT -5. The time now is 05:52 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration