LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-22-2014, 03:03 AM   #1
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Rep: Reputation: 0
Reduce the timeout in dual boot to micro seconds


Hey friends,

I have just installed Linux Mint 17 Qiana Cinnamon on my Samsung RV509, i3, 3GB RAM, 300GB HDD Laptop. I have two OSs in dual boot. The other one is Windows 7. Now I would like to reduce the timeout in dual boot options to micro seconds or less than a second, may be 1/10th of a second, during startup. I have LM as the default OS.

Can this be done?

I would greatly appreciate any help in this regard.

Thank you.
 
Old 08-22-2014, 08:14 AM   #2
jross
Member
 
Registered: Apr 2014
Distribution: Xubuntu 14.04
Posts: 164

Rep: Reputation: Disabled
Wouldn't that just mean you will no longer have a "dual boot"? Is your real goal to get rid of windows 7?
 
Old 08-22-2014, 08:51 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,603
Blog Entries: 25

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Member Response

Hi,

Welcome to LQ!

For /etc/lilo.conf;
Quote:
From 'man lilo.conf';
timeout=<tsecs>
sets a timeout (in tenths of a second) for keyboard input at the boot: prompt. "timeout" only has meaning if "prompt" is mentioned. If no
key is pressed for the specified time, the default image is automatically booted. The default timeout is infinite.
http://linuxpoison.blogspot.com/2010...t-timeout.html
For 'grub' timeout;
Quote:
From http://linuxpoison.blogspot.com/2010...t-timeout.html

Change default Timeout:

To change the default timeout option in GRUB 2, you just need to change the GRUB_TIMEOUT parameter. The value of this parameter is in sec, change this value as per your requirement.
Hope this helps.
Have fun & enjoy!
 
1 members found this post helpful.
Old 08-31-2014, 02:13 AM   #4
Anil Kagi
Member
 
Registered: Aug 2014
Distribution: LinuxMint 17 Qiana Cinnamon
Posts: 149

Original Poster
Rep: Reputation: 0
Thank you Gary,

and sorry for the delay in replying.

Thanks for the painstaking answer and the links.

Regards

Anil
 
Old 08-31-2014, 10:03 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,603
Blog Entries: 25

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Member Response

Hi,

Glad to be of help. Happy that you were able to use the information.
 
Old 08-31-2014, 10:33 AM   #6
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
I'm with jross on this,

Sure, you can set 'time out'to low or none as detailed by Onebuck.

The question is why?, a few seconds to confirm OS/ kernel version is, in my opinion a small price to pay for flexability.

Edit: if you are 'there' just hit enter

If things go 'screwy' you will be thankful of that 5sec delay

Last edited by Firerat; 08-31-2014 at 10:38 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_fcgid: read data timeout in 31 seconds invader7 Debian 0 11-04-2011 05:55 PM
SSH timeout after few seconds vikas027 Linux - Server 16 07-10-2011 01:15 AM
Micro-lags/freezes every ~3 seconds under Xubuntu 8.04 nanawel Linux - General 4 09-29-2008 04:25 PM
XP/Fedora dual boot timeout alaneh Fedora 2 08-08-2005 10:17 PM
Eggdrop has quit (Ping timeout: 181 seconds) Kroppus Linux - Software 0 11-13-2003 12:32 PM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration