LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2004, 04:41 PM   #1
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Rep: Reputation: 15
radeon 9600 help


if I restart the now the kde interface will not start and i will have to reinstall again because i do not know enough to use just command prompts.
im going to leave this post up a while before i restart so reply quick please.

the following is where i am stuck.
how can i fix this?????????


x1-6-00-07-e9-6d-24-c0:/lib/modules/fglrx/build_mod # ./make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.5-7.104-default/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
x1-6-00-07-e9-6d-24-c0:/lib/modules/fglrx/build_mod # uname -r
2.6.5-7.104-default
x1-6-00-07-e9-6d-24-c0:/lib/modules/fglrx/build_mod #
 
Old 08-21-2004, 05:33 PM   #2
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
Well according to the output you post, it seems like you are either running an X version higher than 4.3.0., or you are running a 2.6.xx kernel. In order for the driver to work you have to have X version 4.3.0. you should verify if you have that version. If you have the 2.6.xx kernel there is a patch for the driver to make it work. If you have the 2.6.xx kernel i'd recommendo you browse the slackware forum there's a post on how to patch the driver to make it work under the kernel 2.6.xx
 
Old 08-24-2004, 03:00 PM   #3
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
I have learned a liitle more since my last post.

lok at the following and see if you can help

[root@x1-6-00-07-e9-6d-24-c0 Kevin]# rpm -Uh --force fglrx-4.3.0-3.11.1.i386.rpm
########################################### [100%]
########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
make.sh: line 630: /proc/version: Permission denied
make.sh: line 631: /proc/version: Permission denied
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.27-1ark/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings

so i do this

[root@x1-6-00-07-e9-6d-24-c0 fglrx]# ls
build_mod fglrx.2.4.20-28.9bigmem.o fglrx.2.4.27-1ark.o
fglrx.2.4.18-17.7.x.o fglrx.2.4.20-28.9.o fglrx.o
fglrx.2.4.18-17.8.0.o fglrx.2.4.20-28.9smp.o make.2.4.27-1ark.log
fglrx.2.4.20-28.8bigmem.o fglrx.2.4.20-8bigmem.o make_install.sh
fglrx.2.4.20-28.8.o fglrx.2.4.20-8.o
fglrx.2.4.20-28.8smp.o fglrx.2.4.20-8smp.o
[root@x1-6-00-07-e9-6d-24-c0 fglrx]# ./make_install.sh
bash: ./make_install.sh: Permission denied
[root@x1-6-00-07-e9-6d-24-c0 fglrx]# chmod a+x make_install.sh
[root@x1-6-00-07-e9-6d-24-c0 fglrx]# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.27-1ark/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings
done.


still will not work. any help??????????
 
Old 08-24-2004, 05:30 PM   #4
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
This is supposed to be like that because the driver has not GPL license.
Quote:
Warning: loading /lib/modules/2.4.27-1ark/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings
My advice is to do the following in text mode, if you are running slackware just do
Code:
init 3
, if you are running other distro do cat /etc/inittab to see what level is text mode in your distro.
After you get that you are supposed to do
Code:
fglrxconfig
.

But i'll recommend you to first check if the modules is loaded by following these steps:
First check if the module is actually loaded:
Code:
lsmod | grep fglrx
after you do that if you get an output like
Code:
fglrx somenumber
then you can do
Code:
fglrxconfig
if you don't get anything after doing lsmod | grep fglrx then do this
Code:
 modprobe fglrx
, check now if the modules is being loaded by doing lsmod | grep fglrx.

Once the modules is being loaded you can go ahead and do
Code:
fglrxconfig
. Just answer the questions according to you hardware. I'd took the default for most of the questions except for two . I said yes to the question where it ask you something about xfree86-dga, and to the question that ask you something about agp-gart.

After you finish answering the questions just save everything, if you are running xfree86 you will want to say yes to the last question, if your distro is running xorg then you will have to say no to the last question for a couple of times until it ask you where you want to save the settings, then just say /etc/X11/xorg.conf. Then again if you are running xfree86 just say yes to the last question.

AFter you've done with that just go back to multiuser mode, in slackware
Code:
 init 4
or just do
Code:
startx
Once you are back in kde or whichever gui u use, do
Code:
fglrxinfo
to check that the driver has been loaded
the output should be something like this.

Code:
 display :0.0 screen: 0
 OpenGL vendor string: ATI Technologies Inc.
 OpenGL render string: RADEON your card number
 OpenGL version string: the version of your driver.
if it still says mesa where it should say ATI technologies, the ati driver did not load. By the way which distro are you using. I hope this helps because i think i might have confuse you with all this.
 
Old 08-24-2004, 05:34 PM   #5
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
I forgot to ask, before you do all of the above, make sure you go to /lib/modules/fglrx/build_mod
and check first if the make.sh file is executable, if it's not make it executable, then do
Code:
./make.sh
after that go to /lib/modules/fglrx and also make sure the make_install.sh is executable if it's not make it executable then do
Code:
./make_install.sh
after doing this you can follow the steps i posted above, if you have already done this then just follow the steps from the post above. HOpe this helps
 
Old 08-25-2004, 09:32 AM   #6
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
I am using ark which is based on redhat. I will do the steps exactly as you say and get back to you


I have been able to configure it using fglrxconfig before. It let me go thru the steps but when I reeboot i get a error " ????x respawning to fast." not sure if that is the exact error, it flashes to fast for me to read. After that i can only go to the command line. if i type kde then everything just goes and i have to reinstall.
I guess another question i should ask is how to back up my display drivers if i go thru the steps above and still do not get the drivers to install correctly?

i really appreciate all the help.
 
Old 08-25-2004, 09:38 AM   #7
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
one more thing I wanted to point out.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
make.sh: line 630: /proc/version: Permission denied
make.sh: line 631: /proc/version: Permission denied

I am getting "permission denied" error every time i try. Could this be the problem or part of it????
 
Old 08-25-2004, 03:48 PM   #8
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
to back up your display just do mv /etc/X11/xfree86.conf /etx/X11/xfree86.conf.old
If anything goes wrong just mv the .old file to .conf file.

I'm not sure why you are getting that error, you are doing that as root right?, other thing you could do is open the make.sh fiel and check lines 630 and 631, and see what it says. YOu might want to post that as well, if all keeps on going like this why don't you just download the driver again and try again.
 
Old 08-25-2004, 04:48 PM   #9
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
thanx for the response. i will let you know what happens
 
Old 08-26-2004, 09:53 PM   #10
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
It is still not loading. I hope this is all the info you need.



==============================================================================
Finish
==============================================================================

I am going to write the XF86Config-4 file now. Make sure you don't accidently
overwrite a previously configured one.

Shall I write it to '/etc/X11/XF86Config-4' (y/n)? y






Probing PCI bus for a supported graphics device...
found: RV350 (AP)
PCI bus slot: PCI:1:0:0

entering the detected PCI bus slot into the XF86Config-4 file.





File has been written. Take a look at it before running 'startx'.
Note that the XF86Config-4 file must be in one of the directories
searched by the server (e.g. /etc/X11) in order to be used.

Within the server press ctrl, alt and 'Num+' or 'Num-' simultaneously
to cycle video resolutions.
Pressing ctrl, alt and backspace simultaneously immediately exits the server.
Use these keys if the monitor doesn't sync for a particular mode.

For further configuration, refer to /usr/X11R6/lib/X11/doc/README.Config.

[root@x1-6-00-07-e9-6d-24-c0 kevin]# startx
hostname: Unknown host


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to xfree86@xfree86.org.

[root@x1-6-00-07-e9-6d-24-c0 kevin]# cd ..
[root@x1-6-00-07-e9-6d-24-c0 home]# cd ..
[root@x1-6-00-07-e9-6d-24-c0 /]# cd temp
bash: cd: temp: No such file or directory
[root@x1-6-00-07-e9-6d-24-c0 /]# ls
bin boot dev etc home initrd lib lost+found mnt opt proc root sbin sys tmp usr var wallpapers
[root@x1-6-00-07-e9-6d-24-c0 /]# cd tmp
[root@x1-6-00-07-e9-6d-24-c0 tmp]# ls
anacronGTTJRp anacronqYAnne install-grub.sh kde-kevin ksocket-kevin mcop-kevin unpack.log
anacronHvR8A2 grub-install install-initrd.sh kde-root ksocket-root mcop-root
[root@x1-6-00-07-e9-6d-24-c0 tmp]# cd cd /kevin
bash: cd: cd: No such file or directory
[root@x1-6-00-07-e9-6d-24-c0 tmp]# cd ..
[root@x1-6-00-07-e9-6d-24-c0 /]# cd kevin
bash: cd: kevin: No such file or directory
[root@x1-6-00-07-e9-6d-24-c0 /]# ls
bin boot dev etc home initrd lib lost+found mnt opt proc root sbin sys tmp usr var wallpapers
[root@x1-6-00-07-e9-6d-24-c0 /]# cd home
[root@x1-6-00-07-e9-6d-24-c0 home]# cd kevin
[root@x1-6-00-07-e9-6d-24-c0 kevin]# startx
hostname: Unknown host


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to xfree86@xfree86.org.

[root@x1-6-00-07-e9-6d-24-c0 kevin]# fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".

help!!!
I know if i restart i will have to start all over.
 
Old 08-27-2004, 06:17 PM   #11
itywygms
Member
 
Registered: Aug 2004
Posts: 51

Original Poster
Rep: Reputation: 15
i copied xfree86.conf file back to original location and still had to reinstall.
oh well. everytime i try i learn more
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
TV-Out with Radeon 9600 NullDevice23 Linux - Hardware 2 05-23-2005 10:01 AM
What's going on with my Radeon 9600 (and everything else)?!??! zach124 Linux - Hardware 1 08-18-2004 12:28 PM
Radeon 9600 jjreid Linux - Software 0 03-23-2004 07:05 PM
radeon 9600 se Motown Mandriva 0 03-20-2004 09:34 AM
Radeon 9600 xt casimir Linux - Hardware 1 02-08-2004 05:08 AM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration