LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-02-2014, 01:05 PM   #1
nprakash
LQ Newbie
 
Registered: Oct 2014
Posts: 3

Rep: Reputation: Disabled
Unhappy pyuic-command-is-not-working-in-centos-7


Its been crazy last 3 days.
I have installed Pyqt 4.10.4 and QT 5.3.2 in my Centos 7.0 OS. I have also installed QT Designer and have created a layout (.ui format). I want to change it to .py form using pyuic4/pyuic/pyrcc any of them. When I use "pyuic inputfile.ui -o outputfile.py" then bash says pyuic command not found... Why am I getting this inspite of having QT and Pyqt and how can I rectify it. Please suggest
 
Old 10-02-2014, 05:58 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Welcome to LQ.
Quote:
... 3 days
CentOS 7 → 3 minutes : # yum install PyQt4-devel
.. you will get PyQt4-devel-4.10.1, providing /usr/bin/pyuic4

The libraries etc. mentioned in your post :
Looks like "all manual build".
Please try searching for pyuic5 / pyuic4, e.g. with $ which pyuic5 ,
$ which pyuic4 , .. or just type $ pyuic<TAB> , or $ pyu<TAB> .
May be ``bash completion´´ will fill out the word ending.


-

Last edited by knudfl; 10-03-2014 at 11:50 AM.
 
1 members found this post helpful.
Old 10-03-2014, 10:15 AM   #3
nprakash
LQ Newbie
 
Registered: Oct 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Smile Thank you so much

You are just awesome. Why the hell I did not ask this earlier.. Thanks friend
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic package not working from xcfe yet working from the command line onerous Debian 8 11-15-2012 04:40 PM
CentOS: command not linked/working Zeno McDohl Linux - Newbie 3 01-06-2012 01:56 PM
CentOS 5.3 - PHP - ftp_connect working command line only Orayi Red Hat 7 12-22-2009 11:06 AM
Python and pyuic jokar.mohsen Linux - Software 0 08-12-2009 10:38 AM
./configure command isn't working in command line jumpmansbro Linux - Newbie 20 01-22-2009 09:29 PM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration