LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2004, 07:15 AM   #1
mindfestival
Member
 
Registered: Mar 2004
Posts: 47

Rep: Reputation: 15
Lightbulb proftpd problems


hello all. i am fairly new to linux and have just finished getting proftpd set up on my rh9 machine, and am trying to get anonymous going. I have defined a home directory for the user 'ftp' and set
'chmod 750 /home/ftp' (the anon. directory). My /etc/proftpd.conf has anonymous access like this:
user: ftp
group: ftp.

My problem is that i get this:

Connected to localhost (127.0.0.1).
220 ProFTPD 1.2.9 Server (ProFTPD Default Installation) [athome]
Name (localhost:root): anonymous
331 Anonymous login ok, send your complete email address as your password.
Password:
530-Unable to set anonymous privileges.
530 Login incorrect.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.

Maybe the 'user' ftp is not in the 'group' ftp? i believe i can check this buy reading my passwd file, but it gives me a number rather than a name, an i cant decipher it hehe!
As you can probably tell, i have much learning to do, and any help would be greatly apprieciated.

-mindfestival
 
Old 08-16-2004, 07:27 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
can you post your proftpd config file?
 
Old 08-16-2004, 07:33 AM   #3
mindfestival
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User nobody
Group ftp

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite on
</Directory>

# A basic anonymous configuration, no upload directories. If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
User ftp
Group ftp

# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>
(END)
 
Old 08-16-2004, 07:43 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try adding
Code:
AuthPAM Off
RequireValidShell Off

Last edited by Demonbane; 08-16-2004 at 07:45 AM.
 
Old 08-16-2004, 07:56 AM   #5
mindfestival
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
hrrm no that didnt fix it im afraid, i am still getting the same message letter for letter, if its any conselation... i think it is to do with my user - group settings.
 
Old 08-16-2004, 08:08 AM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
check the /etc/passwd file and make sure the home directory for the ftp user is set to /home/ftp, not something like /var/ftp
 
Old 08-16-2004, 08:13 AM   #7
mindfestival
Member
 
Registered: Mar 2004
Posts: 47

Original Poster
Rep: Reputation: 15
Ok yes it was incorrect. it reads
ftp:x:14:50:FTP User:/var/ftp:/sbin/nologin.
What do i issue to change a users default directory?
 
Old 08-16-2004, 08:18 AM   #8
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
edit it manually or
Code:
usermod -d /home/ftp ftp
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd problems soulwatcher1974 Linux - Software 4 06-04-2005 11:01 PM
proFTPd problems wiky007 Linux - General 11 09-22-2004 12:49 PM
Problems with proftpd alitrix Linux - Software 0 12-13-2003 04:58 AM
Problems with Proftpd Inexactitude Linux - Networking 4 11-21-2003 07:12 PM
ProFTPD problems Corellon Linux - Newbie 23 06-07-2003 11:11 AM


All times are GMT -5. The time now is 07:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration