LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2011, 09:20 AM   #1
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Rep: Reputation: 0
Problems with Sound, ALSA


I have recently configured with alsaconf my sound card. When I run
$ aplay /usr/share/sounds/alsa/test.wav

I hear a sound in the speakers

If I run
$ cat /proc/asound/card0/pcm0c/info
card: 0
device: 0
subdevice: 0
stream: CAPTURE
id: ALC889 Analog
name: ALC889 Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1

I believe my card is well configured in the system, but in Gnome when I run gnome-volume-control it appears an error:
No volume control GStreamer plugins and/or devices found.

All I can say is that time ago I used to use OSS on my system. I want to use ALSA because it works better with an app of mine, so I need this back.

Any ideas why this might happen with gnome volume control?

BTW In the upper corner, it appears the simbol of the speaker with a cross, and If I go to Preferences, nothing happens.

$ gnome-volume-control --version
GNOME gnome-volume-control 2.22.0

Also maybe this output can help somehow:

$ gnome-volume-control --gst-debug-level=2
0:00:00.046728275 15570 0x9440b0 WARN oss4 oss4-property-probe.c:356:gst_oss4_property_probe_get_values:<oss4mixer0> Can't open file descriptor to probe available devices: No such file or directory
0:00:00.050289327 15570 0x9440b0 WARN oss gstossmixerelement.c:223:gst_oss_mixer_element_change_state:<ossmixerelement0> error: Failed to open oss mixer device '/dev/mixer'

Looks like is trying to open an OSS mixer, but don't know how to change this.

Last edited by SirLouen; 01-18-2011 at 09:25 AM.
 
Old 01-18-2011, 09:59 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
What distro are you using?

Do you have Pulse Audio running on the system?
 
Old 01-19-2011, 06:27 AM   #3
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri View Post
What distro are you using?

Do you have Pulse Audio running on the system?
I'm using Debian Lenny

And there is no Pulse Audio server running

Regards
 
Old 01-19-2011, 10:59 AM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
Have a look through this link -->http://www.linuxquestions.org/questi...13-1-a-827194/

Different distro, same sound chip.

It seems ALC889 has had some problems, I did a google search and got a ton of hits.
 
Old 01-21-2011, 08:11 AM   #5
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
As my user I ran:

#sudo usermod -a -G audio sirlouen

now

sirlouen@host#aplay-l
aplay: device_list:207: no soundcards found...

sirlouen@host# sudo aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC889 Analog [ALC889 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889 Digital [ALC889 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

About sounds:

sirlouen@host$ aplay /usr/share/sounds/alsa/test.wav
ALSA lib confmisc.c:768: (parse_card) cannot find card '0'
ALSA lib conf.c:4154: (_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392: (snd_func_concat) error evaluating strings
ALSA lib conf.c:4154: (_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251: (snd_func_refer) error evaluating name
ALSA lib conf.c:4154: (_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4633: (snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211: (snd_pcm_open_noupdate) Unknown PCM default
aplay: main:564: audio open error: No such file or directory

sirlouen@host$ sudo aplay /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Stereo

Maybe this have something to do with users but the command usermod as I did, has not done the trick
 
Old 01-24-2011, 04:09 AM   #6
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
I've been wandering around this problem with no solution this weekend any ideas?
 
Old 01-24-2011, 10:00 AM   #7
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
In order to help further, I need you to post some information about your hardware, and modules you may have loaded.

Open a konsole, and run the command 'lsmod | grep snd' and post the results. Run the command without the quotes, just what is between them.

Please also run the command 'lspci | grep Audio' and post the results. If this command doesn't produce output, just run 'lspci' and post that.
 
Old 01-25-2011, 08:51 AM   #8
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
here are the results:

# lsmod | grep snd

snd_hda_codec_atihdmi 2743 1
snd_hda_codec_realtek 283384 1
snd_hda_intel 24063 0
snd_hda_codec 89442 3 snd_hda_codec_atihdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 5938 1 snd_hda_codec
snd_pcm 78583 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 5324 0
snd_rawmidi 19434 1 snd_seq_midi
snd_seq_midi_event 6667 1 snd_seq_midi
snd_seq 50220 2 snd_seq_midi,snd_seq_midi_event
snd_timer 20169 2 snd_pcm,snd_seq
snd_seq_device 6250 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 55825 9 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
soundcore 1208 1 snd
snd_page_alloc 7772 2 snd_hda_intel,snd_pcm

# lspci | grep Audio

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
01:00.1 Audio device: ATI Technologies Inc RV710/730

Regards!
 
Old 01-25-2011, 10:06 AM   #9
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
Have you ever had sound working on this system with your linux install?

You have two sound cards installed. That is a problem. I have read many threads with the user trying to add a second card, then nothing works.

Have you got one of the cards ( chipsets ) disabled in the BIOS? Do you have your speakers connected to the card you want working? You have two, where are you connected? Which card do you want to work?

To add to the confusion, I can not figure out exactly what driver you should have loaded. By looking at the Alsa pages, it appears snd_hda_intel supports both cards; but I'm not positive.

Is this a desktop or a laptop? Make and model please.
 
Old 01-26-2011, 12:08 PM   #10
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by camorri View Post
Have you ever had sound working on this system with your linux install?

You have two sound cards installed. That is a problem. I have read many threads with the user trying to add a second card, then nothing works.

Have you got one of the cards ( chipsets ) disabled in the BIOS? Do you have your speakers connected to the card you want working? You have two, where are you connected? Which card do you want to work?
01:00.1 Audio device: ATI Technologies Inc RV710/730

Quote:
Originally Posted by camorri View Post
To add to the confusion, I can not figure out exactly what driver you should have loaded. By looking at the Alsa pages, it appears snd_hda_intel supports both cards; but I'm not positive.

Is this a desktop or a laptop? Make and model please.
Actually as I said before, I can make as root, play sounds just by running aplay. When I want to hear something (a file) I download it, login as root and run aplay "file.wav" and I can hear it in the speakers. But I can use it as a real time sound speaker/mic like with skype or something.

Is not a laptop, is a desktop made by me. It has an Gigabyte GA-P55A-UD3 Mother Board. Also I have an ATI HD4350 video card, maybe it also has a sound chipset or something because it is named the same as the Audio Device (RV710)

# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]

With Alsa conf ran as root, I select the audio device "ATI Technologies Inc RV710/730" and in the end it runs a test with aplay and I hear the sound, whilst with the other audio device, in the play test, I can't hear anything. That's why I'm sticking with the RV710 sound card.

Thanks for the patience and help
 
Old 01-26-2011, 01:45 PM   #11
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,105

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
Well, that clears up a few things. This sounds more like a permission issue. If you can play a .wav file as root, but not as a regular user, there are some things to look into.

I have never run Debain, I do run ubuntu, a Deb derivative. Do you have an audio group? If yes, add your regular user to that group, and try aplay some.wav file.

If that still fails, you may need to look at the ownership of the /dev/audio . On my system /dev/audio is root:audio. However, distros do this differently, so I can't tell you for sure which file in /dev to look at. That said, look at /dev/snd/ directory. There should be files there for each part of the sound system.

Hope this helps.
 
Old 01-27-2011, 09:06 AM   #12
SirLouen
LQ Newbie
 
Registered: Aug 2010
Posts: 12

Original Poster
Rep: Reputation: 0
I did actually solve it here

http://www.linuxquestions.org/questi...5/#post4232923
but since I have not reboot my computer until now changes did not took effect!

Thanks for the assistance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems with ALSA Mellar Slackware 7 10-17-2010 12:43 PM
Sound problems alsa 1.9 d_dallis_gr Linux - Software 2 06-20-2005 06:58 AM
Alsa sound problems mario8723 Ubuntu 1 03-19-2005 07:07 PM
Alsa Sound Problems (I think) Maestro485 Linux - Newbie 7 04-14-2004 08:52 PM
Problems with OSS while trying to avoid problems in ALSA (scratchy sound) GT_Onizuka Linux - General 1 02-06-2004 12:55 AM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration