LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2004, 01:30 AM   #1
godzilla_roar20
Member
 
Registered: Jul 2004
Location: PA
Distribution: Fedora Core 1, Knoppix
Posts: 74

Rep: Reputation: 15
Unhappy Problems with GRUB on dells


Alot of my friends have dell 4550's and all tried putting fedora on them. After Instalation, when they reboot, All it does is say GRUB in white text on a black screen. NOTHING ELSE HAPPENS! This also happens on my computer. What is wront, and how to I fix it?
 
Old 07-21-2004, 04:43 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
When you hit return at GRUB, does it prompt GRUB again? If yes, type the following
(you can use the TAB key to autofill or give you more options)
root (hd<hit tab and select the appropriate number>,<tab to select the boot partition>
kernel /boot/vmlinuz root=/dev/hdxn (where x is the drive and n is the partition where / resides)
initrd /boot/<hit tab> to select the appropriate image file (ending in img)
boot
----------------

Method 2
You may try this

boot from your installation CD
at the boot: prompt, type linux rescue
Follow the instructions -- You will be instructed that the rescued partitions are at /mnt/sysimage
At the initial hash (#) prompt, type chroot /mnt/sysimage
at this hash (#) prompt, type grub-install /dev/hdx where x is the drive that has the MBR.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo... grub problems... "/boot/grub/stage1" exists... no halo14 Gentoo 5 02-06-2011 04:50 PM
Grub Error 17: Cannot mount selected partition and other Grub problems Sebastian Naitsabes Linux - General 1 07-05-2005 08:33 AM
Dells and Linux Dragokatzov Linux - Hardware 7 05-08-2005 07:19 PM
Thin client rollout on Various Dells basemodel Slackware 27 01-16-2004 03:24 PM
Grub problems Evolution8 Slackware 3 07-06-2003 11:00 AM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration