LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2014, 10:20 AM   #1
l0pht
Member
 
Registered: Sep 2008
Posts: 79

Rep: Reputation: 1
problem with new epel


Hi
when i want to update new epel i get this error:
Quote:
warning: epel-release-6-8.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-8.noarch
rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-8.noarch

please help me.
 
Old 06-03-2014, 10:48 AM   #2
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
The fact that the installation has errors suggests that you may be installing epel meant for one distribution onto another.

Will you please post the contents of /etc/redhat-release?
 
Old 06-03-2014, 11:58 AM   #3
l0pht
Member
 
Registered: Sep 2008
Posts: 79

Original Poster
Rep: Reputation: 1
of course

CentOS release 5.7 (Final)
 
Old 06-03-2014, 12:14 PM   #4
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
The one you are installing is meant for RHEL/CentOS 6.x.

Please try this instead:
rpm -Uvh http://mirror.symnds.com/distributio...5-4.noarch.rpm

Note: You may need to remove the existing EPEL repo if you run into issues.

Also, if possible without affecting production, you may want to upgrade your distribution to 5.10. There are many security vulnerabilities that are addressed through updates.
 
Old 06-04-2014, 02:02 AM   #5
l0pht
Member
 
Registered: Sep 2008
Posts: 79

Original Poster
Rep: Reputation: 1
thanks
finally i install remi repository but when it download packages and want to install says:

Transaction Check Error:
file /etc/my.cnf from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/armscii8.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/ascii.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1256.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1257.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp850.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp852.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp866.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/dec8.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/geostd8.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/greek.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/hebrew.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/hp8.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/keybcs2.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/koi8r.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/koi8u.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/latin1.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/latin2.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/latin5.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/latin7.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/macce.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/macroman.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/swe7.xml from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/bin/msql2mysql from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/bin/mysql_find_rows from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/bin/mysqlaccess from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/my_print_defaults.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysql.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysql_config.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysql_find_rows.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysql_waitpid.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysqlaccess.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysqladmin.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysqldump.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/man/man1/mysqlshow.1.gz from install of mysql-5.5.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386


please help me. it tired me so.
 
Old 06-04-2014, 06:20 AM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
You really don't want to add extra repos if you can afford it.
If you do have to, EPEL is the most appropriate/best.

What you must do before(!) adding non-Centos repos is install/setup http://wiki.centos.org/PackageManagement/Yum/Priorities.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
EPEL Repo problem newbie14 Linux - Server 26 03-14-2013 01:38 PM
Epel 6 jokar.mohsen Linux - Software 1 03-10-2012 03:47 AM
EPEL REPO - Problem agriz Linux - Server 2 12-01-2011 05:59 AM
EPEL jokar.mohsen Linux - Software 1 04-26-2011 07:32 AM
epel repo centos 5.4 fernfrancis Linux - Newbie 12 10-02-2010 06:36 PM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration