LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-29-2009, 01:43 AM   #1
dynamiteboy
Member
 
Registered: Aug 2009
Posts: 42

Rep: Reputation: 17
problem with "./configure --prefix=usr/local/apache --enable-module=so"


Using Ubuntu 9.04 on a partitioned hard drive installation.

I'm trying to set up Apache as part of a LAMP setup. My book told me to use that command as part of compilation process, right before "make", but when I run that command, I get this:

Warning: Your 'echo' command is slightly broken.
It interprets escape sequences per default. We already
tried 'echo -E' but had no real success. If errors occur
please set the SEO variable in 'configure' manually to
the required 'echo' options, i.e. those which force your
'echo' to not interpret escape sequences per default.
using installation path layout: Apache (config.layout)

Obviously, I'm a Linux newbie. I have not a clue what all that means, so any advice will be greatly appreciated.

Thanks!

db

P.S.- Is my Apache corrupted?

db
 
Old 08-29-2009, 02:17 AM   #2
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 661

Rep: Reputation: 66
Try following
root#rm -f /bin/sh
root#ln -s /bin/bash /bin/sh

thnks
 
Old 08-29-2009, 02:23 AM   #3
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 252Reputation: 252Reputation: 252
Apache Compiles

Greetingz!

I'll take a stab at this one;

Quote:
Warning: Your 'echo' command is slightly broken.
It interprets escape sequences per default. We already
tried 'echo -E' but had no real success. If errors occur
please set the SEO variable in 'configure' manually to
the required 'echo' options, i.e. those which force your
'echo' to not interpret escape sequences per default.
using installation path layout: Apache (config.layout)

Escape-Sequence: basically, you can give certain commands "special characters" if you want to do things like display color, or in some cases call variables. In this case the "echo" command (which just outputs whatever you give it to STDOUT) that is available on your system doesn't act the way that the ./configure script would like.
Normally this isn't a big deal, as most project's ./configure scripts are rather robust (heck, Apache will compile on almost anything).

Quote:
P.S.- Is my Apache corrupted?
No, as long as you downloaded the file from Apache, and verified either the MD5 or the SHA-1 sum, you should be good.
(To do that, run md5sum -b filename.of.the.tar.gz.you.downloaded and verify the alphanumeric string it gives you with the MD5 listed on the website for the download).

Either way, you can typically disregard little things like the "echo" error and continue along with your build process. It's typically not a show-stopper.

Hope this helps!
 
Old 08-29-2009, 02:26 AM   #4
dynamiteboy
Member
 
Registered: Aug 2009
Posts: 42

Original Poster
Rep: Reputation: 17
You're my hero.

What did all that do, and what do those commands mean?

Thanks,

db

Last edited by dynamiteboy; 08-29-2009 at 02:33 AM.
 
Old 08-29-2009, 02:35 AM   #5
xeleema
Member
 
Registered: Aug 2005
Location: D.i.t.h.o, Texas
Distribution: Slackware 13.x, rhel3/5, Solaris 8-10(sparc), HP-UX 11.x (pa-risc)
Posts: 987
Blog Entries: 4

Rep: Reputation: 252Reputation: 252Reputation: 252
Do *NOT* do that.

Quote:
Try following
root#rm -f /bin/sh
root#ln -s /bin/bash /bin/sh
I would strongly advise against doing that. The problem the Original Poster is having is not related to a shell call, in most Linux flavors, "echo" is a binary living in /usr/bin or /bin.

If you're unable to continue your Apache build, you may want to check both /bin/sh and /bin/bash. You might find out that "sh" is just a symbolic link to "bash".

You can find out for sure if they're separate files by running the following command;
"ls -l /bin/bash /bin/sh"
(Note: that's the "ls" command, not the "ln" command used to create links)

-r-xr-xr-x 1 root bin 735572 Jan 22 2005 /bin/bash
-r-xr-xr-x 1 root root 95468 May 9 2008 /bin/sh


If you see something like this, then they're separate files, and you should rename "/bin/sh" (with the "mv" command) before creating the link (but don't just outright delete the "/bin/sh" binary, you can't undo that, and it might cause problems down the road.)

If instead you see something like this, then "/bin/sh" is already a link to "/bin/bash";

-r-xr-xr-x 1 root bin 732556 May 2 2007 /bin/bash
lrwxrwxrwx 1 root root 13 Nov 24 2008 /bin/sh -> /bin/bash



P.S: Exercise extreme caution when using the "rm" command. I understand that you're new to Linux, so take heed and read the man page for that command. There's no Recycle Bin on the command-line!
 
Old 08-29-2009, 02:50 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Ok but apache is available in the repositories that you can use for install.
 
Old 08-29-2009, 02:52 AM   #7
dynamiteboy
Member
 
Registered: Aug 2009
Posts: 42

Original Poster
Rep: Reputation: 17
Xeleema-

i saw your post after I had done the other. No worries though, it definitely fixed the problem. I don't appear to have any problems yet, but I'm not exactly an expert. I did look up those commands in the manual, not that I understood them too well, but hey, it's all a learning curve. The good news is, if all else fails, this is a throwaway system anyhow, rescued from the trash heap. So if I irrevocably screw it up, no huge loss. Of course, if I can avoid that, so much the better. Anyhow, thanks to both of you. Problem solved, for now at least.

db
 
Old 08-29-2009, 02:55 AM   #8
dynamiteboy
Member
 
Registered: Aug 2009
Posts: 42

Original Poster
Rep: Reputation: 17
linuxlover-

What does that mean? Are you talking about part of the Ubuntu install? I'm not familiar with "repositories", at least in this context.

db
 
Old 08-29-2009, 03:05 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Apache is available with package manager, Synaptic, which is in the menus System > Administration
 
Old 08-29-2009, 03:07 AM   #10
dynamiteboy
Member
 
Registered: Aug 2009
Posts: 42

Original Poster
Rep: Reputation: 17
Now they tell me.

Oh, well, I got the thing installed, anyway.

Thanks, though, that's good information to have.

db
 
Old 08-29-2009, 03:22 AM   #11
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
Not just that apache but there more than 20000 packages available. You can find most of the popular packages there, may be more than what you will ever use in your life. Instead of compiling from the source use the Synaptic. It will download and install not only the package you want but all the dependencies as well. That will save a lot of time for you and put more time in productive work.
 
Old 08-29-2009, 05:33 AM   #12
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,563
Blog Entries: 29

Rep: Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179
Quote:
Originally Posted by vishesh View Post
Try following
root#rm -f /bin/sh
root#ln -s /bin/bash /bin/sh

thnks
Please don't, not without some solid research into what breakage this might cause. And then use
Code:
mv /bi/sh /bin/sh.original
so you can back out the change.
 
Old 09-15-2009, 12:42 PM   #13
conosoar
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
You should be able to just run:

"bash ./configure --prefix=usr/local/apache --enable-module=so"

Worked for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP5 + Apache 2.x : /usr/local/modules/libphp5.so: Undefined symbol "apr_table_set" Ephracis Linux - Software 6 10-01-2010 01:26 PM
./configure --prefix=/usr [default: /usr/local] why??? stevesk Slackware 14 07-03-2006 07:28 AM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 05:51 AM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-29-2004 12:33 AM
MySQL setup stops at command "./configure --prefix=/usr/local/mysql" k41184 Linux - Software 1 05-20-2004 03:44 PM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration