LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-27-2010, 05:10 AM   #1
rajanmaharjan
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Rep: Reputation: 0
problem while installing virtual box in centos 5.4


hi to all!

I was trying to install VM virtual box from the rpm file . It was then that i got following errors:

warning: only V3 signatures can be verified, skipping V4 signature
error: Failed dependencies:
libcrypto.so.6 is needed by VirtualBox-3.2-3.2.4_62467_rhel5-1.i386
libpng12.so.0(PNG12_0) is needed by VirtualBox-3.2-3.2.4_62467_rhel5-1.i386
libpython2.4.so.1.0 is needed by VirtualBox-3.2-3.2.4_62467_rhel5-1.i386
python(abi) = 2.4 is needed by VirtualBox-3.2-3.2.4_62467_rhel5-1.i386
rtld(GNU_HASH) is needed by VirtualBox-3.2-3.2.4_62467_rhel5-1.i386

please i'd be glad if you provide me with some help

-
regards
rajanmaharjan
 
Old 06-27-2010, 07:50 AM   #2
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
Try running this:
Quote:
yum localinstall VirtualBox*rpm
 
Old 06-28-2010, 12:30 AM   #3
rajanmaharjan
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Original Poster
Rep: Reputation: 0
not much help!

dear carltm

i tried the command you suggested but it didn't affect anyhow.

But i found out that the centos in which i am trying to install VB is 4.8 and the rpm: VirtualBox-3.2-3.2.4_62467_rhel5-1.i386.rpm is dor centos 5..
May be thats why i am having problem ?


have you anything else for sugggestion.
 
Old 06-28-2010, 01:48 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
update the cent 4 install to the current 5.5

or build vb from source

installing a 5 rpm on 4 will not work.
 
Old 06-28-2010, 06:18 AM   #5
rajanmaharjan
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Original Poster
Rep: Reputation: 0
thanks

all,
the problem i was having about virtual box is solved after i installed rpm for 4.

is it possible to upgrade centos 4 to centos 5 without affecting the operation of my server.


thanks.
 
Old 06-28-2010, 09:11 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by rajanmaharjan View Post
all,
the problem i was having about virtual box is solved after i installed rpm for 4.

is it possible to upgrade centos 4 to centos 5 without affecting the operation of my server.
thanks.
You're going to have some sort of outage during an upgrade, no matter how you do it, on ANY operating system. It's far better to do a clean installation, than run an upgrade, though.
 
Old 06-28-2010, 02:09 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
also upgrading between major versions is not supported, never has
fresh install
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem installing Virtual Box 3.1.4 in SLackware 12.1 acmal Linux - Virtualization and Cloud 3 04-11-2010 12:19 PM
Installing Virtual Box on slack 64 g_paschoal Linux - Software 1 10-15-2009 05:24 PM
Virtual Box and loading CentOS 5.3 enzymezero Linux - Newbie 3 08-25-2009 09:58 AM
Help with VIrtual Box installing windows xp edgartech Ubuntu 6 05-23-2008 04:52 PM
Installing XP on Virtual Box in Ubuntu 7.04 Neo-Leper Linux - Software 6 07-23-2007 02:56 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration