LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2004, 01:50 AM   #1
orifux
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Rep: Reputation: 0
Angry Problem to boot w2k from GRUB


Hi,

I have problem to boot W2K, here is the details :

I have two hard disk:

on Hard disk_1 (as master), i installed FEDORA 3 (GRUB install on MBR)

on Hard disk_2 (as slave) there is W2K installation.


When i try to boot my W2K i get this message :

rootnoverify (hd1,0)
chainloader +1

and nothing happened

this is my grub.conf

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.9-1.681_FC3)
root (hd0,0)
kernel /vmlinuz-2.6.9-1.681_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-1.681_FC3.img
title Fedora Core (2.6.9-1.667)
root (hd0,0)
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-1.667.img
title Windows
rootnoverify (hd1,0)
chainloader +1


What to do ?

Last edited by orifux; 12-02-2004 at 11:11 AM.
 
Old 12-02-2004, 03:08 AM   #2
shmonkey
Member
 
Registered: Nov 2004
Location: UK
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
post you grub config file so people can check it out (it's either menu.1st or grub.conf).
 
Old 12-02-2004, 01:21 PM   #3
AngryLlama
Member
 
Registered: Sep 2004
Location: /dev/urandom
Distribution: Gentoo
Posts: 171

Rep: Reputation: 30
I'm having the same problem, except I have both OSes installed one harddrive. You can see my post here. I have no idea why this is happening. Your problem is exactly like mine though, it just sits there, no NTLDR message or anything.

However, since you are using two drives, there is something you can try:

title Windows
map (hd0,hd1)
map (hd1,hd0)
rootnoverify (hd1,0)
chainloader +1
makeactive

the map lines logically swap the two harddrives, so Windows will think it is on the master drive. The makeactive is there since I've always seen it on Window boots. If that doesn't work, you may want to add the line 'boot' after makeactive.

Llama
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
did GRUB wipe my W2K partition; won't boot? graywave Linux - General 7 11-26-2005 08:55 PM
Number of cylinders, w2k,fc3 boot problem xmlmagician Linux - Newbie 2 01-20-2005 03:37 AM
Problem to boot W2K from GRUB orifux Linux - Newbie 2 12-02-2004 12:19 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 09:13 PM
Installed W2k, then RH 7.3 but grub now can't see W2K ericcarlson Linux - General 5 07-17-2002 06:08 PM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration